1 Ответить Последний ответ: 17.07.2014 22:36, автор: rp0428

    SQL developer application log

    user5347559

      I do have problem with loading extension into SQL developer.

      It there any kind of log to get an error while loading extensions?

      In case when such as log exists is possible to get more details. (Is there any log level?)

       

       

      I try already following log:

      ---- begin ---

      1) Close SQL Developer, and open the following file for editing

      {sqldeveloper installation path}/sqldeveloper/bin/sqldeveloper.conf

       

      2) comment out the line containing "sqldeveloper-nondebug.conf" and add the following two lines:

       

      IncludeConfFile sqldeveloper-debug.conf

      AddVMOption -Dcom.methodr.loglevel=all

       

      3) save file, and restart SQL Developer. You should now see a "Logging Page" tab.

      --- end ---

       

      But there's just something like this:

      INFO6480org.netbeans.core.netigso.Netigsobundle com.tomecode.showme.password.sqldeveloper@1.0.0 resolved

      when it's successful and otherwise I can't get any sufficient error.

       

      There's also in windows log on path C:\Users\<UserName>\AppData\Roaming\SQL Developer\sqlDevelope.log\SQLDeveloper_<DateTime>.log

      the content is almost same in the "Logging Page" tab.

       

      Is there any other way how to get error while loading extensions?

        • 1. Re: SQL developer application log
          I do have problem with loading extension into SQL developer.

          Ok - so are you going to tell us what 'problem' you are having?

           

          Please post ALL of the info needed to help you:

          1. full version of sql developer

          2. platform os and version

          3. extension name and version

           

          Did you download the extension from this link?

          http://show-me-password.tomecode.com/

           

          Are you using the extension version appropriate for your sql developer version? Sql Developer 4+ uses the JDeveloper 12.1.3 framework and that framework changed significantly from previous versions. In particular NONE of the extensions written for the previous version will work with sql dev 4; the developers need to modify the extension for the new framework.