1 Reply Latest reply: Jul 26, 2014 4:59 AM by Chrisjenkins-Oracle RSS

    Cant start active standby pair Timesten

    2720929

      Hi all

       

      Im installing Timestan with Oracce RAC and i have a issue:

      My Timesten version:

      ./ttisql --version

      TimesTen Release 11.2.2.7.4

       

      My Clusterware grid version:

      11.2.0.1.0

       

      My cluster.oracle.ini

      [rac3]

      MasterHosts=db5-pri,db6-pri

      CacheConnect=Y

       

      My sys.odbc.ini

       

      [ODBC Data Sources]

      rac3=TimesTen 11.2.2 Driver

       

      [rac3]

      Driver=/home/timesten/TimesTen/tt1122/lib/libtten.so

      DataStore=/home/timesten/TimesTen/tt1122/info/rac3

      LogDir=/home/timesten/TimesTen/tt1122/info/

      DatabaseCharacterSet=US7ASCII

      PermSize=40

      TempSize=32

      OracleNetServiceName=rac3

       

      I start Daemon ok with no error but when init, it s a an issue:

      ./ttCWAdmin -init

      Oracle Clusterware home = /u01/app/11.2.0/grid, hosts = db5-pri,db6-pri

      ====================================================================

       

       

      All Agents are already ONLINE

      ====================================================================

      ====================================================================

       

       

      All Daemons are already ONLINE

      ====================================================================

      (ttCWAdmin:) crsctl.c(17294): TT48004: clssnsqanum returned clscrsretBADRESNAME: "Invalid resource name", failed with status = 12.

       

      After that, i connect to DNS rac3, it ok

       

      ./ttIsql rac3

       

      Copyright (c) 1996, 2014, Oracle and/or its affiliates. All rights reserved.

      Type ? or "help" for help, type "exit" to quit ttIsql.

       

      connect "DSN=rac3";

      Connection successful: DSN=rac3;UID=timesten;DataStore=/home/timesten/TimesTen/tt1122/info/rac3;DatabaseCharacterSet=US7ASCII;ConnectionCharacterSet=US7ASCII;DRIVER=/home/timesten/TimesTen/tt1122/lib/libtten.so;PermSize=40;TempSize=32;TypeMode=0;OracleNetServiceName=rac3;

      (Default setting AutoCommit=1)

       

      But when i try to creat active-standby pair,have another problem:

      ./ttCWAdmin -create -dsn rac3

      Successful connection with Oracle clusterware stack

      replication DDL = create active standby pair "RAC3" on "db5-pri","RAC3" on "db6-pri" 

       

       

      Enter internal UID with ADMIN privileges: adm

      Enter password for the same UID:

      IMDB Cache is Enabled

      Enter Oracle password for the same UID:

      Enter any phrase for password encryption:

      Uid/Pwd could not be verified on host db5-pri

      ====================================================================

      Error: TimesTen Cluster agent could not successfully verify Oracle password for the OracleNetServiceName rac3.

      ====================================================================

      Uid/Pwd could not be verified on host db6-pri

      ====================================================================

      Error: TimesTen Cluster agent could not successfully verify Oracle password for the OracleNetServiceName rac3.

      ====================================================================

      Error: Failed to create Cluster of an Active Standby pair

       

      What is Oracle pass for the same UID, i tried Oracle user password but not give me the righ answer

       

      Can someone give me  solutions to solve these 2 issues ? Thank you so much!

       

      Best regards,

       

      Trung

        • 1. Re: Cant start active standby pair Timesten
          Chrisjenkins-Oracle

          Please note that only Clusterware 11.2.0.2 and 11.2.0.3 are supported with TimesTen. Clusterware 11.2.0.1 is *not* supported so you need to address that before proceeding any further.

           

          Your problem looks to be that the TT cache userid/password cannot be verified with the backend Oracle database. Have you performed the necessary setup steps in the RAC DB to prepare it for use by TT cache (see TT Cache Admin guide for details)? Have you set the TT cache user and password in the primary TT database (call ttcacheuidpwdset(...,...))?

           

          Chris