1 Reply Latest reply on Jul 31, 2014 3:27 AM by Wang Xin - Oracle

    Primavera - Virtualization


      Hello...wondering if this is at all possible? We are converting our Labs to VMware Horizon View 5.3 and using Unidesk (Layering technology) to virtualize all our applications.


      Current Version: Primavera P6 Release 7.0 SP3


      I am able to create the Layer, but when it's deployed noticed that the 'OracleXETNSListener' service wasn't starting. The issue pointed to the 'Listerner.ora' file and how it referenced the build workstation:



        (SID_LIST =

        (SID_DESC =

        (GLOBAL_DBNAME = XE)

        (ORACLE_HOME = C:\oraclexe\app\oracle\product\10.2.0\server )

        (SID_NAME = XE)


          (SID_DESC =

            (SID_NAME = PLSExtProc)

            (ORACLE_HOME = C:\oraclexe\app\oracle\product\10.2.0\server)

            (PROGRAM = extproc)


          (SID_DESC =

            (SID_NAME = CLRExtProc)

            (ORACLE_HOME = C:\oraclexe\app\oracle\product\10.2.0\server)

            (PROGRAM = extproc)





      LISTENER =


          (DESCRIPTION =


            (ADDRESS = (PROTOCOL = TCP)(HOST = vditest04.test.ca)(PORT = 1521))







      When the host name above was modified the service started to run. I am now trying to connect to a default DB and receiving the following message:


      Is there a way when building the package to set some sort of wildcard for the hostname that every workstation could use?


      When I try connecting to the db I have been receiving the following:


      ORA12545 - Connect failed because target host or object does not exist!


      Thank you



        • 1. Re: Primavera - Virtualization
          Wang Xin - Oracle

          Can you check the content of TNSNAME.ora? which is located at same path with Listerner.ora.

          Ie. Below is my TNSNAME.ora

          XE =TNSNAME.ora

            (DESCRIPTION =

              (ADDRESS = (PROTOCOL = TCP)(HOST = localhost)(PORT = 1521))

              (CONNECT_DATA =

                (SERVER = DEDICATED)

                (SERVICE_NAME = XE)



          Yours should be HOST=vditest04.test.ca, if not please change it.


          After that open a command prompt, enter below

          sqlplus system/<password>@XE


          NOTE: replace the password with the password you set during xe installation.

          If successfully connected, it means your xe is running well.




          Was our answer helpful?


          If so, highlight the information for other Community members by rating it or marking the answer as correct.


          Just hit the “Correct Answer” link on the answer, or rate it by clicking "Helpful Answer" or "Like".