8 Replies Latest reply: Aug 21, 2014 12:29 PM by Todd Little-Oracle RSS

    Compatibility

    Bruno Taboada

      Hi Todd Little-Oracle, how is it going?

       

      I am here again. I came by now to ask one more question but before doing it I will tell you a bit about the project.

       

      I work at a Brazilian company which got a project to migrate an old SOA platform to a brand new one. in addition, the old platform uses oracle tuxedo version 6.0. This project is going to migrate from this old version (6.x.x) to newest version and also we already know that oracle tuxedo 12.1.3 can run on top of Oracle Linux 6.0 (64-bit) on x86-64 and Red Hat Enterprise Linux 6.0 (64-bit) on x86-64. However, we are wondering if Oracle Tuxedo Message Queue  can make it as well? could you tell me if it is able to run on top of those operation systems already mentioned above?

       

      Thank you in advance for your help.

       

      Best regards.

        • 1. Re: Compatibility
          Todd Little-Oracle

          Hi,

           

          Tuxedo Message Queue supported platforms are listed in the Oracle Tuxedo Message Queue Certified Platform Tables.  It is currently certified on Oracle Linux 5.6 and RedHat Enterprise Linux 5.6.  It should run on Oracle Linux 6 or RedHat Enterprise Linux 6, but the certification hasn't been done yet to the best of my knowledge.  If you want to request that certification or find out the schedule for it, please open a support request in My Oracle Support.

           

          Regards,

          Todd Little

          Oracle Tuxedo Chief Architect

           

          PS  There is a white paper describing how to migrate Tuxedo 6.5 applications to the latest version of Tuxedo.

          • 2. Re: Compatibility
            Bruno Taboada

            Thank you for answering my questions. Todd Little-Oracle

            However, another question came through my mind. if we use Oracle Linux 6 or Red Hat Enterprise Linux 6 Oracle would provide support on these Operations system? I mean if we find an error caused by os does oracle company help with it? (patches and so forth?)

            • 3. Re: Compatibility
              Todd Little-Oracle

              Hi,

               

              If it is listed in the Supported Platform Datasheet, absolutely.  If it's not and you need it supported, please submit a support request.  I'll you tell you quite truthfully that we rarely encounter platform version problems and even less often encounter kernel version problems.  Often the decision to support or not support a platform is based upon the platform vendor as we won't support Tuxedo Message Queue (or any other Tuxedo related product) on a platform that is no longer supported by the vendor.

               

              Regards,

              Todd Little

              Oracle Tuxedo Chief Architect

              • 4. Re: Compatibility
                Bruno Taboada

                Thank you very much Todd Little-Oracle for your attention on my questions.

                 

                yes. great. I got you. My company has bought support service from oracle and also tuxedo platform. As soon as we need help for sure we will submit a support request.

                 

                One more question. is here the best communication channel so I can ask you questions and doubts regarding the tuxedo platform and so on?

                I mean.

                whenever a doubt shows up do I have to ask you via this community forum?

                • 5. Re: Compatibility
                  Todd Little-Oracle

                  Hi,

                   

                  This is certainly as a good a place as any to ask questions as others may have similar questions.

                   

                  Regards,

                  Todd Little

                  Oracle Tuxedo Chief Architect

                  • 6. Re: Compatibility
                    Bruno Taboada

                    Thank you very much. I really appreciated.

                    • 7. Re: Compatibility
                      Bruno Taboada

                      Do you have any idea when Oracle tuxedo message queue will be certified for running on Oracle Linux 6.0 Todd Little-Oracle

                      • 8. Re: Compatibility
                        Todd Little-Oracle

                        Hi Bruno,

                         

                        We are planning on releasing a new version of Oracle Tuxedo Message Queue (OTMQ) soon and that version will be certified on Linux 6.x.  Are you thinking of using OTMQ instead of Tuxedo or as an add-on to Tuxedo?

                         

                        Regards,

                        Todd Little

                        Oracle Tuxedo Chief Architect