4 Replies Latest reply: Aug 12, 2014 8:25 AM by 2716335 RSS

    Ideas how to fix OCI Error 6,500

    2716335

      I'm attempted to setup to and Amazon RDS using these instructions

      Appendix: Using Oracle GoldenGate with Amazon RDS - Amazon Relational Database Service

       

      When I get to REGISTER the extract, I get this error message.

       

      ERROR: Cannot register or unregister EXTRACT IDEXT2 because of the following SQL error: OCI Error 6,550.

       

       

      On a different help site, it was suggested that DBMS_GOLDENGATE_AUTH.GRANT_ADMIN_PRIVILEGE wasn't executed, but I did like this.

       

      EXEC DBMS_GOLDENGATE_AUTH.GRANT_ADMIN_PRIVILEGE (grantee=>'myGGUserName',privilege_type=>'capture',grant_select_privileges=>true, do_grants=>TRUE);

       

      myGGUserName has full admin rights (for now while we try to setup on a TEST instance)

       

      I can't find anything else about this error code or this issue.  Any ideas?

      Thanks!

      -John V

        • 1. Re: Ideas how to fix OCI Error 6,500
          ORASCN

          Hi John,

           

          What is the GoldenGate version you are using? Please recheck whether you have given the privileges properly for the user myGGUserName.

           

          Execute it as the below as 'SYS' user and retry to register the Extract again.,

           

          EXEC DBMS_GOLDENGATE_AUTH.GRANT_ADMIN_PRIVILEGE ('myGGUserName');


          Regards,

          Veera

          • 2. Re: Ideas how to fix OCI Error 6,500
            2716335

            Thank you for the reply Veera!

            I tried the GRANT again with no joy, same error message. I believe I have the latest version here is the output of my 'versions' command.

             

            Operating System:

            Version 6.2 (Build 9,200: )

            Database:

            Oracle Database 11g Release 11.2.0.4.0 - 64bit Production

            PL/SQL Release 11.2.0.4.0 - Production

            CORE    11.2.0.4.0      Production

            TNS for Linux: Version 11.2.0.4.0 - Production

            NLSRTL Version 11.2.0.4.0 - Production

             

            I found this query last week that looks like it might be relevant.

                 select * from sys.goldengate$_privileges;

            the (non-NULL) results are:

            USERNAME: myGGUserName

            PRIVILEGE_TYPE: 3

            PRIVILEGE_LEVEL: 1

            CREATE_TIME: 6/20/2014  -- this is how long we've been trying to get this working

            ALLDBS: 0

             

            Any other logs to check?  Nothing for this is coming up in \ggserr.log.

            • 3. Re: Ideas how to fix OCI Error 6,500
              ORASCN

              Hi John,

               

               

              1. I had asked for GoldenGate software version you are using and not the Oracle Version? Please provide me the GoldenGate Version you are using.

               

              2. You have mentioned that, you have given full admin rights to the myGGUserName. What privileges have u given to the user? Is that a DBA Privilege? If no, please try granting DBA privileges to the user myGGUserName.

               

              Whether the privileges were granted before creating the Extract or After Creating the extract? If it is After Creating the Extract, then please drop or delete the extract. Logout from the GGSCI prompt and execute the below statement,

               

              EXEC DBMS_GOLDENGATE_AUTH.GRANT_ADMIN_PRIVILEGE( -

              grantee => 'myGGUserName', -

              privilege_type => 'capture', grant_select_privileges=> true, do_grants => TRUE);

               

              After this, login to the GG prompt and create the Extract and try to Register it.

               

              GGSCI> DBLOGIN USERID myGGUserName, PASSWORD <password>

              GGSCI> REGISTER EXTRACT IDEXT2 DATABASE

               

              3. Since you are using the Oracle Database 11.2.0.4.0, We have unique parameter for GoldenGate in introduced in this version. Please make sure that you have edited this parameter,

              ENABLE_GOLDENGATE_REPLICATION=true

               

               

              Regards,

              Veera

              • 4. Re: Ideas how to fix OCI Error 6,500
                2716335

                I was working with my OGG trainer on this as well. We tried many different things, poured over the documentation to make sure we didn't miss something and still came up empty. For now, I've opened up an SR now.  When I get it working, I'll update this thread for anyone else looking for a solution.

                 

                We checked permissions and roles and anything else he could think of. 

                 

                Thanks for your help Veera!

                -John V