1 Reply Latest reply: Aug 5, 2014 11:19 AM by user7039445 RSS

    PolicySet Invalid: WSM-02557 (Error when try to run a deployed BPEL process)

    user7039445

      Hello All,

       

      I have a BPEL process deployed and it accepts a file which is configured through File Adapter as the input for the process. But whenever the process tries to read the file (the file is places in a physical path within the weblogic server) it throws below error,

       

      PolicySet Invalid: WSM-02557 oracle.wsm.policymanager.accessor.BeanAccessor The documents required to configure the Oracle Web Services Manager runtime have not been retrieved from the Policy

      Manager application (wsm-pm), possibly because the application is not running or has not been deployed in the environment. The query "&(policysets:global/%)(@appliesTo~="SCA-Component()")" is

      queued for later retrieval.



      I'm not quite sure what the error means. I just made sure wsm-pm under Deployments in the weblogic admin console is Active and also under the Data Sources, that the mds-owsm jdbc data source is targeted at the SOA managed server. Here is file adapter details,

       

      <adapter-config name="ReadStagedCsvFile" adapter="File Adapter" wsdlLocation="ReadStagedCsvFile.wsdl" xmlns="http://platform.integration.oracle/blocks/adapter/fw/metadata"> 

        <connection-factory location="eis/FileAdapter" adapterRef=""/>

        <endpoint-activation portType="ReadCsvOperation_ptt" operation="ReadCsvOperation">

          <activation-spec className="oracle.tip.adapter.file.inbound.FileActivationSpec">

            <property name="UseHeaders" value="false"/>

            <property name="PhysicalDirectory" value="/opt/xxxx_bpel/csvupload/stage"/>

            <property name="Recursive" value="false"/>

            <property name="PhysicalArchiveDirectory" value="/opt/xxxx_bpel/csvupload/archive"/>

            <property name="DeleteFile" value="true"/>

            <property name="IncludeFiles" value=".*\.(?i)csv"/>

            <property name="PollingFrequency" value="5"/>

            <property name="MinimumAge" value="60"/>

          </activation-spec>

        </endpoint-activation>

      </adapter-config>

       

      The weblogic server and SOA suite is configured new and this is the first BPEL process which we have deployed and testing. We are not sure if any of the configuration is missing.

      Any help would be greatly appreciated.