0 Replies Latest reply: Aug 5, 2014 6:48 AM by James.Tran RSS

    Why is the initial Payload not fully initialized

    James.Tran

      To create a Task form for an Initiator task, I have the following Payload:

      Capture14.PNG

      My problem is that when I try to generate some input fields (e.g. `receiptNo` from `Base Details`) based on the Payload, the fields are not rendered at all. From Frank Nimphius's answer for the question "ADF Input Text not showing", I found out that my Payload is not fully initialized. As a consequence, the "objects" like `Base Details` are `null`. Hence, as Frank mentioned, on my page, no input fields could be rendered for any attributes coming from `Base Details`.

       

      I tested this theory by using a "Script" activity to set some dummy value for an attribute from `Base Details`. This helped initialize the `Base Details` and thus, all input fields were generated properly. Even though this worked, I believe I must have missed some configuration for Payload auto-initialization. Otherwise, it'd be very troublesome to manually initialize everything.

       

      I also tried to create a "Process Data Object" with "Auto Initialized = true" and then associate this object to the Input of the Initiator task. This doesn't help at all.

       

      I'd be very grateful if someone could show me how I can properly initialize an empty Payload for a Task form .