4 Replies Latest reply: Aug 7, 2014 2:52 PM by Philipp Grigoryev RSS

    Multicast issue?

    Philipp Grigoryev

      Hey guruz,

       

      We set up an OIM cluster with unicast communication. I can see that in Weblogic Admin Console. But at the same time I'm able to see that there is a certain multicast address assigned (but i can't modify it). When I change OIM configuration to a clustered one and also change OIM cache mode to clustered, I get errors in the cluster log that UDP packet can't be sent to a multicast address. I wonder if it's a problem related to Weblogic or OIM?

       

      What would be a good troubleshooting path in my case?

       

      Thank you in advance

        • 1. Re: Multicast issue?
          Luz Mestre-Oracle

          Hi Philipp

          1. Please share the exact error and WLS patches applied

          2. What is the topology used? (How many managed servers?, Do you see any issues using unicast?)

          For troubleshooting, here is a very useful document:

          WebLogic Server (WLS) Multicast Issues Support Pattern (Doc ID 1092037.1)

          Best Regards

          Luz

          • 2. Re: Multicast issue?
            Philipp Grigoryev

            Hi Luz, thank you for the reply...

             

            failed sending message to null (58 bytes)
            java.lang.Exception: dest=/225.66.76.108:45566 (61 bytes)
            at org.jgroups.protocols.UDP._send(UDP.java:212)
            at org.jgroups.protocols.UDP.sendToAllMembers(UDP.java:167)
            at org.jgroups.protocols.TP.doSend(TP.java:1102)
            at org.jgroups.protocols.TP.send(TP.java:1088)
            at org.jgroups.protocols.TP.down(TP.java:907)
            at org.jgroups.protocols.PING.sendMcastDiscoveryRequest(PING.java:276)
            at org.jgroups.protocols.PING.sendGetMembersRequest(PING.java:256)
            at org.jgroups.protocols.Discovery$PingSenderTask$1.run(Discovery.java:396)
            at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:439)
            at java.util.concurrent.FutureTask$Sync.innerRunAndReset(FutureTask.java:317)
            at java.util.concurrent.FutureTask.runAndReset(FutureTask.java:150)

             

            I don't remember patching it at all Only patching IAM suite, it's 11.1.2.1.

            The domain includes 2 OAM, 2 OIM and 2 SOA servers. The problem appears only when I change OIM cache to clustered mode (it's managed by oim-config.xml). AdminServer shows that cluster messaging mode for OIM cluster is unicast.

             

            I was wondering if OIM/WebLogic uses multicast for cache even if it's unicast in a config file for a cluster. I'll have a look at the Doc you mentioned.

             

            Thank you

            Philipp

            • 3. Re: Multicast issue?
              Luz Mestre-Oracle

              HI Philipp

              This does not sound as weblogic issue, as weblogic server classes are not seen in the stack.

              I have found 2 docs in identity management that can help:

              "java.lang.Exception:at org.jgroups.protocols.UDP._send" Error in OIM log (Doc ID 1582765.1)

              OIA cluster nodes fail to start with error : [UDP] failed sending message to null (Doc ID 1601654.1)

              Please give a try, otherwise, you can post again here:

              Identity Management (MOSC)

              I hope this helps

              Best Regards

              Luz

              • 4. Re: Multicast issue?
                Philipp Grigoryev

                Hey Luz,

                 

                Actually you helped a lot. That annoying message has completely gone, thank you!