6 Replies Latest reply on Aug 13, 2014 4:33 PM by Amitt

    issue in creating roles as per jazn-data

    Amitt

      jdev 11.1.1.7

       

      In my application i am creating the roles in jazn-data files. When i run the application, the roles defined in the jazn file are not created automatically in the integrated weblogic.

       

      Whereas, i have different applications in the same workspace, when i run them, the roles defined in their jazn gets created in the weblogic. I can see a tab "deployment" which gets created in the jdev console and can see following console.

       

      09:42:07 AM] Uploading jazn-data users.

      [09:42:07 AM] Updating user "john".

      [09:42:07 AM] Updating user "susan".

      [09:42:07 AM] Updating user "steve".

      [09:42:07 AM] Uploading jazn-data roles.

      [09:42:07 AM] Removing existing group "ERole".

      [09:42:07 AM] Creating group for role "ERole".

      [09:42:07 AM] Adding "susan" to group "ERole".

       

       

      So what is wrong with my application that i am not able to see the roles getting created in weblogic?