4 Replies Latest reply: Aug 18, 2014 5:31 AM by mehzin RSS

    Unable to infer entities using a table

    mehzin

      Hi,

       

      I have the following structure in my data model:

      • Global
        • Entity A
          • Entity B

       

      I am trying to infer Entity B using a rule table. I have defined the relationship(containment) between Entity A & Entity B. This is the rule that I have :

       

      <containment relationship from Entity A to Entity B>
      "ABC"conditions required for "ABC" to exist
      "DEF"conditions required for "DEF" to exist

          

      But when I try this, OPM throws an error saying that I need an "otherwise" condition.

      My understanding is that "otherwise" would be applicable for general rule tables, but is not required when trying to infer instances using a table. Then why do I get this error? Is there any way to fix this ?

        • 1. Re: Unable to infer entities using a table
          Sean Reardon

          This only happens for me if the relationship text you're using isn't actually the correct relationship text - so I would double-check that.

           

          I just tried this myself to double-check (10.4.5) and it works fine for me (I used a basic setup of entity A = "the parent", entity B = "the child" containing relationship text from A to B = "all instances of the child for the parent").

          • 2. Re: Unable to infer entities using a table
            mehzin

            I tried renaming the relationship and then it worked.

            I had initially given the relationship name something like "the parent's child". But that didn't seem to infer. I changed the wording of the relationship to "the parent's children" and this worked.

            I wonder what was wrong with the first name.

            • 3. Re: Unable to infer entities using a table
              Sean Reardon

              If I had to guess (and I'll have to since you can't post your project) I'd say that it was probably a normal quote mark in the relationship definition text and a smart quote in the word document (possibly but unlikely it could have been the other way around).

               

              Since they're different characters the compiler wouldn't recognise them as being the same so different text = no relationship text in conclusion line of table = the error message you saw.

               

              It's one of the reasons why there is the recommendation to remove the automatic smart quotes feature in your word setup (see the help topic on setting up to write rules in Word):

              http://docs.oracle.com/html/E54499_01/toc.htm#Writing rules/Write_rules_in_Word.htm

              • 4. Re: Unable to infer entities using a table
                mehzin

                Yeah. It's probably due to something like that.

                 

                Thank though. I have my project running.