3 Replies Latest reply on Sep 10, 2014 5:50 AM by user13325223

    ESM Block Error

    user13325223

      Hi Experts,

       

      I am getting the below ESM Block error while executing a calculation.

      Error: 1012704 Dynamic Calc processor cannot lock more than [5] ESM blocks during the calculation, please increase CalcLockBlock setting and then retry(a small data cache setting could also cause this problem, please check the data cache size setting).

       

      I have made "CALCLOCKBLOCKHIGH 5000" in essbase.cfg and restarted the server. Then I "SET LOCKBLOCK HIGH" in the calc script. My cache settings are as below.

      Index cache setting (KB) 8024

      Index cache current value (KB) 1024

      Data file cache setting (KB) 32768

      Data file cache current value (KB) 0

      Data cache setting (KB) 268352

      Data cache current value (KB) 2882

      But still I am getting the same error. Could anyone please advise?

        • 1. Re: ESM Block Error
          Amit Khanna

          Hi,

           

          There are two possible causes for this error:

          1. Essbase cannot allocate enough blocks from heap to perform the calculation.

          2. The database Block Size is not optimal

           

          Your seeting seems to be fine but I am not sure about your block size. Check this.

          Data Cache Setting:

           

          This is the size of memory that Essbase is allowed to store blocks while doing a dynamic calc process. To find out how many blocks can fit into this cache, take the current setting and divide it by the block size.

           

          Data Cache in K

          ______________ = Number of blocks that can be allocated

           

          Block Size in K

           

          Data Cache needs to be set high enough to hold N blocks (to calculate: N x 2 x blocksize (in K)).

           

          Check for these two settings.

           

          Hope this helps....

           

          Regards,

          Amit Khanna

          • 2. Re: ESM Block Error
            Altair Ribeiro


            Try increase the database properties->Caches->Cache sizes. Try change the default values, cause its always less than you need.

            Regards

            Altair

            • 3. Re: ESM Block Error
              user13325223

              Thanks. I have increased the cache size and the problem is resolved for this time being.