1 Reply Latest reply: Aug 19, 2014 12:07 PM by Wcichy -Oracle RSS

    Solaris 11.2 with Solaris 10 zones on different netmask to global

    markleadbitter-JavaNet

      Hi. I'm fairly new to Solaris 11 (been using 10 for years though) and I'm struggling to achieve the following.

       

      I have 4 NICS on an M3000 which I've paired and using IPMP multipathing on 2 subnets. To simplify, NIC 1 & 2 are on subnet 1 (IPMP0) and NIC 3 & 4 are on subnet 2 (IPMP1). The global zone is using subnet 1 but I need to create zones (branded Solaris 10) using subnet 2.

       

      I've tried various configs but still can't get any zone to work on subnet 2. I also had issues using vnic's and exclusive IP within zones using subnet 1 and the way around this was to use shared-ip which works fine (using subnet 1). I've tried shared-ip and exclusive IP (using vnic) to get zones with subnet 2 working. Basically, when I configure a zone using subnet 2, I can't see anything else on that network and can't even ping the global zone. The zones that I've configured on subnet 1 can communicate with all address on subnet 1 and subnet 2 without issue.

       

      I'm wondering if anyone has any advice on the best way to achieve having zones using a different subnet to the global zone?

       

      Any help would be greatly appreciated.

       

      Cheers,

       

      Mark.