2 Replies Latest reply on Aug 25, 2014 3:33 PM by Solerous

    oc4j standalone 10.1.3.1 stopped working

    Solerous

      I am developing on a Mac running 10.8.5 and our system admins pushed Java 7 onto the machine and now my oc4j app will no longer run.

       

      The java version running is 1.7.0_65.

       

      Is there a way I can get oc4j to run again? I'm running oc4j 10.1.3.1. When I try to launch it from the command line I get the following error:

       

      java -jar oc4j.jar

      14/02/12 10:43:58 Exception in thread "OC4J Launcher" java.lang.NoClassDefFoundError: Could not initialize class com.evermind.server.jms.JMSUtils

      14/02/12 10:43:58 at com.evermind.server.jms.XMLJMSServerConfig.postInit(XMLJMSServerConfig.java:497)

      14/02/12 10:43:58 at com.evermind.xml.XMLConfig.init(XMLConfig.java:206)

      14/02/12 10:43:58 at com.evermind.xml.XMLConfig.init(XMLConfig.java:113)

      14/02/12 10:43:58 at com.evermind.server.jms.XMLJMSServerConfig.init(XMLJMSServerConfig.java:113)

      14/02/12 10:43:58 at com.evermind.server.XMLApplicationServerConfig.getJMSServerConfig(XMLApplicationServerConfig.java:413)

      14/02/12 10:43:58 at com.evermind.server.ApplicationServer.initializeJMS(ApplicationServer.java:2432)

      14/02/12 10:43:58 at com.evermind.server.ApplicationServer.setConfig(ApplicationServer.java:999)

      14/02/12 10:43:58 at com.evermind.server.ApplicationServerLauncher.run(ApplicationServerLauncher.java:131)

      14/02/12 10:43:58 at java.lang.Thread.run(Thread.java:744)