4 Replies Latest reply on Sep 30, 2014 7:02 PM by Andy_CSC

    sqldeveloper-4.0.3.16.84-x64 crashes after splash screen

    Andy_CSC

      I had successfully used my install of sqldeveloper-4.0.3.16.84-x64 last week. Following a windows 7 SP1 enterprise update it crashes after the splash screen and about 10% of the progress bar, before the message saying it's registering extensions. There are no errors or other information messages displayed. I tried running it from a command window producing  no additional information. I have deleted the sqldeveloper directory and downloaded a new zip file and reinstalled. Same behavior.

       

      2014-09-29 12_11_57-Clipboard.jpg

       

      The data modeler works fine.

       

      Any suggestions on how to proceed troubleshooting this issue.

        • 2. Re: sqldeveloper-4.0.3.16.84-x64 crashes after splash screen
          Andy_CSC

          Additional things I've tried,

           

          Downloaded the jdk1.7.0_67 and pointed SQL developer to it.

          Reinstalled SQL developer 4.0.1 and that works fine. Pointed to SD 4.0.3 to the jdk included with that.

           

          Same behaviour, SD 4.0.3 spalsh screen disappears without a trace.

          • 3. Re: sqldeveloper-4.0.3.16.84-x64 crashes after splash screen
            Gary Graham-Oracle

            Hi Andy,

             

            If the problem is not with the SQL Developer installation (what you unzipped into an empty directory) or with finding the JDK or having an inappropriate JDK version, then you should see if your user settings got corrupted or (perhaps) somehow became less accessible than before the Windows 7 SP1 update.  Those settings can be found under C: \Users\<your_username>\Appdata\Roaming\SQL Developer\system4.0.3.16.84.


            Here is a compilation of some standard advice offered many times before on this forum for such situations:

            1. See if the behavior still occurs after deleting the settings then restarting SQL Developer without migrating settings.

                (Be careful to take a backup (export) of your connections first!)

            2. See if (assuming (1) does not help) reinstalling SQL Developer helps.

            If blame cannot be placed on some settings migration / download / installation corruption, then we can begin to consider...

            3. Possible issues with older JDKs.

            4. Possible OutOfMemory issues that may be masked by not running SQL Developer from a command line console.

            5. Some new bug.

            So try (1) and (2) if you haven't already.  Ignore (3) if  you already use jdk7_u51 or higher and are not on a Mac.  Point (4) may be an issue if you are have lots of windows to restore, and haven't upped the Xmx values in the product.conf file -- especially if using a 64-bit JDK.  And for (5), if you have the inclination, see..

            http://www.thatjeffsmith.com/archive/2012/06/how-to-collect-debug-info-for-oracle-sql-developer/

             

            And if you wish to try (1) in a clean "sandbox" unaffected by any existing user settings directories, you can always add a

            AddVMOption -Dide.user.dir=<directory_system4.0.3.16.83_should_go_under>

            line to your sqldeveloper.conf file.

             

            Hope this help,

            Gary

            SQL Developer Team

             

            P.S.:  And keep in mind that "pointing" SQL Developer to a specific JDK in 4.0 and above uses the SetJavaHome in product,conf rather than sqldeveloper.conf      

            1 person found this helpful
            • 4. Re: sqldeveloper-4.0.3.16.84-x64 crashes after splash screen
              Andy_CSC

              Gary,

               

              Thank you, option one worked for me as directed.

               

              Much Appreciated