3 Replies Latest reply on Nov 3, 2014 11:20 AM by ThomasFlecken

    ODI 12c doesn't start up after Linux kernel update

    ThomasFlecken

      Hello everyone,

       

      I am currently having trouble to start up my ODI 12c after I have updated a kernel package and rebooted the machine.

       

      The formerly working configuration was as follows:

      Linux oraclelinux6.localdomain 3.8.13-35.3.4.el6uek.x86_64 #2 SMP Wed Jul 30 00:59:13 PDT 2014 x86_64 x86_64 x86_64 GNU/Linux

      ODI Standalone Edition Version 12.1.3

      Build ODI_12.1.3.0.0_GENERIC_140617.0542

      Java(TM) Platform 1.7.0_67

       

      Then I have updated the package kernel-uek.x86_64, the output of the "yum update" command was as follows:

      sudo yum update kernel-uek.x86_64 -y
      Loaded plugins: refresh-packagekit, security
      Setting up Update Process
      Resolving Dependencies
      --> Running transaction check
      ---> Package kernel-uek.x86_64 0:3.8.13-44.1.1.el6uek will be installed
      --> Processing Dependency: kernel-firmware = 3.8.13-44.1.1.el6uek for package: kernel-uek-3.8.13-44.1.1.el6uek.x86_64
      --> Running transaction check
      ---> Package kernel-uek-firmware.noarch 0:3.8.13-44.1.1.el6uek will be installed
      --> Finished Dependency Resolution
      --> Running transaction check
      ---> Package kernel-uek.x86_64 0:2.6.39-400.17.1.el6uek will be erased
      ---> Package kernel-uek-firmware.noarch 0:2.6.39-400.17.1.el6uek will be erased
      --> Finished Dependency Resolution


      Dependencies Resolved

      ===========================================================================================================================
      Package                                     Arch         Version                       Repository                    Size
      ===========================================================================================================================
      Installing:
      kernel-uek                                  x86_64       3.8.13-44.1.1.el6uek          public_ol6_UEKR3_latest       41 M
      Removing:
      kernel-uek                                  x86_64       2.6.39-400.17.1.el6uek        @ol6_UEK_base                101 M
      kernel-uek-firmware                         noarch       2.6.39-400.17.1.el6uek        @ol6_UEK_base                5.0 M
      Installing for dependencies:
      kernel-uek-firmware                         noarch       3.8.13-44.1.1.el6uek          public_ol6_UEKR3_latest      1.9 M

      Transaction Summary
      ===========================================================================================================================
      Install       2 Package(s)
      Remove        2 Package(s)

      Total download size: 43 M
      Downloading Packages:
      (1/2): kernel-uek-3.8.13-44.1.1.el6uek.x86_64.rpm                                                       |  41 MB     00:55    
      (2/2): kernel-uek-firmware-3.8.13-44.1.1.el6uek.noarch.rpm                                              | 1.9 MB     00:02    
      ---------------------------------------------------------------------------------------------------------------------------
      Total                                                                                          761 kB/s |  43 MB     00:58    
      Running rpm_check_debug
      Running Transaction Test
      Transaction Test Succeeded
      Running Transaction
        Installing : kernel-uek-firmware-3.8.13-44.1.1.el6uek.noarch                                                         1/4
        Installing : kernel-uek-3.8.13-44.1.1.el6uek.x86_64                                                                  2/4
        Cleanup    : kernel-uek-2.6.39-400.17.1.el6uek.x86_64                                                                3/4
        Cleanup    : kernel-uek-firmware-2.6.39-400.17.1.el6uek.noarch                                                       4/4
        Verifying  : kernel-uek-firmware-3.8.13-44.1.1.el6uek.noarch                                                         1/4
        Verifying  : kernel-uek-3.8.13-44.1.1.el6uek.x86_64                                                                  2/4
        Verifying  : kernel-uek-2.6.39-400.17.1.el6uek.x86_64                                                                3/4
        Verifying  : kernel-uek-firmware-2.6.39-400.17.1.el6uek.noarch                                                       4/4


      Removed:
        kernel-uek.x86_64 0:2.6.39-400.17.1.el6uek                                          
        kernel-uek-firmware.noarch 0:2.6.39-400.17.1.el6uek                                         

      Installed:
        kernel-uek.x86_64 0:3.8.13-44.1.1.el6uek                                                                                                                                         

      Dependency Installed:
        kernel-uek-firmware.noarch 0:3.8.13-44.1.1.el6uek                                                                                                                                

      Complete!

       

      The broken configuration after the kernel update is as follows:

      Linux oraclelinux6.localdomain 3.8.13-44.1.1.el6uek.x86_64 #2 SMP Wed Sep 10 06:10:25 PDT 2014 x86_64 x86_64 x86_64 GNU/Linux

      ODI Standalone Edition Version 12.1.3

      Build ODI_12.1.3.0.0_GENERIC_140617.0542

      Java(TM) Platform 1.7.0_67

       

       

      When trying to start ODI-Studio after rebooting the machine, the following Java exception appears:

      Oracle Fusion Data Integrator Studio 12c
      Copyright (c) 1997, 2014, Oracle and/or its affiliates. All rights reserved.

      2014-10-08 15:24:15.025 NOTIFICATION Install area set to file:/oradisk/Oracle/Middleware/Oracle_Home/
      java.lang.RuntimeException: Exception in org.eclipse.osgi.framework.internal.core.SystemBundleActivator.start() of bundle org.eclipse.osgi.
      at org.eclipse.osgi.framework.internal.core.InternalSystemBundle.resume(InternalSystemBundle.java:233)
      at org.eclipse.osgi.framework.internal.core.Framework.launch(Framework.java:657)
      at org.eclipse.osgi.framework.internal.core.EquinoxLauncher.internalInit(EquinoxLauncher.java:69)
      at org.eclipse.osgi.framework.internal.core.EquinoxLauncher.init(EquinoxLauncher.java:37)
      at org.eclipse.osgi.launch.Equinox.init(Equinox.java:178)
      at org.netbeans.modules.netbinox.Netbinox.init(Netbinox.java:84)
      at org.netbeans.core.netigso.Netigso.prepare(Netigso.java:166)
      at org.netbeans.NetigsoHandle.turnOn(NetigsoHandle.java:127)
      at org.netbeans.ModuleManager.enable(ModuleManager.java:1176)
      at org.netbeans.ModuleManager.enable(ModuleManager.java:1011)
      at org.netbeans.core.startup.ModuleList.installNew(ModuleList.java:340)
      at org.netbeans.core.startup.ModuleList.trigger(ModuleList.java:276)
      at org.netbeans.core.startup.ModuleSystem.restore(ModuleSystem.java:301)
      at org.netbeans.core.startup.Main.getModuleSystem(Main.java:181)
      at org.netbeans.core.startup.Main.getModuleSystem(Main.java:150)
      at org.netbeans.core.startup.Main.start(Main.java:307)
      at org.netbeans.core.startup.TopThreadGroup.run(TopThreadGroup.java:123)
      at java.lang.Thread.run(Thread.java:745)
      Caused by: org.osgi.framework.BundleException: Exception in org.eclipse.osgi.framework.internal.core.SystemBundleActivator.start() of bundle org.eclipse.osgi.
      at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:734)
      at org.eclipse.osgi.framework.internal.core.BundleContextImpl.start(BundleContextImpl.java:683)
      at org.eclipse.osgi.framework.internal.core.InternalSystemBundle.resume(InternalSystemBundle.java:225)
      ... 17 more
      Caused by: java.lang.NumberFormatException: For input string: "2.0"
      at java.lang.NumberFormatException.forInputString(NumberFormatException.java:65)
      at java.lang.Integer.parseInt(Integer.java:492)
      at java.lang.Integer.parseInt(Integer.java:527)
      at org.eclipse.osgi.internal.resolver.StateBuilder.createBundleDescription(StateBuilder.java:61)
      at org.eclipse.osgi.internal.resolver.StateObjectFactoryImpl.createBundleDescription(StateObjectFactoryImpl.java:33)
      at org.eclipse.osgi.internal.baseadaptor.BaseStorage.readStateData(BaseStorage.java:845)
      at org.eclipse.osgi.internal.baseadaptor.BaseStorage.getStateManager(BaseStorage.java:791)
      at org.eclipse.osgi.baseadaptor.BaseAdaptor.getPlatformAdmin(BaseAdaptor.java:380)
      at org.eclipse.core.runtime.internal.adaptor.EclipseAdaptorHook.frameworkStart(EclipseAdaptorHook.java:90)
      at org.eclipse.osgi.baseadaptor.BaseAdaptor.frameworkStart(BaseAdaptor.java:253)
      at org.eclipse.osgi.framework.internal.core.SystemBundleActivator.start(SystemBundleActivator.java:60)
      at org.eclipse.osgi.framework.internal.core.BundleContextImpl$1.run(BundleContextImpl.java:711)
      at java.security.AccessController.doPrivileged(Native Method)
      at org.eclipse.osgi.framework.internal.core.BundleContextImpl.startActivator(BundleContextImpl.java:702)
      ... 19 more

       

      I have already tried to re-install ODI 12c 12.1.3 but the error message is still the same. However, running ODI-Studio as super-user (su) does work, even though the whole configuration is lost, e.g. the repository connections.

       

      Sorry for the wall of text, I thought that some details might be helpful. Did anyone ever have a similar problem? Is this a known issue? How can this be solved? I didn't find any information about it all so far.

       

      Thanks in advance and kind regards
      Thomas