11 Replies Latest reply on Nov 3, 2014 4:40 PM by Gary Graham-Oracle

    Connections panel

    user7946489

      Connections view is empty, although I have previously defined several connections.

      I can't create new connections File -> New -> Database connection doesn't work. When I click OK in New Gallery Window nothing happens.

      Sql developer 4.0.2 and 4.0.3 show same behavior.

       

      Regards

        • 1. Re: Connections panel
          thatJeffSmith-Oracle

          Something is borked.

           

          Try this first, Window > Reset Factory Settings

           

          If that doesn't work, find your sql developer preferences directory - where your connections are stored, and delete the connections.xml file.

          • 2. Re: Connections panel
            user7946489

            I tried with Window > Reset Factory Settings, but it didn't work.

            Sql developer 4.0.3 is new instalation, so there is no connections.xml

            Something is seriously wrong, because I don't even see plus sign in connections panel.

            Sql developer doesn't throw any exception, so I don't know where to look for problem.

             

            Regards

            • 3. Re: Connections panel
              thatJeffSmith-Oracle

              >>Connections view is empty, although I have previously defined several connections.

              Which way is it? Did you have connections or not?

               

              In either case, I"m going to recommend you rename the system4.0.3 directory - this will force all of your local settings for the 4.0.3 copy of SQL Dev to be rebuilt from scratch.

              • 4. Re: Connections panel
                user7946489

                Problem is that connections panel is unusable.

                I renamed system4.0.3.16.84 folder, started Sql Developer and choose not to import from previous versions, so it was clean install. But it doesn't work.

                 

                Regards

                 

                SqlDeveloperError.png

                • 5. Re: Connections panel
                  thatJeffSmith-Oracle

                  Can you open the log panel? Do you see any errors in the Logging Page?

                   

                  You can also try running in debug mode and see what exceptions are being raised.

                  • 6. Re: Connections panel
                    Gary Graham-Oracle

                    In such difficult cases, the following (in some combination) have worked in the past...

                    1. Window > Reset Factory Settings

                    2. Deleting/renaming user settings and relaunching the product without user settings migration

                    3. Forcing user settings onto a local disk in environments defaulting to network share desktops

                    4. Downloading and reinstalling the product into an empty directory.  Avoid unzipping into C:\Program Files or an Oracle home.

                    5. Picking the download that bundles the JDK (in 64-bit environments for 4.x & up, or 32-bit environments 3.2 & below).

                    For (3), add this to your sqldeveloper.conf  file: AddVMOption -Dide.user.dir=some_local_directory_to_own_system4.0.3.16.84

                     

                    Hope this helps,

                    Gary

                    • 7. Re: Connections panel
                      user7946489

                      I downloaded sql developer installation which includes JDK, but it also doesn't work (before first run I deleted user settings directory system4.0.3.16.84).

                       

                      There is following warning in logging page:

                      source: org.netbeans.modules.netbinox

                      message: Error creating delegate for C:\Oracle\sqldeveloper403\modules\oracle.ldap_12.1.2\ldapjclnt11.jar because of reference:file:external/oracle.external.ldap.jar

                       

                       

                      After I try to create New Database connection from „New Gallery“, there is following warning and error in log

                       

                      source: oracle.dbtools.raptor.timesten.connection.TTBasicPanel, oracle.dbtools.thirdparty.jdbc.JDBCBasicPanel:

                      message: oracle.ide.natives.registry.RegistryKey.openKey(Native Method)

                       

                      source: oracle.ide.controller.IdeAction

                      message: Error during handleEvent on action 'New Database Connection...' (id=442).

                      None of the attached controllers handled the action.

                      oracle.ide.controller.IdeAction$ControllerDelegatingController@1d5383a9[oracle.ideimpl.controller.ControllersHook$RuleBasedController@1d5383a9[oracle.jdeveloper.db.DatabaseActions][always-enabled]].

                       

                      Regards

                      • 8. Re: Connections panel
                        Gary Graham-Oracle

                        Well, ldapjclnt11.jar does not exist in my 4.0.3 installation's oracle.ldap_12.1.2 folder.  Could it be that you are not unzipping into an empty directory?

                        • 9. Re: Connections panel
                          user7946489

                          This file (ldapjclnt11.jar) also doesn't exist in my installation.

                          I have one more error in log:

                               org.netbeans.core.windows.persistence.PersistenceManager

                               Error in RequestProcessor oracle.ideimpl.usages.UsagesTrackerImpl$3

                           

                          Regards

                          • 10. Re: Connections panel
                            user7946489

                            I edited sqldeveloper.conf, so that SetJavaHome points to 32-bit JDK.

                            Now it works.

                             

                            Thank you

                             

                            Regards

                            • 11. Re: Connections panel
                              Gary Graham-Oracle

                              Glad you got it to work, but it is unclear why since

                              SetJavaHome in sqldeveloper.conf (under installation directory) only controls JDK location in releases prior to 4.x.

                              In 4.x & up, control the JDK location using SetJavaHome in the product.conf under the user settings directory.

                              Thanks,

                              Gary

                              SQL Developer Team