2 Replies Latest reply on Nov 21, 2014 3:10 PM by Jon T.

    SQL Developer settings for Oracle SSO authentication using Kerberos

    Jon T.

      Hello

       

      I am in the process of setting up Oracle SSO authentication using Kerberos but I cannot get it to work with SQL Developer.

       

      From a Windows 7 laptop, I can connect via sqlplus to my database which is running on Red Hat with no problems.  However, via SQL Developer, I create a Connection Name, I set Role to default and Connection Type to Basic

       

       

      It makes no difference if I use the SID or the Service Name.

       

       

      If I check OS Authentication, the ,error is ORA-12639

      If I try Kerberos Authentication, I get Kerberos configuration file krb5.conf not configured.  In sqlnet.ora I have configured the file to be C:\WINDOWS\krb5.conf which does exist.

       

      Can someone advise what I am missing?

        • 1. Re: SQL Developer settings for Oracle SSO authentication using Kerberos
          Gary Graham-Oracle

          According to the online doc, it depends on whether you request the use of a Thin or OCI/Thick JDBC driver.  Just go to Help > Search, key in Kerberos and you will easily find the following info (under SQL Developer Dialog Boxes and Wizards > Create/Edit/Select Database Connection).

           

          For the Thin case, go to Tools > Preferences > Database > Advanced and fill in the blanks in the Kerberos Thin Config section. Click on the Help button for the documentation.  For Thick driver use, configuration is done through sqlnet.ora (sqlnet.authentication_services=(KERBEROS) and related parameters.

           

          And if you read this blog ... The long long route to Kerberos | Laurent Schneider

          you will see a recommendation to use OCI/Thick, or else replace Tab characters with spaces in the krb5.conf file.

           

          Hope this helps,

          Gary

          SQL Developer Team

          • 2. Re: SQL Developer settings for Oracle SSO authentication using Kerberos
            Jon T.

            Hi Gary

             

            Yes that was it.  I went to Tools -> Preferences -> Advanced Parameters and checked the Use OCI/Thick Driver box.  And it works.

             

            Many thanks

             

            BTW, for some reason I though my initial query had got lost somewhere so I resubmitted it - that's the reason for the duplication