2 Replies Latest reply on Nov 24, 2014 7:40 PM by cj

    ORA-03134: Connections to this server version are no longer supported

    M Padmanabhan

      Hi

       

         Oracle Version Details
      1Oracle9i Enterprise Edition Release 9.2.0.1.0 - 64bit Production
      2PL/SQL Release 9.2.0.1.0 - Production
      3"CORE
      9.2.0.1.0Production
      "
      4TNS for Solaris: Version 9.2.0.1.0 - Production
      5NLSRTL Version 9.2.0.1.0 - Production

       

       

      Connection Code :

      ----------------------------------

      <?php

       

      $c = oci_connect("XXXX", "XXXXX", "//192.168.100.95/ora9i");

      $s = oci_parse($c, "select table_name from all_tables where owner = 'HR'");

      $r = oci_execute($s);

       

       

      echo "<table border='1'>\n";

      $ncols = oci_num_fields($s);

      echo "<tr>\n";

      for ($i = 1; $i <= $ncols; ++$i) {

        $colname = oci_field_name($s, $i);

        echo "  <th><b>".htmlentities($colname, ENT_QUOTES)."</b></th>\n";

      }

      echo "</tr>\n";

       

       

      while (($row = oci_fetch_array($s, OCI_ASSOC+OCI_RETURN_NULLS)) != false) {

        echo "<tr>\n";

        foreach ($row as $item) {

        echo "  <td>".($item!==null?htmlentities($item, ENT_QUOTES):" ")."</td>\n";

        }

        echo "</tr>\n";

      }

      echo "</table>\n";

       

      ?>

      Error

      ----------

      Warning: oci_connect(): ORA-03134: Connections to this server version are no longer supported

       

      Please help me regarding this error

       

      Regards

      M.Padmanabhan