1 Reply Latest reply on Dec 5, 2014 2:07 PM by Arvind Srinivasamoorthy-Oracle

    Unable to reach OAuth registration page

    Arvind Srinivasamoorthy-Oracle

      Hi all,

      I'm using the REST Services within Oracle Database Cloud Service.

      When trying to secure my API, I'm hitting a fundamental problem.

       

      I'm unable to reach the /ui/oauth2/clients/ page.

      I get a 404 - page not found

      I'm able to successfully access my API at https://<dbcsinstance-identitydomain>.db.us1.oraclecloudapps.com/apex/hr/departments/

       

      In the OAuth registration URL (which is not working), I've tried the following for the workspace tag

      1. workspace = dbcsinstance-identitydomain. This is the value that I'm seeing the top right corner of my browser window

      So I tried both

      https://<dbcsinstance-identitydomain>/ords/<dbcsinstance-identitydomain>/ui/oauth2/clients/

      https://<dbcsinstance-identitydomain>/apex/<dbcsinstance-identitydomain>/ui/oauth2/clients/

      Gor a 404

       

      2. workspace as the schema name. When I click 'SQL Workshop', I see the schema name to the right end of my screen. It is a 13 character alphanumeric word.

      So I tried both

      https://<dbcsinstance-identitydomain>/ords/CGZCJZPSBNTW9/ui/oauth2/clients/

      https://<dbcsinstance-identitydomain>/apex/CGZCJZPSBNTW9/ui/oauth2/clients/

      Got a 404 again


      I've logged in as myself and have the both RESTful Services and OAuth2 Client Developer assigned to me.


      What am I missing? Why am I not able to access the OAuth registration page?


      Any help will be greatly appreciated.


      Arvind