3 Replies Latest reply on Dec 11, 2014 2:52 PM by Joyce Scapicchio-Oracle

    Error in Cart with Apex application

    evrm

      Hi,

       

      I'm using SQL Developer  Version 4.0.3.16.84 on Mac OS X Yosemite with Java(TM) Platform 1.7.0_71

       

      In the navigator I choose the Application Express node and from there right click on an Apex application.

      In the context menu I select "Add To Cart..." to place the Apex application in the cart.

      After it shows up in the cart I click the "Export Cart" button but then it shows the following error message: "Some objects included in the cart are not available. Review the cart contents."

       

      I have tried this with the user owning the Apex application, SYS and APEX owner but all give the same error.

      What could go wrong here?

       

      Regards,

      Erik-jan

        • 1. Re: Error in Cart with Apex application
          Gary Graham-Oracle

          According to the documentation for that error message (by searching from the Help menu in SQL Developer)...

           

          Cart Error (Objects Not Available)

           

          This box, with the text Some objects included in the cart are not available. Review cart contents., is displayed when you attempt to perform a Cart operation when one or more of the database objects in the selected cart are no longer available. For example, if you attempt to export some tables that include TABLE_1, but TABLE_1 was dropped or the database connection was deleted after that table was added to the cart, then this error box is displayed.

           

          To fix the problem, ensure that you are attempting to perform the Cart operation only on database objects that exist and are available.

           

          If you click the Refresh icon to synchronize the Cart with the existing DB objects, do some objects get disabled?  According to your comment, this should not be permission issue.  If this is indeed a bug, then it is best to create a service request through Oracle Support.

          • 2. Re: Error in Cart with Apex application
            evrm

            Hi Gary,

             

            when I click the Refresh icon I get the same error message.

            In the Cart the Apex application is the only object that gets disabled.

            For this I will create a SR with Oracle Support.

             

            Regards,

            Erik-jan

            • 3. Re: Error in Cart with Apex application
              Joyce Scapicchio-Oracle

              Sorry for the incovenience, but this looks like a bug.  We will file a bug and investigate the problem.

               

              SQLDeveloper Development