2 Replies Latest reply on Dec 15, 2014 10:03 AM by Turloch O'Tierney-Oracle

    I'm having trouble conecting sdsql to my db.

    2813820

      sqlplus works

       

      C:\util\sdsql\sdsql\bin>sqlplus rlockard@pdev

      SQL*Plus: Release 12.1.0.1.0 Production on Fri Dec 12 16:08:08 2014

      Copyright (c) 1982, 2013, Oracle.  All rights reserved.

      Enter password:

      Last Successful login time: Fri Dec 12 2014 15:23:11 -05:00

      Connected to:

      Oracle Database 12c Enterprise Edition Release 12.1.0.2.0 - 64bit Production

      With the Partitioning, OLAP, Advanced Analytics and Real Application Testing opt

      ions

      SQL> exit

       

      but sdsql seems to have issues.

      C:\util\sdsql\sdsql\bin>sdsql rlockard@pdev

      sdsql: Release 4.1.0 Beta on Fri Dec 12 16:08:27 2014

      Copyright (c) 1982, 2014, Oracle.  All rights reserved.

       

      Password? (**********?) ***********

       

      Error starting at line : 0 in command -

      connect rlockard@pdev

      Error report -

      Connection Failed, retry up to 3 times

       

      Any ideas?

        • 1. Re: I'm having trouble conecting sdsql to my db.

          There's a new update that fixes that.

           

          See this other thread from today.

          SDSQL - doesn't work in 4.1 EA

          • 2. Re: I'm having trouble conecting sdsql to my db.
            Turloch O'Tierney-Oracle

            See sqsql gives error 0

             

            Repeated here:

             

            >it works with

             

            >sdsql -oci scott/tiger@db01

             

            It will be particular about the Oracle Client/instant client version .dll or .so

            Try connecting using thin and go ***show jdbc*** the thick/oci/client driver with the same driver number as the thin should work.

             

            If it is not hostname resolution (bug logged)

            i.e. sqlplus rlockard@pdev

            is

            sqlplus rlockard@pdev:1521/pdev

            I would be interested to know what the issue is.

             

            >Hi Laurent,

             

            >If you want to connect non oci the options include:

            >tnsnames.ora alias scott/tiger@db01 where db01 is set on ORACLE_HOME\network\admin\tnsnames.* or TNS_ADMIN\tnsnames.*

            >ezconnect host:port/Servicename scott/tiger@localhost:1521/db01

            >or $TWO_TASK (non windows) or %LOCAL% (windows) [set LOCAL/TWO_TASK] then scott/tiger

            >(We do not currently have HOSTNAME resolution method on thin driver)

            >Logged bug:

            ************************************************

            >Bug 20181262 - HOSTNAME RESOLUTION METHOD FOR THIN NOT AVAILABLE

            ************************************************

            >Turloch,

            >SQLDeveloper team

             

             

            Turloch

            -SQLDeveloper team