2 Replies Latest reply on Dec 17, 2014 9:34 PM by WeatherDave

    Blank Connection dialog box

    WeatherDave

      Good afternoon,

       

      Environment:

      Windows 7 (x64)

      JDK 1.8.0_25

      Working SQl Developer: 4.0.0.12

      Not-Working SQL Developer: 4.1.0.17.29 (also 4.0.1.14, 4.0.2.15, 4.0.3.16)

       

      Old SQL Developer works just fine.  When I try to test out the newer versions, I get a mostly blank Connection dialog box.

      SQLDeveloper_4-1-0_ConnectionIssues.png

      As you can see, I don't get the 'Oracle' tab, Nor do I get Connection type, Role, Hostname, Port, SID, Service name or Authentication Options that I see in 4.0.0.12.

      Lastly, whenever I try starting up a new version, I've tried both migrating the old connections, and starting fresh, with no difference.

       

      Thoughts?

        • 1. Re: Blank Connection dialog box
          thatJeffSmith-Oracle

          4.0.3 exhibits the same behavior?

           

          Please confirm that you extracted the zip into a fresh directory and not on top of some other existing SQLDev copy.

           

          Also, did you says 'yes' or 'no' to importing your preferences from an earlier install/version? 

          • 2. Re: Blank Connection dialog box
            WeatherDave

            Appreciate the reply.

             

            As I was double-checking my work for you, I seem to have come across something.

             

            So, when testing SQL Developer I create a folder in the "C:\Program Files (x86)" for the new SQL Developer testbed.  Something like "SQLDeveloper_v4x".  The version "4.0.0.12" sits in "C:\Program Files (x86)\SQLDeveloper_v400", similarly the new 4.1 version would sit in "C:\Program Files (x86)\SQLDeveloper_v410".

             

            So, to double check my work I

             

            1. Wiped the "SQLDeveloper_v41" folder, and recreated it.  Extracted the archive to it.
            2. Wiped the "41 profile folder" from the AppData location.
            3. Started it up (normal user, not elevated), NOT IMPORTING the previous preferences.  Same blank screen.
            4. Repeated Steps 1,2.
            5. Started it up, IMPORTING the previous preferences.  Same blank screen.

             

            For some strange reason, I tried extracting it to another drive folder "X:\Temp\" and re-ran the 5 steps above (not expecting to see anything different).

            However, in THIS case, both sets of actions resulted in the Connection Window populating properly, and in the case of Importing previous preferences, I DO see the populated data.

             

            Tested it with versions 4.0.1.14; 4.0.2.15;  4.0.3.16.  In all cases, the new location worked perfectly every time.

             

            Thank you for the question, as I would not have thought to retest it under a different drive/folder structure.