3 Replies Latest reply on Jan 29, 2015 6:02 PM by Gianni Ceresa

    Cannot access query_blob field in Usage Tracking

    Jerry S.

      If I create an analysis using the QUERY_BLOB field,

      I get the following error message:

       

      View Display Error

       

      Odbc driver returned an error (SQLExecDirectW).

       

      https://itwoaccept.ais.psu.edu/OBIEE_Skins/sk_iTwoDefault/common/errorminus.gif  Error Details

      Error Codes: OPR4ONWY:U9IM8TAC:OI2DL65P

       

       

      State: HY000. Code: 10058. [NQODBC] [SQL_STATE: HY000] [nQSError: 10058] A general error has occurred. [nQSError: 43113] Message returned from OBIS. [nQSError: 43119] Query Failed: [nQSError: 17001] Oracle Error code: 932, message: ORA-00932: inconsistent datatypes: expected - got CLOB at OCI call OCIStmtExecute. [nQSError: 17010] SQL statement preparation failed. (HY000)

       

       

      SQL Issued: SELECT 0 s_0, "Usage Tracking"."Attributes"."Physical BLOB" s_1, "Usage Tracking"."Date"."Date" s_2 FROM "Usage Tracking" WHERE ("Date"."Date" BETWEEN timestamp '2015-01-27 00:00:00' AND timestamp '2015-01-28 00:00:00') FETCH FIRST 100001 ROWS ONLY

       

        Refresh

       

      I have no trouble accessing the field through SQL Developer, so it appears to contain valid information.

      In the OBIEE physical layer, it shows up as a type LONGVARCHAR, but in Oracle, it shows up as type CLOB.

       

      Can anyone tell me why I cant view this field in an analysis?