12 Replies Latest reply: Mar 2, 2006 3:23 PM by Pweckerl-Oracle RSS

    10g AS Forms & Reports Services 10.1.2.0.2

    Billy
      Hi,

      Can anyone PLEASE help me!!!!!

      I have just installed 10g AS Forms & Reports Services 10.1.2.0.2. I have got the forms to work without any problem.

      How on earth does the Reports Server start?

      I have read that it is an inprocess server in that when I invoke the report from the browser the server should start. This does not work.

      I can go to command prompt and start a standalone server (rwserver =MyRepSrv). But my report does not run on this server either.

      However, if I try and install this server as a service (rwserver -install server=.....) a pop-up box tells me to consult my documentation!!!

      When I try... http://localhost/reports/rwservlet/getserverinfo? i get....

      rep-51002: Bind to report server rep_localhost_bs_appsrv failed

      My default reports server on install was rep_localhost_bs_appsrv. This is evident in rwservlet.properties , which I have not modified.

      Ultimately I want to launch my Report from my Form. I have the Form working but when I try to launch my Report from my Form I get....

      FRM-41213-Unable to connect to report server rep_localhost_bs_appsrv

      Someone please help!

      Thanks in advance.
        • 1. Re: 10g AS Forms & Reports Services 10.1.2.0.2
          432524
          My memory is a little bit rusty so I do not remeber exactly how I did this, but I did this about two months ago. Make sure that the reports server is in the opmn.xml file and start it with the opmnctl utility. There are some notes on Metalink describing this (especially for additional reports servers).

          cu
          Andreas
          • 2. Re: 10g AS Forms & Reports Services 10.1.2.0.2
            114271
            Ok..... How can you start the Reports Server.

            If you use the in-process server, it starts automatically. The catch is that you MUST use the Reports servlet to call the report in order for it to start and process your report. An easy way to test this is to run the demo test.rdf for Reports. Go to http://youservername:port/repdemo

            Just run the form & leave everything the way it is. You should get a sample report to print. When you do it that way, you are running the in-process server through the Reports servlet, rwservlet.

            You can start the in-process Reports Server using a URL (http://your_machine_name:your_port_num/reports/rwservlet/startserver), but it will already automatically start when you submit a job to it through the Reports Servlet (and end when it is finished).

            That is a good way to run a report as far as keeping your options for scalability & load balancing with Reports open. To call a report this way, you'd dynamically generate the URL in Forms and call web.show_document to call the Reports servlet using that URL.

            If you use run_report_object, you MUST have a standalone Reports Server. (well, I guess it is possible to use the in-process server, but it isn't practical in my experience). You'll need to start a standalone Reports Server and pass all the correct info to the named Reports Server you've started.

            To start it standalone, you use rwserver.sh (rwserver.exe on Windows).

            VERY extensive documentation on the Reports Server can be found in the doc library here:
            http://download.oracle.com/docs/html/B14048_02/toc.htm (HTML)
            http://download.oracle.com/docs/pdf/B14048_02.pdf (PDF)

            I hope this helps.

            Steve Falconer
            • 3. Re: 10g AS Forms & Reports Services 10.1.2.0.2
              Billy
              Thanks for the reply. I have now read extensive documentation on this and understand the basic processes involved in configuring a reports server.

              However, on my brand new installation (On new machine done yesterday) I still have the basic problem that I had on my last installation (on different machine).

              This is that after installing 10g F/R Services I cannot run the test.rdf. I use the repdemo screen to do this. I leave all fields as default so that it invokes the in-process server. However, it gives me REP-51002 Bind to reports server rep_mymachine_bsapp failed.

              I have not messed with any reports configuration files.

              Also tried invoking a standalone server from dos (rwserver server=repsrv). This starts ok but when specifying this in the Reports Server name on repdemo screen I still get the bind error.

              All input will be highly appreciated as i am at my whits with this problem.

              Thanks
              • 4. Re: 10g AS Forms & Reports Services 10.1.2.0.2
                Pweckerl-Oracle
                hello,

                all indications point to the fact that your reports server either does not start up or there is some networking issue that prevents the servlet from communicating with the server.

                here are a couple of pointers:

                a) after you start up your application server open a web browser and goto http://.../reports/rwservlet/showjobs

                this should show you the server queue table. if you get the bind error, then your server has not startet correctly. then i would go into $OH/reports/conf and edit the server config file. check for the <trace .../> element and make sure it is not commented out. then restart the server and try again. now you will find a bunch of trace files in the log directory. they might give you a hint as to what is wrong.

                b) if your machine setup uses multiple network cards and/or you are using software VPN (e.g. cisco) and/or you have VMware installed on your machine, switch to naming service for the server (see the reports documnetation for futher details)

                in some instances, we have seen issues when multiple NICs (actual physical NICs and/or software NICs, such created by VPN software or VMware) were present on certain machiens. in these cases the corba stack potentially binds to different NICs and the communication from the servlet actually goes out a different NIC than the server binds to. switching to the naming service should help.

                bottom line, things should work out of the box, the way you expect them to work, but without knowing any furhter details about your machine or trace information from the server it's hard to diagnose what might be wrong exactly. i would strongly suggest, if the problem persists, to contact oracle support services. they can diagnose and trouble shoot the problem much easier than we can do here at the forum.

                thanks,
                ph.
                • 5. Re: 10g AS Forms & Reports Services 10.1.2.0.2
                  Billy
                  Thanks for you reply.

                  I cannot get http://.../reports/rwservlet/showjobs as I get the bind error.

                  I ran the trace and did not find anything helpful in the trace files. Logged a call with Oracle who have not bothered replying all day!

                  I only have one NIC, no VMware VNC etc.

                  Ok so I can't invoke the in-process server. But if I run a standalone server (rwserevr server=repsrv) this starts ok.

                  Howerever, specifying this servername as that to be used when using the repdemo screen still gets me a bind error, but this time when binding to my repserv server!

                  It should be straight forward running the test.rdf from the repdemo screen. I'm puzzled as to why I have now had this problem with 2 totally seperate installations.

                  HELP!

                  Thanks
                  • 6. Re: 10g AS Forms & Reports Services 10.1.2.0.2
                    Pweckerl-Oracle
                    the fact that you can not contact the in-process server or the stand-alone server is interesting.

                    have you tried to do a http://.../reports/rwservlet/showjobs?server=repsrv to see whether you can contact the stand alone server ? my guess is you can't, but just to make sure we have all our bases covered.

                    also could you post the SR number so i can take a look ? please make sure you upload all the trace files you got and your server config file and rwservlet.properties with the SR.

                    the fact that you have the exact same issue on two separate installations tells me that there is something systematiclly wrong, which is a good thing as it can be reproduced.

                    thanks,
                    ph.
                    • 7. Re: 10g AS Forms & Reports Services 10.1.2.0.2
                      Billy
                      Hi,

                      Just received a reply from Oracle. I have not fully read it so feel free to contribute. It is SR 5185215.993

                      Thanks for you ongoing input.
                      • 8. Re: 10g AS Forms & Reports Services 10.1.2.0.2
                        Billy
                        Tried http://.../reports/rwservlet/showjobs?server=repsrv as you guessed it still gives a bind error.
                        • 9. Re: 10g AS Forms & Reports Services 10.1.2.0.2
                          Pweckerl-Oracle
                          ok. please turn on tracing as described in the service request and upload the tracefiles as well. also make a note in the SR that you have already uploaded some files earlier. so support does not miss these.

                          the support analyst shoudl be able to help you identifiy the issue as soon as they had a chance to look through your traces.

                          thanks,
                          ph.

                          PS: have you tried to switch to naming service ?

                          http://download.oracle.com/docs/cd/B14099_17/bi.1012/b14048/pbr_arch.htm#sthref85
                          http://download.oracle.com/docs/cd/B14099_17/bi.1012/b14048/pbr_strt.htm#sthref148
                          http://download.oracle.com/docs/cd/B14099_17/bi.1012/b14048/pbr_conf.htm#sthref507
                          • 10. Re: 10g AS Forms & Reports Services 10.1.2.0.2
                            Pweckerl-Oracle
                            one more thing ... have you checked that your machien does not have some kind of firefall software (windows, norton, etc) that might trap the communication between server and servlet ?
                            • 11. Re: 10g AS Forms & Reports Services 10.1.2.0.2
                              Billy
                              Hi,

                              I have got the report server to work by changing the rwnetwork.conf file to use namingserver instead of multicast.

                              Does this mean that I have to manually start my namingservice each time I reboot the machine?

                              Also this is just the 1st hurdle as I still cannot call reports from forms. I get FRM-41211: Integration Error: SSL Failure Running Another Product.

                              Any input appreciated.

                              Thanks
                              • 12. Re: 10g AS Forms & Reports Services 10.1.2.0.2
                                Pweckerl-Oracle
                                ok, that basically indicated that your machine has issues with multicast. you should check whether there is any software firewall active on your machine. that's usually the case. they could block the multicast packets and prevent the servlet from talking to the server.

                                since you identified the issue, please work with your support analyst to diagnose the exact issue. as for the

                                thanks,
                                ph.