1 Reply Latest reply on Feb 20, 2015 10:49 AM by Gary Graham-Oracle

    msvcr100.dll is not a valid windows image


      OS: Windows XP Professional 32 bit

      SQLDeveloper Version:


      I got the following error when trying to open SQLDeveloper


      1) ...\sqldeveloper\jdk\bin\msvcr100.dll is not a valid windows image



      2) Unable to launch the Java Virtual Machine ...\sqldeveloper\jdk\bin\msvcr100.dll



      Thank you in advance.


      I do not have admin rights to my laptop so I can not install Java JDK on laptop.

        • 1. Re: msvcr100.dll is not a valid windows image
          Gary Graham-Oracle

          Given that you have Win XP 32-bit, you should not have downloaded and installed the SQL Developer 4.0 that comes with 64-bit Java -- that is the reason for the "not a valid image" error.  If do not already have an appropriate 32-bit Java 7 JDK installed on that machine (and cannot install one due to lack of admin privileges), your only alternative is to download and install the 32-bit SQL Developer 3.2.2 that comes with 32-bit Java.


          As you may have noticed, only one of our downloads for Windows includes Java, and the policy changed between 3.2.2 and 4.0. Prior to 4.0 the bundled Java was 32-bit, whereas with 4.x it is now 64-bit only. This reflects a shift in popularity from 32-bit to 64-bit hardware and applications.


          If somehow your IT organization installs the latest 32-bit Java 7 JDK for you, then everything is easy:  just change the SetJavaHome line in the sqldeveloper\\product.conf file under your Windows user settings to point to that JDK and ignore the one that came bundled.


          Since your IT has not already upgraded you to a more modern, supported Windows version (yes, XP is past its end-of-life date), it would not be too surprising if you are kept locked down in your current, stable configuration in an effort to avoid any new problems.

          1 person found this helpful