10 Replies Latest reply on Feb 24, 2015 12:29 PM by 2889748

    RCU:6090 when running RCU

    2889748

      Hi,

      Been trying to create the schemas using rcu as a standalone (DB running on my machine).

      The version is 11g.

      I'm using MySQL for DB (Version: 5.5.42-1) and have followed the steps as in the documentation. When I run rcu from command line, I get an error :

      Processing command line ....

      Invalid database type. Valid database types are: ORACLE , {1} and {2}

      RCU-6090:Skipping Main operation: Failed in Connection step validation

       

      Same is information from the logs.

       

      The command I've run is :

      ./rcu -silent -createRepository -databaseType MYSQL -connectString 127.0.0.1:3306:ORACLE -dbUser ORACLE -component MDS -tablespace MDS -tempTablespace IAS_TEMP

      I hope that I've provided the parameters correctly.

      The db name and username is the same and in caps viz ORACLE. I did this as per notes found in the documentation.

      The reason I'm doing this by command line is because, the GUI gave me an SDU Mismatch and no further information, when I provided the connection details.

       

      My system meets all the requirements (or so I think) that the certification xls seems to require.

      OS: debian linux (Jessie) - 64bit.

      However, I have installed the ia32-sun-java6-bin package (from 6.26-squeeze1) and modified the rcu file in <RCU_HOME>/bin

      This was done because out of the box the RCU wizard did not come up and a forum Q advised people to point to the native jre in the system.

      This got the wizard running but the SDU mismatch had me wondering about the a 32/64 bit issue and I installed ia32-sun-java6-bin. But the SDU still showed up . Finally got a ('sensible?!') error from the command line.

       

      I've also set the following configuration parameters for MySql:

      mysql>SET GLOBAL INNODB_FILE_PER_TABLE="ON";

      mysql>SET GLOBAL INNODB_FILE_FORMAT="Barracuda";

      mysql>SET GLOBAL INNODB_LARGE_PREFIX="ON";

      mysql>SET GLOBAL LOG_BIN_TRUST_FUNCTION_CREATORS="ON";

      I've not fully understood what they mean, but discussion forms seem to indicate that this is required. So I did it. I have the (same) error before and after adding this. So  ...

       

      Now, I've run out of ideas to resolve this so any pointers or solutions are welcome.

      My main question is:

      Why do I get Invalid Database type? Have I missed installing something?

      I downloaded the disks from Oracle Business Intelligence Applications (11.1.1.7.1) Downloads all the 64-bit linux disks and unzipped them and followed instructions in the documentation and the documentation states that MySQL is supported.

       

      Thanks in advance for your time and efforts.

      AK

       

      P.S. Hoping that this posted in the correct forum. If no please advise. Thx!
      .

        • 1. Re: RCU:6090 when running RCU
          SunilSharma

          2889748 wrote:

           

          Hi,

          Been trying to create the schemas using rcu as a standalone (DB running on my machine).

          The version is 11g.

          I'm using MySQL for DB (Version: 5.5.42-1) and have followed the steps as in the documentation. When I run rcu from command line, I get an error :

          Processing command line ....

          Invalid database type. Valid database types are: ORACLE , {1} and {2}

          RCU-6090:Skipping Main operation: Failed in Connection step validation

           

          Same is information from the logs.

           

          The command I've run is :

          ./rcu -silent -createRepository -databaseType MYSQL -connectString 127.0.0.1:3306:ORACLE -dbUser ORACLE -component MDS -tablespace MDS -tempTablespace IAS_TEMP

          I hope that I've provided the parameters correctly.

          The db name and username is the same and in caps viz ORACLE. I did this as per notes found in the documentation.

          The reason I'm doing this by command line is because, the GUI gave me an SDU Mismatch and no further information, when I provided the connection details.

           

           

           

          .

          is 127.0.0.1 your MYSQL DB hostname/ip address? Does ORACLE user has sysdba privilage ? generally RCU table creation requires sys user with sysdba role and also how are you seeding the password in the command which you are running? i dont see any -f password files are seeded ?

           

          is this BIAPPS 11.1.1.7.1 RCU? Did you successfully run the OBIEE 11g RCU along with OBIEE 11g? If yes did OBIEE rcu ran without any issues?

          • 2. Re: RCU:6090 when running RCU
            2889748

            Hi Sunil,

            127.0.0.1 is the ip address.

            I followed the instructions on Repository Creation Utility Screens As you can see in there, it states I can give any one of "host name, IP address, or complete server name in host\server format" Similarly for user. The user does not have admin privileges but that can be modified.

            I did not use the -f option, so when I hit enter, it asks for password and proceeds; after a while it gives the 'Invalid Database type' error message.

            As required; I have mysql at port 3306 and there is a db named ORACLE which can be accessed by user named ORACLE

             

            This is the Oracle Business Intelligence Applications RCU (11.1.1.8.1) downloaded from Oracle Business Intelligence Applications (11.1.1.7.1) Downloads for Linuxx86 -64

            This is the first time I'm running the RCU, in the sense no previous successful runs. I mean: The sequence of actions is downloaded, verified system using the xl file and the went on to install as per instructions. i.e. create a RCU_HOME, and from bin run ./rcu

             

            Thank you for your time and efforts.

            AK

            • 3. Re: RCU:6090 when running RCU
              SunilSharma

              Did you try to run the rcu from windows machine? Can you connect to MySQL DB using the credentials, which you are using in commandline? RCU schema creation requires a user with sysdba or dba privilages check this for more Oracle® Fusion Middleware System Requirements and Specifications

              • 4. Re: RCU:6090 when running RCU
                2889748

                Hi Sunil,

                I'm a bit lost. Did you mean to point me to Oracle® Fusion Middleware System Requirements and Specifications because the link you've provided takes me to Microsoft SQL Server.

                But, I have not tried on windows. That means another 1 GB + download  

                Thanks for taking time out to help.

                AK.

                • 5. Re: Re: RCU:6090 when running RCU
                  SunilSharma

                  ya, i was referring to user roles irrespective of DB. Even your link which you are following for installation show you the same Repository Creation Utility Screens you should use a user with sysdba or dba privilages

                   

                  Table A-3 Oracle MySQL Database Connection Credentials

                  FieldDescription

                  Host Name

                  Enter the host name, IP address, or complete server name in host\server format of the server where your database is running.

                  For Oracle RAC databases, specify the VIP name or one of the node names in this field.

                  Port

                  Enter the port number for your database.

                  Database Name

                  Specify the name of your database.

                  Username

                  Specify the name of a user with DBA or SYSDBA privileges.

                  Password

                  Enter the password for your database user.

                   

                  see the highlighted section. Ya you got to use windows one

                  1 person found this helpful
                  • 6. Re: RCU:6090 when running RCU
                    2889748

                    Ok that is nice. So I can create the schema on the windows machine and use it from my Linux machine? yes?

                    But does it not mean that it is no longer in a standalone mode? While this is an option, any suggestions on how to get it stand alone on a linux x86-64?

                    That is what I'd really like.

                    But this is a good idea.

                    • 7. Re: RCU:6090 when running RCU
                      SunilSharma

                      yes, you can run the rcu from windows machine and it will create the database tables in database and you can just refer them in your configuration files further.

                       

                      actually there are 2 ways to run the rcu one is windows and another one is linux. So in any case it creates the req. tables in respective db. So it doesnt matter whether you run from linux or windows

                      • 8. Re: RCU:6090 when running RCU
                        2889748

                        So let me get this right.

                        1. Run RCU on windows with MySQL db and giving the user DBA privileges.

                        2. Then run the installer for the OBIA on my Linux machine.

                        3. Provide the connection string appropriately when it asks for schema details

                        Follow steps. Everything should work.

                        Do correct me or point out gotchas...

                        Thanks a lot for your time and patience.

                        AK.

                        • 9. Re: RCU:6090 when running RCU
                          SunilSharma

                          yes, you are right. You got it this time

                          • 10. Re: RCU:6090 when running RCU
                            2889748

                            Thank you very much! Appreciate your time and patience.

                            I hope to get the download done soon. Then, hope to be at the end of the exercise.

                            Will update.

                            AK.