1 2 3 Previous Next 34 Replies Latest reply on Mar 3, 2015 4:36 PM by Dude!

    Support Notes for Installing Oracle db 11.2.0.4 on RHEL 6.5

      Hi all.

       

      Can you give me the metalink note (Support note doc id) for Installing Oracle db 11.2.0.4 on RHEL 6.5?

       

      Thanks a lot,

      mk

        • 1. Re: Support Notes for Installing Oracle db 11.2.0.4 on RHEL 6.5
          12cdb

          Hi,

           

          You can find them as below;

           

          Requirements for Installing Oracle 11.2.0.3/11.2.0.4 RDBMS on RHEL 6 on zLinux (s390x) (Doc ID 1470834.1)

           

          https://docs.oracle.com/cd/E11882_01/install.112/e24326/toc.htm

           

          For other versions you can refer

          Master Note of Linux OS Requirements for Database Server (Doc ID 851598.1)

           

          HTH,

          Pradeep

          1 person found this helpful
          • 2. Re: Support Notes for Installing Oracle db 11.2.0.4 on RHEL 6.5
            John Stegeman

            When you download the patch for 11.2.0.4, it comes with a readme.html file. When you read that document, you'll find a link to the installation guide. That is where you go for installation instructions.

             

            The certification tab on the Oracle Support site will provide you information about what OS is certified with what version of the database.

            1 person found this helpful
            • 4. Re: Support Notes for Installing Oracle db 11.2.0.4 on RHEL 6.5

              Hi pradeep,john, and all.

               

              I am applying some pre-reqs RPM's for 11.2.0.4.

               

              One of them is  compat-libstdc++-33.i686

               

              But when I run yum install, I got lots of warnings and error. Please help how to resolve this. Thanks.

               

              [root@ip-10-0-0-4 ~]# yum install compat-libstdc++-33.i686 -y

              Loaded plugins: amazon-id, refresh-packagekit, rhui-lb, security

              Setting up Install Process

              Resolving Dependencies

              There are unfinished transactions remaining. You might consider running yum-complete-transaction first to finish them.

              --> Running transaction check

              ---> Package compat-libstdc++-33.i686 0:3.2.3-69.el6 will be installed

              --> Processing Dependency: libm.so.6 for package: compat-libstdc++-33-3.2.3-69.el6.i686

              --> Processing Dependency: libgcc_s.so.1(GLIBC_2.0) for package: compat-libstdc++-33-3.2.3-69.el6.i686

              --> Processing Dependency: libgcc_s.so.1(GCC_3.3) for package: compat-libstdc++-33-3.2.3-69.el6.i686

              --> Processing Dependency: libgcc_s.so.1(GCC_3.0) for package: compat-libstdc++-33-3.2.3-69.el6.i686

              --> Processing Dependency: libgcc_s.so.1 for package: compat-libstdc++-33-3.2.3-69.el6.i686

              --> Processing Dependency: libc.so.6(GLIBC_2.3) for package: compat-libstdc++-33-3.2.3-69.el6.i686

              --> Processing Dependency: libc.so.6(GLIBC_2.2) for package: compat-libstdc++-33-3.2.3-69.el6.i686

              --> Processing Dependency: libc.so.6(GLIBC_2.1.3) for package: compat-libstdc++-33-3.2.3-69.el6.i686

              --> Processing Dependency: libc.so.6(GLIBC_2.1) for package: compat-libstdc++-33-3.2.3-69.el6.i686

              --> Processing Dependency: libc.so.6(GLIBC_2.0) for package: compat-libstdc++-33-3.2.3-69.el6.i686

              --> Processing Dependency: libc.so.6 for package: compat-libstdc++-33-3.2.3-69.el6.i686

              --> Running transaction check

              ---> Package glibc.x86_64 0:2.12-1.132.el6_5.3 will be updated

              --> Processing Dependency: glibc = 2.12-1.132.el6_5.3 for package: glibc-headers-2.12-1.132.el6_5.3.x86_64

              --> Processing Dependency: glibc = 2.12-1.132.el6_5.3 for package: glibc-devel-2.12-1.132.el6_5.3.x86_64

              --> Processing Dependency: glibc = 2.12-1.132.el6_5.3 for package: glibc-common-2.12-1.132.el6_5.3.x86_64

              ---> Package glibc.i686 0:2.12-1.149.el6_6.5 will be installed

              --> Processing Dependency: libfreebl3.so(NSSRAWHASH_3.12.3) for package: glibc-2.12-1.149.el6_6.5.i686

              --> Processing Dependency: libfreebl3.so for package: glibc-2.12-1.149.el6_6.5.i686

              ---> Package glibc.x86_64 0:2.12-1.149.el6_6.5 will be an update

              ---> Package libgcc.i686 0:4.4.7-11.el6 will be installed

              --> Running transaction check

              ---> Package glibc.x86_64 0:2.12-1.132.el6_5.3 will be updated

              --> Processing Dependency: glibc = 2.12-1.132.el6_5.3 for package: glibc-common-2.12-1.132.el6_5.3.x86_64

              ---> Package glibc-devel.x86_64 0:2.12-1.132.el6_5.3 will be updated

              ---> Package glibc-devel.x86_64 0:2.12-1.149.el6_6.5 will be an update

              ---> Package glibc-headers.x86_64 0:2.12-1.132.el6_5.3 will be updated

              ---> Package glibc-headers.x86_64 0:2.12-1.149.el6_6.5 will be an update

              ---> Package nss-softokn-freebl.i686 0:3.14.3-22.el6_6 will be installed

              --> Finished Dependency Resolution

              Error: Package: glibc-common-2.12-1.132.el6_5.3.x86_64 (installed)

                         Requires: glibc = 2.12-1.132.el6_5.3

                         Removing: glibc-2.12-1.132.el6_5.3.x86_64 (installed)

                             glibc = 2.12-1.132.el6_5.3

                         Updated By: glibc-2.12-1.149.el6_6.5.x86_64 (rhui-REGION-rhel-server-releases)

                             glibc = 2.12-1.149.el6_6.5

                         Available: glibc-2.12-1.7.el6.i686 (rhui-REGION-rhel-server-releases)

                             glibc = 2.12-1.7.el6

                         Available: glibc-2.12-1.7.el6_0.3.i686 (rhui-REGION-rhel-server-releases)

                             glibc = 2.12-1.7.el6_0.3

                         Available: glibc-2.12-1.7.el6_0.4.i686 (rhui-REGION-rhel-server-releases)

                             glibc = 2.12-1.7.el6_0.4

                         Available: glibc-2.12-1.7.el6_0.5.i686 (rhui-REGION-rhel-server-releases)

                             glibc = 2.12-1.7.el6_0.5

                         Available: glibc-2.12-1.25.el6.i686 (rhui-REGION-rhel-server-releases)

                             glibc = 2.12-1.25.el6

                         Available: glibc-2.12-1.25.el6_1.3.i686 (rhui-REGION-rhel-server-releases)

                             glibc = 2.12-1.25.el6_1.3

                         Available: glibc-2.12-1.47.el6.i686 (rhui-REGION-rhel-server-releases)

                             glibc = 2.12-1.47.el6

                         Available: glibc-2.12-1.47.el6_2.5.i686 (rhui-REGION-rhel-server-releases)

                             glibc = 2.12-1.47.el6_2.5

                         Available: glibc-2.12-1.47.el6_2.9.i686 (rhui-REGION-rhel-server-releases)

                             glibc = 2.12-1.47.el6_2.9

                         Available: glibc-2.12-1.47.el6_2.12.i686 (rhui-REGION-rhel-server-releases)

                             glibc = 2.12-1.47.el6_2.12

                         Available: glibc-2.12-1.80.el6.i686 (rhui-REGION-rhel-server-releases)

                             glibc = 2.12-1.80.el6

                         Available: glibc-2.12-1.80.el6_3.3.i686 (rhui-REGION-rhel-server-releases)

                             glibc = 2.12-1.80.el6_3.3

                         Available: glibc-2.12-1.80.el6_3.4.i686 (rhui-REGION-rhel-server-releases)

                             glibc = 2.12-1.80.el6_3.4

                         Available: glibc-2.12-1.80.el6_3.5.i686 (rhui-REGION-rhel-server-releases)

                             glibc = 2.12-1.80.el6_3.5

                         Available: glibc-2.12-1.80.el6_3.6.i686 (rhui-REGION-rhel-server-releases)

                             glibc = 2.12-1.80.el6_3.6

                         Available: glibc-2.12-1.80.el6_3.7.i686 (rhui-REGION-rhel-server-releases)

                             glibc = 2.12-1.80.el6_3.7

                         Available: glibc-2.12-1.107.el6.i686 (rhui-REGION-rhel-server-releases)

                             glibc = 2.12-1.107.el6

                         Available: glibc-2.12-1.107.el6_4.2.i686 (rhui-REGION-rhel-server-releases)

                             glibc = 2.12-1.107.el6_4.2

                         Available: glibc-2.12-1.107.el6_4.4.i686 (rhui-REGION-rhel-server-releases)

                             glibc = 2.12-1.107.el6_4.4

                         Available: glibc-2.12-1.107.el6_4.5.i686 (rhui-REGION-rhel-server-releases)

                             glibc = 2.12-1.107.el6_4.5

                         Available: glibc-2.12-1.132.el6.i686 (rhui-REGION-rhel-server-releases)

                             glibc = 2.12-1.132.el6

                         Available: glibc-2.12-1.132.el6_5.1.i686 (rhui-REGION-rhel-server-releases)

                             glibc = 2.12-1.132.el6_5.1

                         Available: glibc-2.12-1.132.el6_5.2.i686 (rhui-REGION-rhel-server-releases)

                             glibc = 2.12-1.132.el6_5.2

                         Available: glibc-2.12-1.132.el6_5.4.i686 (rhui-REGION-rhel-server-releases)

                             glibc = 2.12-1.132.el6_5.4

                         Available: glibc-2.12-1.149.el6.i686 (rhui-REGION-rhel-server-releases)

                             glibc = 2.12-1.149.el6

                         Available: glibc-2.12-1.149.el6_6.4.i686 (rhui-REGION-rhel-server-releases)

                             glibc = 2.12-1.149.el6_6.4

              You could try using --skip-broken to work around the problem

              ** Found 12 pre-existing rpmdb problem(s), 'yum check' output follows:

              bash-4.1.2-29.el6.x86_64 is a duplicate with bash-4.1.2-15.el6_5.2.x86_64

              1:busybox-1.15.1-21.el6_6.x86_64 is a duplicate with 1:busybox-1.15.1-20.el6.x86_64

              glibc-common-2.12-1.149.el6_6.5.x86_64 is a duplicate with glibc-common-2.12-1.132.el6_5.3.x86_64

              glibc-common-2.12-1.149.el6_6.5.x86_64 has missing requires of glibc = ('0', '2.12', '1.149.el6_6.5')

              kernel-firmware-2.6.32-504.8.1.el6.noarch is a duplicate with kernel-firmware-2.6.32-431.29.2.el6.noarch

              kernel-headers-2.6.32-504.8.1.el6.x86_64 is a duplicate with kernel-headers-2.6.32-431.29.2.el6.x86_64

              libgcc-4.4.7-11.el6.x86_64 is a duplicate with libgcc-4.4.7-4.el6.x86_64

              mesa-dri-filesystem-10.1.2-2.el6.x86_64 is a duplicate with mesa-dri-filesystem-9.2-0.5.el6_5.2.x86_64

              nss-softokn-freebl-3.14.3-22.el6_6.x86_64 is a duplicate with nss-softokn-freebl-3.14.3-10.el6_5.x86_64

              redhat-release-server-6Server-6.6.0.2.el6.x86_64 is a duplicate with redhat-release-server-6Server-6.5.0.1.el6.x86_64

              tzdata-2015a-1.el6.noarch is a duplicate with tzdata-2014g-1.el6.noarch

              tzdata-java-2015a-1.el6.noarch is a duplicate with tzdata-java-2014g-1.el6.noarch

              [root@ip-10-0-0-4 ~]#

              • 5. Re: Support Notes for Installing Oracle db 11.2.0.4 on RHEL 6.5
                John Stegeman

                Sounds like a good question for you to ask Oracle Support or perhaps IBM support.

                1 person found this helpful
                • 6. Re: Support Notes for Installing Oracle db 11.2.0.4 on RHEL 6.5
                  12cdb

                  +

                  You are trying to install [root@ip-10-0-0-4 ~]# yum install compat-libstdc++-33.i686 -y

                   

                  From a document:

                  The following or later version of packages for Oracle Linux 6, and Red Hat Enterprise Linux 6 must be installed:

                  compat-libcap1-1.10-1 (x86_64)

                  compat-libstdc++-33-3.2.3-69.el6 (x86_64)

                  compat-libstdc++-33-3.2.3-69.el6.i686

                   

                  Shouldn't you try compat-libstdc++-33-3.2.3-69.el6.i686.

                  You need both versions 32 & 64 for this rpm. So if you  already have 64-bit installed then installing 32-bits will fail. In this case I believe force installation should do the job.

                   

                  HTH,

                  Pradeep

                  1 person found this helpful
                  • 7. Re: Support Notes for Installing Oracle db 11.2.0.4 on RHEL 6.5

                    Thanks Pradeep & John...

                     

                    But I am not using IBM hardware?

                     

                    By the what how do I query if there is a higher version of rpm being installed? You can not query it exactly by the rpm name as there is always no "matching" entry.

                     

                    For example: The list of rpm's below, lots of them does not match if you query one by one as is by extact "name"

                    using "rpm -qa"

                     

                     

                    • openmotif21-2.1.30-11.EL6.i686 (32-bit)1
                    • xorg-x11-libs-compat-6.8.2-1.EL.33.0.1.i386 (32-bit)
                    • libXrender-0.9.5-1.el6.i686
                    • binutils-2.20.51.0.2-5.20.el6.x86_64
                    • compat-libstdc++-296-2.96-144.el6.i686
                    • compat-libstdc++-33-3.2.3-69.el6.i686
                    • gcc-4.4.5-6.el6.x86_64
                    • gcc-c++-4.4.5-6.el6.x86_64
                    • glibc-2.12-1.7.el6.i686 (32-bit)
                    • glibc-2.12-1.7.el6.x86_64
                    • glibc-common-2.12-1.7.el6.x86_64
                    • glibc-devel-2.12-1.7.el6.i686 (32-bit)
                    • glibc-devel-2.12-1.7.el6.x86_64
                    • libgcc-4.4.4-13.el6.i686
                    • libgcc-4.4.4-13.el6.x86_64
                    • libstdc++-devel-4.4.4-13.el6.i686
                    • libstdc++-devel-4.4.4-13.el6.x86_64
                    • libstdc++-4.4.4-13.el6.i686
                    • libstdc++-4.4.4-13.el6.x86_64
                    • libXi-1.3-3.el6.i686
                    • libXp-1.0.0-15.1.el6.i686
                    • libXp-1.0.0-15.1.el6.x86_64
                    • libaio-0.3.107-10.el6.i686
                    • libaio-0.3.107-10.el6.x86_64
                    • libgomp-4.4.4-13.el6.x86_64
                    • make-3.81-19.el6.x86_64
                    • gdbm-1.8.0-36.el6.i686
                    • gdbm-1.8.0-36.el6.x86_64
                    • redhat-lsb-4.0-3.0.1.el6.x86_64
                    • sysstat-9.0.4-11.el6.x86_64
                    • util-linux-ng-2.17.2-6.el6.x86_64
                    • compat-libcap1-1.10-1.x86_64
                    • compat-libstdc++-33-3.2.3-69.el6.x86_64
                    • elfutils-libelf-devel-0.148.1-el6.x86_64
                    • libaio-devel-0.3.107-10.el6.i686
                    • libaio-devel-0.3.107-10.el6.x86_64
                    • unixODBC-2.2.14-11.el6.i686
                    • unixODBC-devel-2.2.14-11.el6.i686
                    • xorg-x11-utils-7.4-8.el6.x86_64
                    • oracle-rdbms-server-11gR2-preinstall.x86_64
                    • 8. Re: Support Notes for Installing Oracle db 11.2.0.4 on RHEL 6.5

                      Additionally confusing, not all higher version of rpm is supported

                       

                      1: The openmotif package version must be 2.1.30 (for example, openmotif-2.3.3-1 is not supported).

                      • 9. Re: Support Notes for Installing Oracle db 11.2.0.4 on RHEL 6.5
                        John Stegeman

                        Oracle support is really good with installation questions...

                         

                        I thought you were on IBM when I noted 12cdb's reply with a link to a zLinux support note - you can obviously ignore that as well as my comment

                        1 person found this helpful
                        • 10. Re: Support Notes for Installing Oracle db 11.2.0.4 on RHEL 6.5

                          Thanks dear friends,

                           

                          By the way, how do I install rpm's from :

                           

                          (available via ULN on http://linux.oracle.com or the Oracle Public yum repository on http://public-yum.oracle.com) :

                          • oracle-validated-1.1.0-15.el5.x86_64

                           

                          I tried using yum install, but it is not found

                           

                          [root@ip-10-0-0-4 ~]# yum install oracle-validated-1.1.0-15.el5.x86_64

                          Loaded plugins: amazon-id, refresh-packagekit, rhui-lb, security

                          Setting up Install Process

                          No package oracle-validated-1.1.0-15.el5.x86_64 available.

                          Error: Nothing to do

                          • 11. Re: Support Notes for Installing Oracle db 11.2.0.4 on RHEL 6.5
                            Zoltan Kecskemethy

                            Please follow this document.

                            Requirements for Installing Oracle 11gR2 RDBMS on RHEL6 or OL6 64-bit (x86-64) (Doc ID 1441282.1)

                             

                            Redhat linux does not have oracle-validated package as far as I know. I do not recommend to install oracle linux packages on redhat.

                            Also your error message seems to me that you try to install pacakges from other location/repository than redhat one! Or you may mix up redhat releases as package sources? Or you may install manually downloaded packages?

                            Please install only from Redhat media or official RHN.

                             

                            There is a linux forum available Generic Linux where many pro user can help you as well...

                            1 person found this helpful
                            • 12. Re: Support Notes for Installing Oracle db 11.2.0.4 on RHEL 6.5
                              Dude!

                              The oracle-validated package was for Oracle Linux 5. Under Oracle Linux 6 it's called oracle-rdbms-server-11gr2-preinstall. These packages do actually not conatain any software and only trigger the installation of prerequisite packages as dependencies, and execute scripts to configure kernel parameters and create the Oracle account and groups.

                              1 person found this helpful
                              • 13. Re: Support Notes for Installing Oracle db 11.2.0.4 on RHEL 6.5
                                Dude!

                                The following is from my own records and installs all prerequisite packages for 11gR2 11.2.0.3 and later under RHEL 6. No i686 package are needed for installation under x64.

                                 

                                yum install compat-libstdc++-33 compat-gcc-34 compat-gcc-34-c++ \
                                elfutils-libelf-devel ksh sysstat make gcc gcc-c++ compat-libcap1 \
                                glibc-devel glibc-common glibc-headers libstdc++-devel libaio-devel


                                1 person found this helpful
                                • 14. Re: Support Notes for Installing Oracle db 11.2.0.4 on RHEL 6.5

                                  I thank you all, bow

                                   

                                  So from the list of required rpms above, how do I check if they are all applied? Is there a validation script I can run?

                                   

                                  Or I will just run the ./runInstaller  and when it encounters error I just check which rpm is responsible?

                                   

                                  I just wish oracle will let runInstaller will check first if all the rpms are existing

                                  1 2 3 Previous Next