0 Replies Latest reply on Mar 10, 2015 5:19 PM by kgamble

    PDF XSL error with APex report layout

    kgamble

      I have already asked this question in the apex forum but have not received any response so I thought I'd try here.

       

      I have installed Apex 4.2.6 and standalone ORDS 2.0

       

      I have a working app on apex.oracle.com that I have imported into my local environment.

       

      In my local environment I can generate pdf files from reports and report queries if I use the generic layout.  If I use a report layout based on xsl-fo file I get "String index out of range: -1" and a corrupt pdf file.

       

      The exact same layout and report query works on apex.oracle.com.

       

      I have reinstalled the latest versions of ORDS and Apex.

      I have tried a simple report with just one numeric field but get the same error.

       

      Can someone please suggest my next steps.  I see this problem has been noted several times in the past but none of the previously suggested fixes - UTF8, latest versions, simple layout - have worked.

       

       

      Kathryn