4 Replies Latest reply on Mar 13, 2015 2:41 AM by Kj - Kiran Jadhav

    Dead links in R12 menu?

    2730502

      Hi All,

       

      We have upgraded our 11i to 12.2 realease

       

      We're having an issue that some menu entries from the navigator result in the following message. Under the same responsiblity, this only happens for a few pages.. not all of them.

       

       

      Error 404--Not Found

      From RFC 2068 Hypertext Transfer Protocol -- HTTP/1.1:

      10.4.5 404 Not Found

      The server has not found anything matching the Request-URI. No indication is given of whether the condition is temporary or permanent.

       

       

      All of them work just fine on our 11i env, which is strange. How can we start troubleshooting this?

       

      Appreciate your input

       

      Edit:

       

      These are for example, the contents of our access_log on OHS

      This request worked:

      10.90.90.100 - - [11/Mar/2015:12:33:04 -0400] "GET /OA_HTML/RF.jsp?function_id=21601&resp_id=50681&resp_appl_id=283&security_group_id=0&lang_code=US&params=qvlHP-eC58Npa6EJ1qC49x5QVM667L9Z6z6Wi7Nncuk&oas=rczCvmuhfBmqAZPG5Fan0g.. HTTP/1.1" 200 38402

      10.140.9.133 - - [11/Mar/2015:12:33:07 -0400] "GET /" 200 1241

      10.140.9.131 - - [11/Mar/2015:12:33:08 -0400] "GET /" 200 1241

      This one did not:

      10.90.90.100 - - [11/Mar/2015:12:33:08 -0400] "GET /OA_HTML/RF.jsp?function_id=8290&resp_id=50681&resp_appl_id=283&security_group_id=0&lang_code=US&params=qvlHP-eC58Npa6EJ1qC49x5QVM667L9Z6z6Wi7Nncuk&oas=qxdgvdIJyL2LZ9007EUdNQ.. HTTP/1.1" 404 1164

       

      There are no errors on the database log

        • 1. Re: Dead links in R12 menu?
          Kj - Kiran Jadhav

          Hi,

           

          I would suggest you to check -

           

          -  What are those responsibilities - custom or seeded?

          -  If custom menus/functions then please check the type of function.

          -  If custom functions / jsp pages then you may need to recompile/retrofit in R12.2 environment.


          This one did not:

          10.90.90.100 - - [11/Mar/2015:12:33:08 -0400] "GET /OA_HTML/RF.jsp?function_id=8290&resp_id=50681&resp_appl_id=283&security_group_id=0&lang_code=US&params=qvlHP-eC58Npa6EJ1qC49x5QVM667L9Z6z6Wi7Nncuk&oas=qxdgvdIJyL2LZ9007EUdNQ.. HTTP/1.1" 404 1164

          It looks that function_id is 8290

           

          -Kj

          • 2. Re: Dead links in R12 menu?
            2730502

            Hi Kj

             

            Thanks for your reply.

             

            These are jsp pages, how should we go about doing that?

             

            I have already recompiled everything using ojspcompile. Is there anything else needed?

            • 3. Re: Dead links in R12 menu?
              Mohammed Ali A. Syed

              Hi,

              Login to weblogic console

               

              And choose Environment -> Servers -> oacore servers  (Check the following for each oacore servers you have

               

              You will find deployment (7th tab), Click on it

               

              Check the state of oacore(1.0.0) it should be active.

               

              Repeat for all the oacores.

               

              Thanks

              • 4. Re: Dead links in R12 menu?
                Kj - Kiran Jadhav

                Hi,

                 

                I assume that these are custom jsp pages.

                 

                I have already recompiled everything using ojspcompile. Is there anything else needed?

                 

                Have you migrated the custom jsp pages from 11i to R12.2 filesystem and compiled?

                Please check the jsp page name defined in function and make sure it is available in ($EBS_APPS_DEPLOYMENT_DIR/oacore/html) and its class file in ($EBS_APPS_DEPLOYMENT_DIR/oacore/html/WEB-INF/classes/_pages)

                 

                If its not available then migrate the custom jsp pages on R12.2 filesystem and recompile, then retest the issue.

                 

                Refer Note - JSP Page Handling and File Locations in Release 12.2 (Doc ID 1928874.1) -

                Section : Manual compilation of JSP page in Release 12.2

                 

                -Kj