1 Reply Latest reply on Mar 19, 2015 5:40 PM by Hussein Sawwan-Oracle

    Internal server error - after migrating from AIX to Linux

    pmkr

      Hello,

       

      I've just migrated out EBS 11.5.10.2 instance from AIX (after upgrading the DB from 9i to 11g) to Linux After completing all the steps per the metalink notes (238276.1 & 557738.1)

      I started the services, and when I tried to logon, I'm getting the "Internal server error".

       

      JVM log file has the following error :

       

      "Caused by: java.lang.RuntimeException: Guest user/pwd does not exist or match: GUEST/ORACLE"

       

      After going thru' various metalink notes, I checked the GUEST password and the XML file, dbc file and the GUEST_USER_PWD profile are all set to ORACLE only. To test changing the GUEST password, I updated the s_guest_pass variable in the XML file to a new value and ran autoconfig. At the time of generating the dbc file, it's returning this error :

       

      "Unable to update GUEST_USER_PWD in database to GUEST/GUEST - Password was not changed"

       

      Though, the dbc file is updated correctly.

       

      To validate the password, I ran the following SQL statement :

       

      select fnd_web_sec.validate_login ('GUEST', 'ORACLE') and it returns "N". But I found out that, it returns N for even the usernames that have right passwords (APPS and SYSADMIN for example)

       

      Then, when I ran "select fnd_message.get from dual", I'm getting the following error :

       

      "ORA-29540: class oracle/apps/fnd/security/WebSessionManagerProc does not exist has been detected in FND_WEB_SEC.VALIDATE_PASSWORD."

       

      Now, has anyone encountered the similar situation ? I read various metalink notes and google-d, and tried a few things but nothing helps.

       

      Thanks

      Muthu