4 Replies Latest reply on Jul 14, 2015 6:36 PM by Marco Gralike

    ORDS.create_service ?

    Marco Gralike

      I am trying to follow the examples given in http://blog.cdivilly.com/2015/03/12/ords-3.0.0-rest-plsql-api/, but seem to being stuck at calling

       

      ords.create_service


      My ORDS version shows up in SQL*Developer as:


      
      DESCRIBE ORDS
      
      PROCEDURE                    Argument Name         Type           IN/OUT Default 
      ---------------------------- --------------------- -------------- ------ ------- 
      DROP_REST_FOR_SCHEMA         P_SCHEMA              VARCHAR2       IN     DEFAULT 
      ENABLE_OBJECT                P_ENABLED             PL/SQL BOOLEAN IN     DEFAULT 
      ENABLE_OBJECT                P_SCHEMA              VARCHAR2       IN     DEFAULT 
      ENABLE_OBJECT                P_OBJECT              VARCHAR2       IN             
      ENABLE_OBJECT                P_OBJECT_TYPE         VARCHAR2       IN             
      ENABLE_OBJECT                P_OBJECT_ALIAS        VARCHAR2       IN     DEFAULT 
      ENABLE_OBJECT                P_AUTO_REST_AUTH      PL/SQL BOOLEAN IN     DEFAULT 
      ENABLE_SCHEMA                P_ENABLED             PL/SQL BOOLEAN IN     DEFAULT 
      ENABLE_SCHEMA                P_SCHEMA              VARCHAR2       IN     DEFAULT 
      ENABLE_SCHEMA                P_URL_MAPPING_TYPE    VARCHAR2       IN     DEFAULT 
      ENABLE_SCHEMA                P_URL_MAPPING_PATTERN VARCHAR2       IN     DEFAULT 
      ENABLE_SCHEMA                P_AUTO_REST_AUTH      PL/SQL BOOLEAN IN     DEFAULT 
      INSTALLED_VERSION (FUNCTION) <return value>        VARCHAR2       OUT            
      SET_URL_MAPPING              P_SCHEMA              VARCHAR2       IN     DEFAULT 
      SET_URL_MAPPING              P_URL_MAPPING_TYPE    VARCHAR2       IN             
      SET_URL_MAPPING              P_URL_MAPPING_PATTERN VARCHAR2       IN             
      

       

      If I do the following, it shows version...

       

      select ords.installed_version() from dual;
      
      ORDS.INSTALLED_VERSION()
      --------------------------------------------------
      3.0.0.343.08.03
      

       

      Can someone point out a solution and/or my mistake...