3 Replies Latest reply on Apr 5, 2015 7:30 AM by Bdub122-Oracle

    YUM install of a single package results in huge dependency list.

    Bdub122-Oracle

      I'm running Oracle Linux 6.5, and I'm getting into an infinite loop when I try to install the openssh-clients package on my yum server.  Have any ideas on what I'm doing wrong here?  It looks like it wants to install a boat load of updates to install this one package and I don't understand why.  Finally, as shown at the end of the listing, it infinite loops on "gmp.x86_64 0:4.3.1-7.el6_2.2 will be updated".

       

      This server is my YUM server, and I want to install openssh-clients on this server.  Like this. . .

       

      [root@wallyYUM ~]# cat /etc/redhat-release

      Red Hat Enterprise Linux Server release 6.5 (Santiago)

       

      [root@wallyYUM ~]#  yum install openssh-clients

       

      Loaded plugins: downloadonly, rhnplugin, ulninfo

      This system is receiving updates from ULN.

      ol7_x86_64_JavaSE7_public:

      By downloading the Java software, you acknowledge that your use of the Java software is subject to the Oracle Binary Code License Agreement for the Java SE Platform Products and JavaFX (which you acknowledge you have read and agree to) available at http://www.java.com/license.

       

       

      Setting up Install Process

      Resolving Dependencies

      --> Running transaction check

      ---> Package openssh-clients.x86_64 0:6.4p1-8.el7 will be installed

      --> Processing Dependency: openssh = 6.4p1-8.el7 for package: openssh-clients-6.4p1-8.el7.x86_64

      --> Processing Dependency: fipscheck-lib(x86-64) >= 1.3.0 for package: openssh-clients-6.4p1-8.el7.x86_64

      --> Processing Dependency: libedit.so.0()(64bit) for package: openssh-clients-6.4p1-8.el7.x86_64

      --> Running transaction check

      ---> Package fipscheck-lib.x86_64 0:1.2.0-7.el6 will be updated

      --> Processing Dependency: fipscheck-lib = 1.2.0-7.el6 for package: fipscheck-1.2.0-7.el6.x86_64

      ---> Package fipscheck-lib.x86_64 0:1.4.1-5.el7 will be an update

      ---> Package libedit.x86_64 0:3.0-12.20121213cvs.el7 will be installed

      ---> Package openssh.x86_64 0:5.3p1-94.el6 will be updated

      --> Processing Dependency: openssh = 5.3p1-94.el6 for package: openssh-server-5.3p1-94.el6.x86_64

      ---> Package openssh.x86_64 0:6.4p1-8.el7 will be an update

      --> Running transaction check

      ---> Package fipscheck.x86_64 0:1.2.0-7.el6 will be updated

      ---> Package fipscheck.x86_64 0:1.4.1-5.el7 will be an update

      ---> Package openssh-server.x86_64 0:5.3p1-94.el6 will be updated

      ---> Package openssh-server.x86_64 0:6.4p1-8.el7 will be an update

      --> Processing Dependency: systemd-units for package: openssh-server-6.4p1-8.el7.x86_64

      --> Processing Dependency: systemd-units for package: openssh-server-6.4p1-8.el7.x86_64

      --> Running transaction check

      ---> Package systemd.x86_64 0:208-11.0.1.el7_0.5 will be obsoleting

      --> Processing Dependency: systemd-libs = 208-11.0.1.el7_0.5 for package: systemd-208-11.0.1.el7_0.5.x86_64

      --> Processing Dependency: kmod >= 14 for package: systemd-208-11.0.1.el7_0.5.x86_64

      --> Processing Dependency: libudev.so.1(LIBUDEV_189)(64bit) for package: systemd-208-11.0.1.el7_0.5.x86_64

      --> Processing Dependency: libudev.so.1(LIBUDEV_183)(64bit) for package: systemd-208-11.0.1.el7_0.5.x86_64

      --> Processing Dependency: libsystemd-journal.so.0(LIBSYSTEMD_JOURNAL_183)(64bit) for package: systemd-208-11.0.1.el7_0.5.x86_64

      --> Processing Dependency: libsystemd-id128.so.0(LIBSYSTEMD_ID128_38)(64bit) for package: systemd-208-11.0.1.el7_0.5.x86_64

      --> Processing Dependency: libsystemd-daemon.so.0(LIBSYSTEMD_DAEMON_31)(64bit) for package: systemd-208-11.0.1.el7_0.5.x86_64

      --> Processing Dependency: liblzma.so.5(XZ_5.0)(64bit) for package: systemd-208-11.0.1.el7_0.5.x86_64

      --> Processing Dependency: libkmod.so.2(LIBKMOD_5)(64bit) for package: systemd-208-11.0.1.el7_0.5.x86_64

      --> Processing Dependency: libcryptsetup.so.4(CRYPTSETUP_1.0)(64bit) for package: systemd-208-11.0.1.el7_0.5.x86_64

      --> Processing Dependency: dbus for package: systemd-208-11.0.1.el7_0.5.x86_64

      --> Processing Dependency: libudev.so.1()(64bit) for package: systemd-208-11.0.1.el7_0.5.x86_64

      --> Processing Dependency: libsystemd-journal.so.0()(64bit) for package: systemd-208-11.0.1.el7_0.5.x86_64

      --> Processing Dependency: libsystemd-id128.so.0()(64bit) for package: systemd-208-11.0.1.el7_0.5.x86_64

      --> Processing Dependency: libsystemd-daemon.so.0()(64bit) for package: systemd-208-11.0.1.el7_0.5.x86_64

      --> Processing Dependency: libqrencode.so.3()(64bit) for package: systemd-208-11.0.1.el7_0.5.x86_64

      --> Processing Dependency: liblzma.so.5()(64bit) for package: systemd-208-11.0.1.el7_0.5.x86_64

      --> Processing Dependency: libkmod.so.2()(64bit) for package: systemd-208-11.0.1.el7_0.5.x86_64

      --> Processing Dependency: libcryptsetup.so.4()(64bit) for package: systemd-208-11.0.1.el7_0.5.x86_64

      ---> Package udev.x86_64 0:147-2.51.0.1.el6 will be obsoleted

      ---> Package upstart.x86_64 0:0.6.5-12.el6_4.1 will be obsoleted

      --> Processing Dependency: upstart >= 0.6.0 for package: initscripts-9.03.40-2.0.1.el6.x86_64

      --> Running transaction check

      ---> Package cryptsetup-reencrypt-libs.x86_64 0:1.6.4-1.el6 will be installed

      ---> Package dbus.x86_64 1:1.6.12-8.0.1.el7 will be installed

      --> Processing Dependency: dbus-libs(x86-64) = 1:1.6.12-8.0.1.el7 for package: 1:dbus-1.6.12-8.0.1.el7.x86_64

      ---> Package initscripts.x86_64 0:9.03.40-2.0.1.el6 will be updated

      ---> Package initscripts.x86_64 0:9.49.17-1.0.1.el7_0.1 will be an update

      --> Processing Dependency: hostname for package: initscripts-9.49.17-1.0.1.el7_0.1.x86_64

      --> Processing Dependency: /usr/bin/bash for package: initscripts-9.49.17-1.0.1.el7_0.1.x86_64

      ---> Package kmod.x86_64 0:14-9.el7 will be obsoleting

      --> Processing Dependency: /usr/bin/xz for package: kmod-14-9.el7.x86_64

      --> Processing Dependency: /usr/bin/cpio for package: kmod-14-9.el7.x86_64

      ---> Package kmod-libs.x86_64 0:14-9.el7 will be installed

      ---> Package libudev.x86_64 0:147-2.51.0.1.el6 will be obsoleted

      --> Processing Dependency: libudev.so.0()(64bit) for package: device-mapper-libs-1.02.79-8.el6.x86_64

      --> Processing Dependency: libudev.so.0()(64bit) for package: libgudev1-147-2.51.0.1.el6.x86_64

      --> Processing Dependency: libudev.so.0()(64bit) for package: lvm2-2.02.100-8.el6.x86_64

      --> Processing Dependency: libudev.so.0()(64bit) for package: device-mapper-1.02.79-8.el6.x86_64

      --> Processing Dependency: libudev.so.0()(64bit) for package: lvm2-libs-2.02.100-8.el6.x86_64

      --> Processing Dependency: libudev for package: device-mapper-1.02.79-8.el6.x86_64

      --> Processing Dependency: libudev >= 142 for package: libgudev1-147-2.51.0.1.el6.x86_64

      --> Processing Dependency: libudev = 147-2.51.0.1.el6 for package: libgudev1-147-2.51.0.1.el6.x86_64

      ---> Package module-init-tools.x86_64 0:3.9-21.0.1.el6_4 will be obsoleted

      ---> Package qrencode-libs.x86_64 0:3.4.1-3.el7 will be installed

      ---> Package systemd-libs.x86_64 0:208-11.0.1.el7_0.5 will be obsoleting

      ---> Package xz-libs.x86_64 0:4.999.9-0.3.beta.20091007git.el6 will be updated

      --> Processing Dependency: liblzma.so.0()(64bit) for package: rpm-libs-4.8.0-37.el6.x86_64

      --> Processing Dependency: liblzma.so.0()(64bit) for package: python-deltarpm-3.5-0.5.20090913git.el6.x86_64

      --> Processing Dependency: liblzma.so.0()(64bit) for package: deltarpm-3.5-0.5.20090913git.el6.x86_64

      --> Processing Dependency: liblzma.so.0()(64bit) for package: rpm-python-4.8.0-37.el6.x86_64

      --> Processing Dependency: liblzma.so.0()(64bit) for package: rpm-4.8.0-37.el6.x86_64

      ---> Package xz-libs.x86_64 0:5.1.2-8alpha.el7 will be an update

      --> Running transaction check

      ---> Package bash.x86_64 0:4.1.2-15.el6_4 will be updated

      ---> Package bash.x86_64 0:4.2.45-5.el7_0.4.0.1 will be an update

      ---> Package cpio.x86_64 0:2.10-11.el6_3 will be updated

      ---> Package cpio.x86_64 0:2.11-22.el7 will be an update

      ---> Package dbus-libs.x86_64 1:1.2.24-7.0.1.el6_3 will be updated

      ---> Package dbus-libs.x86_64 1:1.6.12-8.0.1.el7 will be an update

      ---> Package deltarpm.x86_64 0:3.5-0.5.20090913git.el6 will be updated

      ---> Package deltarpm.x86_64 0:3.6-3.el7 will be an update

      ---> Package device-mapper.x86_64 0:1.02.79-8.el6 will be updated

      --> Processing Dependency: device-mapper = 1.02.79-8.el6 for package: device-mapper-event-1.02.79-8.el6.x86_64

      ---> Package device-mapper.x86_64 7:1.02.84-14.el7 will be an update

      --> Processing Dependency: util-linux >= 2.23 for package: 7:device-mapper-1.02.84-14.el7.x86_64

      ---> Package device-mapper-libs.x86_64 0:1.02.79-8.el6 will be updated

      ---> Package device-mapper-libs.x86_64 7:1.02.84-14.el7 will be an update

      ---> Package hostname.x86_64 0:3.13-3.el7 will be installed

      ---> Package libgudev1.x86_64 0:147-2.51.0.1.el6 will be updated

      ---> Package libgudev1.x86_64 0:208-11.0.1.el7_0.5 will be an update

      ---> Package lvm2.x86_64 0:2.02.100-8.el6 will be updated

      ---> Package lvm2.x86_64 7:2.02.105-14.el7 will be an update

      ---> Package lvm2-libs.x86_64 0:2.02.100-8.el6 will be updated

      ---> Package lvm2-libs.x86_64 7:2.02.105-14.el7 will be an update

      ---> Package python-deltarpm.x86_64 0:3.5-0.5.20090913git.el6 will be updated

      ---> Package python-deltarpm.x86_64 0:3.6-3.el7 will be an update

      --> Processing Dependency: python(abi) = 2.7 for package: python-deltarpm-3.6-3.el7.x86_64

      ---> Package rpm.x86_64 0:4.8.0-37.el6 will be updated

      ---> Package rpm.x86_64 0:4.11.1-18.el7_0 will be an update

      --> Processing Dependency: libdb-5.3.so()(64bit) for package: rpm-4.11.1-18.el7_0.x86_64

      ---> Package rpm-libs.x86_64 0:4.8.0-37.el6 will be updated

      ---> Package rpm-libs.x86_64 0:4.11.1-18.el7_0 will be an update

      ---> Package rpm-python.x86_64 0:4.8.0-37.el6 will be updated

      ---> Package rpm-python.x86_64 0:4.11.1-18.el7_0 will be an update

      --> Processing Dependency: librpmsign.so.1()(64bit) for package: rpm-python-4.11.1-18.el7_0.x86_64

      --> Processing Dependency: librpmbuild.so.3()(64bit) for package: rpm-python-4.11.1-18.el7_0.x86_64

      --> Processing Dependency: libpython2.7.so.1.0()(64bit) for package: rpm-python-4.11.1-18.el7_0.x86_64

      ---> Package xz.x86_64 0:5.1.2-8alpha.el7 will be installed

      --> Running transaction check

      ---> Package db4.x86_64 0:4.7.25-18.el6_4 will be obsoleted

      --> Processing Dependency: libdb-4.7.so()(64bit) for package: httpd-tools-2.2.15-29.0.1.el6_4.x86_64

      --> Processing Dependency: libdb-4.7.so()(64bit) for package: httpd-2.2.15-29.0.1.el6_4.x86_64

      --> Processing Dependency: libdb-4.7.so()(64bit) for package: db4-utils-4.7.25-18.el6_4.x86_64

      --> Processing Dependency: libdb-4.7.so()(64bit) for package: apr-util-1.3.9-3.el6_0.1.x86_64

      --> Processing Dependency: libdb-4.7.so()(64bit) for package: cyrus-sasl-lib-2.1.23-13.el6_3.1.x86_64

      --> Processing Dependency: libdb-4.7.so()(64bit) for package: iproute-2.6.32-31.el6.x86_64

      --> Processing Dependency: libdb-4.7.so()(64bit) for package: cyrus-sasl-2.1.23-13.el6_3.1.x86_64

      --> Processing Dependency: libdb-4.7.so()(64bit) for package: 4:perl-5.10.1-136.el6.x86_64

      --> Processing Dependency: libdb-4.7.so()(64bit) for package: 2:postfix-2.6.6-2.2.el6_1.x86_64

      --> Processing Dependency: libdb-4.7.so()(64bit) for package: pam-1.1.1-17.el6.x86_64

      --> Processing Dependency: db4 = 4.7.25-18.el6_4 for package: db4-utils-4.7.25-18.el6_4.x86_64

      ---> Package device-mapper-event.x86_64 0:1.02.79-8.el6 will be updated

      ---> Package device-mapper-event.x86_64 7:1.02.84-14.el7 will be an update

      --> Processing Dependency: device-mapper-event-libs = 7:1.02.84-14.el7 for package: 7:device-mapper-event-1.02.84-14.el7.x86_64

      ---> Package libdb.x86_64 0:5.3.21-17.el7_0.1 will be obsoleting

      ---> Package python.x86_64 0:2.6.6-51.el6 will be updated

      --> Processing Dependency: python(abi) = 2.6 for package: rhnlib-2.5.22-15.0.1.el6.noarch

      --> Processing Dependency: python(abi) = 2.6 for package: python-urlgrabber-3.9.1-9.el6.noarch

      --> Processing Dependency: python(abi) = 2.6 for package: python-ethtool-0.6-5.el6.x86_64

      --> Processing Dependency: python(abi) = 2.6 for package: pygobject2-2.20.0-5.el6.x86_64

      --> Processing Dependency: python(abi) = 2.6 for package: yum-3.2.29-40.0.1.el6.noarch

      --> Processing Dependency: python(abi) = 2.6 for package: python-iniparse-0.3.1-2.1.el6.noarch

      --> Processing Dependency: python(abi) = 2.6 for package: yum-metadata-parser-1.1.2-16.el6.x86_64

      --> Processing Dependency: python(abi) = 2.6 for package: yum-utils-1.1.30-14.0.1.el6.noarch

      --> Processing Dependency: python(abi) = 2.6 for package: pyOpenSSL-0.10-2.el6.x86_64

      --> Processing Dependency: python(abi) = 2.6 for package: m2crypto-0.20.2-9.el6.x86_64

      --> Processing Dependency: python(abi) = 2.6 for package: newt-python-0.52.11-3.el6.x86_64

      --> Processing Dependency: python(abi) = 2.6 for package: python-pycurl-7.19.0-8.el6.x86_64

      --> Processing Dependency: python(abi) = 2.6 for package: libxml2-python-2.7.6-14.0.1.el6.x86_64

      --> Processing Dependency: python(abi) = 2.6 for package: pygpgme-0.1-18.20090824bzr68.el6.x86_64

      --> Processing Dependency: python(abi) = 2.6 for package: createrepo-0.9.9-18.0.1.el6.noarch

      --> Processing Dependency: python(abi) = 2.6 for package: dbus-python-0.83.0-6.1.el6.x86_64

      --> Processing Dependency: python(abi) = 2.6 for package: python-gudev-147.1-4.el6_0.1.x86_64

      --> Processing Dependency: python(abi) = 2.6 for package: authconfig-6.1.12-13.el6.x86_64

      --> Processing Dependency: python(abi) = 2.6 for package: python-dmidecode-3.10.13-3.el6_4.x86_64

      ---> Package python.x86_64 0:2.7.5-16.el7 will be an update

      ---> Package python-libs.x86_64 0:2.6.6-51.el6 will be updated

      --> Processing Dependency: libpython2.6.so.1.0()(64bit) for package: 2:vim-enhanced-7.2.411-1.8.el6.x86_64

      ---> Package python-libs.x86_64 0:2.7.5-16.el7 will be an update

      --> Processing Dependency: expat >= 2.1.0 for package: python-libs-2.7.5-16.el7.x86_64

      --> Processing Dependency: libgdbm_compat.so.4()(64bit) for package: python-libs-2.7.5-16.el7.x86_64

      --> Processing Dependency: libgdbm.so.4()(64bit) for package: python-libs-2.7.5-16.el7.x86_64

      --> Processing Dependency: libffi.so.6()(64bit) for package: python-libs-2.7.5-16.el7.x86_64

      ---> Package rpm-build-libs.x86_64 0:4.11.1-18.el7_0 will be installed

      ---> Package util-linux.x86_64 0:2.23.2-16.el7 will be obsoleting

      --> Processing Dependency: libuuid = 2.23.2-16.el7 for package: util-linux-2.23.2-16.el7.x86_64

      --> Processing Dependency: libmount = 2.23.2-16.el7 for package: util-linux-2.23.2-16.el7.x86_64

      --> Processing Dependency: libblkid = 2.23.2-16.el7 for package: util-linux-2.23.2-16.el7.x86_64

      --> Processing Dependency: libmount.so.1(MOUNT_2.23)(64bit) for package: util-linux-2.23.2-16.el7.x86_64

      --> Processing Dependency: libmount.so.1(MOUNT_2.22)(64bit) for package: util-linux-2.23.2-16.el7.x86_64

      --> Processing Dependency: libmount.so.1(MOUNT_2.21)(64bit) for package: util-linux-2.23.2-16.el7.x86_64

      --> Processing Dependency: libmount.so.1(MOUNT_2.20)(64bit) for package: util-linux-2.23.2-16.el7.x86_64

      --> Processing Dependency: libmount.so.1(MOUNT_2.19)(64bit) for package: util-linux-2.23.2-16.el7.x86_64

      --> Processing Dependency: libblkid.so.1(BLKID_2.21)(64bit) for package: util-linux-2.23.2-16.el7.x86_64

      --> Processing Dependency: libblkid.so.1(BLKID_2.20)(64bit) for package: util-linux-2.23.2-16.el7.x86_64

      --> Processing Dependency: libmount.so.1()(64bit) for package: util-linux-2.23.2-16.el7.x86_64

      ---> Package util-linux-ng.x86_64 0:2.17.2-12.14.el6 will be obsoleted

      --> Processing Dependency: mount for package: dracut-004-335.0.1.el6.noarch

      --> Running transaction check

      ---> Package apr-util.x86_64 0:1.3.9-3.el6_0.1 will be updated

      --> Processing Dependency: apr-util = 1.3.9-3.el6_0.1 for package: apr-util-ldap-1.3.9-3.el6_0.1.x86_64

      ---> Package apr-util.x86_64 0:1.5.2-6.0.1.el7 will be an update

      ---> Package authconfig.x86_64 0:6.1.12-13.el6 will be updated

      ---> Package authconfig.x86_64 0:6.2.8-8.el7 will be an update

      --> Processing Dependency: libpwquality > 0.9 for package: authconfig-6.2.8-8.el7.x86_64

      ---> Package createrepo.noarch 0:0.9.9-18.0.1.el6 will be updated

      ---> Package createrepo.noarch 0:0.9.9-23.el7 will be an update

      --> Processing Dependency: pyliblzma for package: createrepo-0.9.9-23.el7.noarch

      ---> Package cyrus-sasl.x86_64 0:2.1.23-13.el6_3.1 will be updated

      ---> Package cyrus-sasl.x86_64 0:2.1.26-17.0.1.el7 will be an update

      ---> Package cyrus-sasl-lib.x86_64 0:2.1.23-13.el6_3.1 will be updated

      --> Processing Dependency: libsasl2.so.2()(64bit) for package: openldap-2.4.23-32.el6_4.1.x86_64

      ---> Package cyrus-sasl-lib.x86_64 0:2.1.26-17.0.1.el7 will be an update

      ---> Package db4-utils.x86_64 0:4.7.25-18.el6_4 will be obsoleted

      ---> Package dbus-python.x86_64 0:0.83.0-6.1.el6 will be updated

      ---> Package dbus-python.x86_64 0:1.1.1-9.el7 will be an update

      ---> Package device-mapper-event-libs.x86_64 0:1.02.79-8.el6 will be updated

      ---> Package device-mapper-event-libs.x86_64 7:1.02.84-14.el7 will be an update

      ---> Package dracut.noarch 0:004-335.0.1.el6 will be obsoleted

      ---> Package dracut.noarch 0:004-335.0.1.el6 will be updated

      ---> Package dracut.x86_64 0:033-161.el7_0.173 will be obsoleting

      --> Processing Dependency: procps-ng for package: dracut-033-161.el7_0.173.x86_64

      --> Processing Dependency: kpartx for package: dracut-033-161.el7_0.173.x86_64

      --> Processing Dependency: hardlink for package: dracut-033-161.el7_0.173.x86_64

      ---> Package dracut-config-rescue.x86_64 0:033-161.el7_0.173 will be obsoleting

      ---> Package dracut-kernel.noarch 0:004-335.0.1.el6 will be obsoleted

      ---> Package expat.x86_64 0:2.0.1-11.el6_2 will be updated

      ---> Package expat.x86_64 0:2.1.0-8.el7 will be an update

      ---> Package gdbm.x86_64 0:1.8.0-36.el6 will be updated

      ---> Package gdbm.x86_64 0:1.10-8.el7 will be an update

      ---> Package httpd.x86_64 0:2.2.15-29.0.1.el6_4 will be updated

      ---> Package httpd.x86_64 0:2.4.6-18.0.1.el7_0 will be an update

      --> Processing Dependency: libpcre.so.1()(64bit) for package: httpd-2.4.6-18.0.1.el7_0.x86_64

      ---> Package httpd-tools.x86_64 0:2.2.15-29.0.1.el6_4 will be updated

      ---> Package httpd-tools.x86_64 0:2.4.6-18.0.1.el7_0 will be an update

      ---> Package iproute.x86_64 0:2.6.32-31.el6 will be updated

      ---> Package iproute.x86_64 0:3.10.0-13.el7 will be an update

      --> Processing Dependency: libxtables.so.10()(64bit) for package: iproute-3.10.0-13.el7.x86_64

      ---> Package libblkid.x86_64 0:2.17.2-12.14.el6 will be updated

      ---> Package libblkid.x86_64 0:2.23.2-16.el7 will be an update

      ---> Package libdb-utils.x86_64 0:5.3.21-17.el7_0.1 will be obsoleting

      ---> Package libffi.x86_64 0:3.0.5-3.2.el6 will be updated

      ---> Package libffi.x86_64 0:3.0.13-11.el7 will be an update

      ---> Package libmount.x86_64 0:2.23.2-16.el7 will be installed

      ---> Package libuuid.x86_64 0:2.17.2-12.14.el6 will be updated

      ---> Package libuuid.x86_64 0:2.23.2-16.el7 will be an update

      ---> Package libxml2-python.x86_64 0:2.7.6-14.0.1.el6 will be updated

      ---> Package libxml2-python.x86_64 0:2.9.1-5.0.1.el7_0.1 will be an update

      --> Processing Dependency: libxml2 = 2.9.1-5.0.1.el7_0.1 for package: libxml2-python-2.9.1-5.0.1.el7_0.1.x86_64

      --> Processing Dependency: libxml2.so.2(LIBXML2_2.9.1)(64bit) for package: libxml2-python-2.9.1-5.0.1.el7_0.1.x86_64

      --> Processing Dependency: libxml2.so.2(LIBXML2_2.9.0)(64bit) for package: libxml2-python-2.9.1-5.0.1.el7_0.1.x86_64

      --> Processing Dependency: libxml2.so.2(LIBXML2_2.8.0)(64bit) for package: libxml2-python-2.9.1-5.0.1.el7_0.1.x86_64

      ---> Package m2crypto.x86_64 0:0.20.2-9.el6 will be updated

      ---> Package m2crypto.x86_64 0:0.21.1-15.el7 will be an update

      ---> Package newt-python.x86_64 0:0.52.11-3.el6 will be updated

      ---> Package newt-python.x86_64 0:0.52.15-4.el7 will be an update

      --> Processing Dependency: newt(x86-64) = 0.52.15-4.el7 for package: newt-python-0.52.15-4.el7.x86_64

      ---> Package pam.x86_64 0:1.1.1-17.el6 will be updated

      ---> Package pam.x86_64 0:1.1.8-9.el7 will be an update

      ---> Package perl.x86_64 4:5.10.1-136.el6 will be updated

      --> Processing Dependency: perl(Carp) for package: 4:perl-5.16.3-283.el7.x86_64

      --> Processing Dependency: perl(Carp) for package: 1:perl-Module-Pluggable-3.90-136.el6.x86_64

      --> Processing Dependency: perl(Carp) for package: 1:perl-Pod-Simple-3.13-136.el6.x86_64

      --> Processing Dependency: perl(Carp) for package: 4:perl-5.16.3-283.el7.x86_64

      --> Processing Dependency: perl(Cwd) for package: 4:perl-5.16.3-283.el7.x86_64

      --> Processing Dependency: perl(Cwd) for package: 4:perl-5.16.3-283.el7.x86_64

      --> Processing Dependency: perl(Cwd) for package: 1:perl-Pod-Simple-3.13-136.el6.x86_64

      --> Processing Dependency: perl(Encode) for package: 1:perl-Pod-Simple-3.13-136.el6.x86_64

      --> Processing Dependency: perl(Exporter) for package: 4:perl-5.16.3-283.el7.x86_64

      --> Processing Dependency: perl(Exporter) for package: 1:perl-Pod-Escapes-1.04-136.el6.x86_64

      --> Processing Dependency: perl(Exporter) for package: 4:perl-5.16.3-283.el7.x86_64

      --> Processing Dependency: perl(File::Path) for package: 4:perl-5.16.3-283.el7.x86_64

      --> Processing Dependency: perl(File::Path) for package: 4:perl-5.16.3-283.el7.x86_64

      --> Processing Dependency: perl(File::Spec) for package: 4:perl-5.16.3-283.el7.x86_64

      --> Processing Dependency: perl(File::Spec) for package: 4:perl-5.16.3-283.el7.x86_64

      --> Processing Dependency: perl(File::Spec) for package: 1:perl-Pod-Simple-3.13-136.el6.x86_64

      --> Processing Dependency: perl(File::Spec::Functions) for package: 4:perl-5.16.3-283.el7.x86_64

      --> Processing Dependency: perl(File::Spec::Functions) for package: 1:perl-Module-Pluggable-3.90-136.el6.x86_64

      --> Processing Dependency: perl(File::Spec::Functions) for package: 4:perl-5.16.3-283.el7.x86_64

      --> Processing Dependency: perl(File::Spec::Unix) for package: 4:perl-5.16.3-283.el7.x86_64

      --> Processing Dependency: perl(File::Spec::Unix) for package: 4:perl-5.16.3-283.el7.x86_64

      --> Processing Dependency: perl(File::Temp) for package: kernel-uek-doc-3.8.13-16.2.1.el6uek.noarch

      --> Processing Dependency: perl(File::Temp) for package: 4:perl-5.16.3-283.el7.x86_64

      --> Processing Dependency: perl(File::Temp) for package: 4:perl-5.16.3-283.el7.x86_64

      --> Processing Dependency: perl(Filter::Util::Call) for package: 4:perl-5.16.3-283.el7.x86_64

      --> Processing Dependency: perl(Filter::Util::Call) for package: 4:perl-5.16.3-283.el7.x86_64

      --> Processing Dependency: perl(Getopt::Long) for package: 4:perl-5.16.3-283.el7.x86_64

      --> Processing Dependency: perl(Getopt::Long) for package: 4:perl-5.16.3-283.el7.x86_64

      --> Processing Dependency: perl(Getopt::Long) for package: 1:perl-Pod-Simple-3.13-136.el6.x86_64

      --> Processing Dependency: perl(Scalar::Util) >= 1.10 for package: 4:perl-5.16.3-283.el7.x86_64

      --> Processing Dependency: perl(Scalar::Util) for package: 4:perl-5.16.3-283.el7.x86_64

      --> Processing Dependency: perl(Scalar::Util) >= 1.10 for package: 4:perl-5.16.3-283.el7.x86_64

      --> Processing Dependency: perl(Scalar::Util) for package: 4:perl-5.16.3-283.el7.x86_64

      --> Processing Dependency: perl(Socket) >= 1.3 for package: 4:perl-5.16.3-283.el7.x86_64

      --> Processing Dependency: perl(Socket) for package: 4:perl-5.16.3-283.el7.x86_64

      --> Processing Dependency: perl(Socket) >= 1.3 for package: 4:perl-5.16.3-283.el7.x86_64

      --> Processing Dependency: perl(Socket) for package: 4:perl-5.16.3-283.el7.x86_64

      --> Processing Dependency: perl(Storable) for package: 4:perl-5.16.3-283.el7.x86_64

      --> Processing Dependency: perl(Storable) for package: 4:perl-5.16.3-283.el7.x86_64

      --> Processing Dependency: perl(Storable) for package: 4:perl-5.16.3-283.el7.x86_64

      --> Processing Dependency: perl(Storable) for package: 4:perl-5.16.3-283.el7.x86_64

      --> Processing Dependency: perl(Time::Local) for package: 4:perl-5.16.3-283.el7.x86_64

      --> Processing Dependency: perl(Time::Local) for package: 4:perl-5.16.3-283.el7.x86_64

      --> Processing Dependency: perl(constant) for package: 4:perl-5.16.3-283.el7.x86_64

      --> Processing Dependency: perl(constant) for package: 4:perl-5.16.3-283.el7.x86_64

      --> Processing Dependency: perl(threads) for package: 4:perl-5.16.3-283.el7.x86_64

      --> Processing Dependency: perl(threads) for package: 4:perl-5.16.3-283.el7.x86_64

      --> Processing Dependency: perl(threads::shared) for package: 4:perl-5.16.3-283.el7.x86_64

      --> Processing Dependency: perl(threads::shared) for package: 4:perl-5.16.3-283.el7.x86_64

      --> Processing Dependency: perl = 4:5.10.1-136.el6 for package: 1:perl-Module-Pluggable-3.90-136.el6.x86_64

      --> Processing Dependency: perl = 4:5.10.1-136.el6 for package: 4:perl-libs-5.10.1-136.el6.x86_64

      --> Processing Dependency: perl = 4:5.10.1-136.el6 for package: 3:perl-version-0.77-136.el6.x86_64

      --> Processing Dependency: perl = 4:5.10.1-136.el6 for package: 1:perl-Pod-Simple-3.13-136.el6.x86_64

      --> Processing Dependency: perl = 4:5.10.1-136.el6 for package: 1:perl-Pod-Escapes-1.04-136.el6.x86_64

      ---> Package perl.x86_64 4:5.16.3-283.el7 will be an update

      --> Processing Dependency: perl-macros for package: 4:perl-5.16.3-283.el7.x86_64

      ---> Package postfix.x86_64 2:2.6.6-2.2.el6_1 will be updated

      ---> Package postfix.x86_64 2:2.10.1-6.0.1.el7 will be an update

      --> Processing Dependency: systemd-sysv for package: 2:postfix-2.10.1-6.0.1.el7.x86_64

      --> Processing Dependency: libmysqlclient.so.18(libmysqlclient_18)(64bit) for package: 2:postfix-2.10.1-6.0.1.el7.x86_64

      --> Processing Dependency: libmysqlclient.so.18()(64bit) for package: 2:postfix-2.10.1-6.0.1.el7.x86_64

      ---> Package pyOpenSSL.x86_64 0:0.10-2.el6 will be updated

      ---> Package pyOpenSSL.x86_64 0:0.13.1-3.el7 will be an update

      ---> Package pygobject2.x86_64 0:2.20.0-5.el6 will be updated

      ---> Package pygobject2.x86_64 0:2.28.6-11.el7 will be an update

      ---> Package pygpgme.x86_64 0:0.1-18.20090824bzr68.el6 will be updated

      ---> Package pygpgme.x86_64 0:0.3-9.el7 will be an update

      ---> Package python-dmidecode.x86_64 0:3.10.13-3.el6_4 will be updated

      ---> Package python-dmidecode.x86_64 0:3.10.13-11.el7 will be an update

      ---> Package python-ethtool.x86_64 0:0.6-5.el6 will be updated

      ---> Package python-ethtool.x86_64 0:0.8-5.el7 will be an update

      ---> Package python-gudev.x86_64 0:147.1-4.el6_0.1 will be updated

      ---> Package python-gudev.x86_64 0:147.2-7.el7 will be an update

      ---> Package python-iniparse.noarch 0:0.3.1-2.1.el6 will be updated

      ---> Package python-iniparse.noarch 0:0.4-9.el7 will be an update

      ---> Package python-pycurl.x86_64 0:7.19.0-8.el6 will be updated

      ---> Package python-pycurl.x86_64 0:7.19.0-17.el7 will be an update

      --> Processing Dependency: libcurl >= 7.29.0 for package: python-pycurl-7.19.0-17.el7.x86_64

      ---> Package python-urlgrabber.noarch 0:3.9.1-9.el6 will be updated

      ---> Package python-urlgrabber.noarch 0:3.10-4.el7 will be an update

      ---> Package rhnlib.noarch 0:2.5.22-15.0.1.el6 will be updated

      ---> Package rhnlib.noarch 0:2.5.71-1.el7 will be an update

      ---> Package vim-enhanced.x86_64 2:7.2.411-1.8.el6 will be updated

      ---> Package vim-enhanced.x86_64 2:7.4.160-1.el7 will be an update

      --> Processing Dependency: vim-common = 2:7.4.160-1.el7 for package: 2:vim-enhanced-7.4.160-1.el7.x86_64

      ---> Package yum.noarch 0:3.2.29-40.0.1.el6 will be updated

      ---> Package yum.noarch 0:3.4.3-118.0.2.el7 will be an update

      --> Processing Dependency: pyxattr for package: yum-3.4.3-118.0.2.el7.noarch

      ---> Package yum-metadata-parser.x86_64 0:1.1.2-16.el6 will be updated

      ---> Package yum-metadata-parser.x86_64 0:1.1.4-10.el7 will be an update

      ---> Package yum-utils.noarch 0:1.1.30-14.0.1.el6 will be updated

      ---> Package yum-utils.noarch 0:1.1.31-25.0.1.el7_0 will be an update

      --> Processing Dependency: python-kitchen for package: yum-utils-1.1.31-25.0.1.el7_0.noarch

      --> Running transaction check

      ---> Package apr-util-ldap.x86_64 0:1.3.9-3.el6_0.1 will be updated

      ---> Package apr-util-ldap.x86_64 0:1.5.2-6.0.1.el7 will be an update

      ---> Package hardlink.x86_64 1:1.0-19.el7 will be installed

      ---> Package iptables.x86_64 0:1.4.7-11.0.1.el6 will be updated

      --> Processing Dependency: libxtables.so.4()(64bit) for package: iptables-ipv6-1.4.7-11.0.1.el6.x86_64

      --> Processing Dependency: iptables = 1.4.7-11.0.1.el6 for package: iptables-ipv6-1.4.7-11.0.1.el6.x86_64

      ---> Package iptables.x86_64 0:1.4.21-13.el7 will be an update

      --> Processing Dependency: libnfnetlink.so.0()(64bit) for package: iptables-1.4.21-13.el7.x86_64

      --> Processing Dependency: libnetfilter_conntrack.so.3()(64bit) for package: iptables-1.4.21-13.el7.x86_64

      ---> Package kernel-uek-doc.noarch 0:3.8.13-16.2.1.el6uek will be updated

      ---> Package kernel-uek-doc.noarch 0:3.8.13-55.1.2.el7uek will be an update

      ---> Package kpartx.x86_64 0:0.4.9-80.0.1.el6_6.1 will be installed

      ---> Package libcurl.x86_64 0:7.19.7-37.el6_4 will be updated

      --> Processing Dependency: libcurl = 7.19.7-37.el6_4 for package: curl-7.19.7-37.el6_4.x86_64

      ---> Package libcurl.x86_64 0:7.29.0-19.el7 will be an update

      --> Processing Dependency: libssh2(x86-64) >= 1.4.3 for package: libcurl-7.29.0-19.el7.x86_64

      ---> Package libpwquality.x86_64 0:1.2.3-4.el7 will be installed

      ---> Package libxml2.x86_64 0:2.7.6-14.0.1.el6 will be updated

      ---> Package libxml2.x86_64 0:2.9.1-5.0.1.el7_0.1 will be an update

      --> Processing Dependency: libz.so.1(ZLIB_1.2.3.3)(64bit) for package: libxml2-2.9.1-5.0.1.el7_0.1.x86_64

      ---> Package mariadb-libs.x86_64 1:5.5.40-2.el7_0 will be obsoleting

      ---> Package mysql-libs.x86_64 0:5.1.71-1.el6 will be obsoleted

      ---> Package newt.x86_64 0:0.52.11-3.el6 will be updated

      ---> Package newt.x86_64 0:0.52.15-4.el7 will be an update

      ---> Package openldap.x86_64 0:2.4.23-32.el6_4.1 will be updated

      ---> Package openldap.x86_64 0:2.4.39-8.el6 will be an update

      ---> Package pcre.x86_64 0:7.8-6.el6 will be updated

      --> Processing Dependency: libpcre.so.0()(64bit) for package: less-436-10.el6.x86_64

      --> Processing Dependency: libpcre.so.0()(64bit) for package: grep-2.6.3-4.el6.x86_64

      ---> Package pcre.x86_64 0:8.32-12.el7 will be an update

      ---> Package perl-Carp.noarch 0:1.26-244.el7 will be installed

      ---> Package perl-Exporter.noarch 0:5.68-3.el7 will be installed

      ---> Package perl-File-Path.noarch 0:2.09-2.el7 will be installed

      ---> Package perl-File-Temp.noarch 0:0.23.01-3.el7 will be installed

      ---> Package perl-Filter.x86_64 0:1.49-3.el7 will be installed

      ---> Package perl-Getopt-Long.noarch 0:2.40-2.el7 will be installed

      --> Processing Dependency: perl(Pod::Usage) >= 1.14 for package: perl-Getopt-Long-2.40-2.el7.noarch

      --> Processing Dependency: perl(Text::ParseWords) for package: perl-Getopt-Long-2.40-2.el7.noarch

      ---> Package perl-Module-Pluggable.x86_64 1:3.90-136.el6 will be updated

      ---> Package perl-Module-Pluggable.noarch 1:4.8-3.el7 will be an update

      ---> Package perl-Module-Pluggable.noarch 1:4.8-3.el7 will be an update

      ---> Package perl-PathTools.x86_64 0:3.40-5.el7 will be installed

      ---> Package perl-Pod-Escapes.x86_64 1:1.04-136.el6 will be updated

      ---> Package perl-Pod-Escapes.noarch 1:1.04-283.el7 will be an update

      ---> Package perl-Pod-Simple.x86_64 1:3.13-136.el6 will be updated

      ---> Package perl-Pod-Simple.noarch 1:3.28-4.el7 will be an update

      ---> Package perl-Scalar-List-Utils.x86_64 0:1.27-248.el7 will be installed

      ---> Package perl-Socket.x86_64 0:2.010-3.el7 will be installed

      ---> Package perl-Storable.x86_64 0:2.45-3.el7 will be installed

      ---> Package perl-Time-Local.noarch 0:1.2300-2.el7 will be installed

      ---> Package perl-constant.noarch 0:1.27-2.el7 will be installed

      ---> Package perl-libs.x86_64 4:5.10.1-136.el6 will be updated

      ---> Package perl-libs.x86_64 4:5.16.3-283.el7 will be an update

      ---> Package perl-macros.x86_64 4:5.16.3-283.el7 will be installed

      ---> Package perl-threads.x86_64 0:1.87-4.el7 will be installed

      ---> Package perl-threads-shared.x86_64 0:1.43-6.el7 will be installed

      ---> Package perl-version.x86_64 3:0.77-136.el6 will be updated

      ---> Package perl-version.x86_64 3:0.99.07-2.el7 will be an update

      ---> Package procps.x86_64 0:3.2.8-25.el6 will be obsoleted

      ---> Package procps-ng.x86_64 0:3.3.9-6.el7 will be obsoleting

      ---> Package pyliblzma.x86_64 0:0.5.3-11.el7 will be installed

      ---> Package python-kitchen.noarch 0:1.1.1-5.el7 will be installed

      --> Processing Dependency: python-chardet for package: python-kitchen-1.1.1-5.el7.noarch

      ---> Package pyxattr.x86_64 0:0.5.1-5.el7 will be installed

      ---> Package systemd-sysv.x86_64 0:208-11.0.1.el7_0.5 will be installed

      ---> Package vim-common.x86_64 2:7.2.411-1.8.el6 will be updated

      ---> Package vim-common.x86_64 2:7.4.160-1.el7 will be an update

      --> Processing Dependency: vim-filesystem for package: 2:vim-common-7.4.160-1.el7.x86_64

      --> Running transaction check

      ---> Package curl.x86_64 0:7.19.7-37.el6_4 will be updated

      ---> Package curl.x86_64 0:7.29.0-19.el7 will be an update

      ---> Package grep.x86_64 0:2.6.3-4.el6 will be updated

      ---> Package grep.x86_64 0:2.16-1.el7 will be an update

      ---> Package iptables-ipv6.x86_64 0:1.4.7-11.0.1.el6 will be updated

      ---> Package iptables-ipv6.x86_64 0:1.4.7-14.0.1.el6 will be an update

      --> Processing Dependency: iptables = 1.4.7-14.0.1.el6 for package: iptables-ipv6-1.4.7-14.0.1.el6.x86_64

      Package iptables is obsoleted by iptables-services, but obsoleting package does not provide for requirements

      ---> Package less.x86_64 0:436-10.el6 will be updated

      ---> Package less.x86_64 0:458-8.el7 will be an update

      --> Processing Dependency: groff-base for package: less-458-8.el7.x86_64

      ---> Package libnetfilter_conntrack.x86_64 0:1.0.4-2.el7 will be installed

      --> Processing Dependency: libmnl.so.0(LIBMNL_1.1)(64bit) for package: libnetfilter_conntrack-1.0.4-2.el7.x86_64

      --> Processing Dependency: libmnl.so.0(LIBMNL_1.0)(64bit) for package: libnetfilter_conntrack-1.0.4-2.el7.x86_64

      --> Processing Dependency: libmnl.so.0()(64bit) for package: libnetfilter_conntrack-1.0.4-2.el7.x86_64

      ---> Package libnfnetlink.x86_64 0:1.0.1-4.el7 will be installed

      ---> Package libssh2.x86_64 0:1.4.2-1.el6 will be updated

      ---> Package libssh2.x86_64 0:1.4.3-8.el7 will be an update

      ---> Package perl-Pod-Usage.noarch 0:1.63-3.el7 will be installed

      --> Processing Dependency: perl(Pod::Text) >= 3.15 for package: perl-Pod-Usage-1.63-3.el7.noarch

      --> Processing Dependency: perl-Pod-Perldoc for package: perl-Pod-Usage-1.63-3.el7.noarch

      ---> Package perl-Text-ParseWords.noarch 0:3.29-4.el7 will be installed

      ---> Package python-chardet.noarch 0:2.0.1-7.el7 will be installed

      ---> Package vim-filesystem.x86_64 2:7.4.160-1.el7 will be installed

      ---> Package zlib.x86_64 0:1.2.3-29.el6 will be updated

      ---> Package zlib.x86_64 0:1.2.7-13.el7 will be an update

      --> Running transaction check

      ---> Package groff-base.x86_64 0:1.22.2-8.el7 will be installed

      ---> Package iptables.x86_64 0:1.4.7-11.0.1.el6 will be obsoleted

      --> Processing Dependency: libxtables.so.4()(64bit) for package: iptables-ipv6-1.4.7-14.0.1.el6.x86_64

      ---> Package iptables-ipv6.x86_64 0:1.4.7-11.0.1.el6 will be obsoleted

      ---> Package iptables-ipv6.x86_64 0:1.4.7-14.0.1.el6 will be an update

      --> Processing Dependency: iptables = 1.4.7-14.0.1.el6 for package: iptables-ipv6-1.4.7-14.0.1.el6.x86_64

      Package iptables is obsoleted by iptables-services, but obsoleting package does not provide for requirements

      ---> Package iptables-services.x86_64 0:1.4.21-13.el7 will be obsoleting

      ---> Package libmnl.x86_64 0:1.0.3-7.el7 will be installed

      ---> Package perl-Pod-Perldoc.noarch 0:3.20-4.el7 will be installed

      --> Processing Dependency: perl(parent) for package: perl-Pod-Perldoc-3.20-4.el7.noarch

      --> Processing Dependency: perl(HTTP::Tiny) for package: perl-Pod-Perldoc-3.20-4.el7.noarch

      --> Processing Dependency: perl(Encode) for package: perl-Pod-Perldoc-3.20-4.el7.noarch

      ---> Package perl-podlators.noarch 0:2.5.1-3.el7 will be installed

      --> Running transaction check

      ---> Package iptables.x86_64 0:1.4.7-11.0.1.el6 will be obsoleted

      --> Processing Dependency: libxtables.so.4()(64bit) for package: iptables-ipv6-1.4.7-14.0.1.el6.x86_64

      ---> Package iptables-ipv6.x86_64 0:1.4.7-14.0.1.el6 will be an update

      --> Processing Dependency: iptables = 1.4.7-14.0.1.el6 for package: iptables-ipv6-1.4.7-14.0.1.el6.x86_64

      Package iptables is obsoleted by iptables-services, but obsoleting package does not provide for requirements

      ---> Package perl-Encode.x86_64 0:2.51-7.el7 will be installed

      ---> Package perl-HTTP-Tiny.noarch 0:0.033-3.el7 will be installed

      ---> Package perl-parent.noarch 1:0.225-244.el7 will be installed

      --> Processing Conflict: systemd-208-11.0.1.el7_0.5.x86_64 conflicts plymouth < 0.8.5.1

      --> Restarting Dependency Resolution with new changes.

      --> Running transaction check

      ---> Package iptables.x86_64 0:1.4.7-11.0.1.el6 will be obsoleted

      ---> Package iptables-ipv6.x86_64 0:1.4.7-14.0.1.el6 will be an update

      ---> Package plymouth.x86_64 0:0.8.3-27.0.1.el6 will be updated

      ---> Package plymouth.x86_64 0:0.8.9-0.10.20140113.0.1.el7 will be an update

      --> Processing Conflict: libblkid-2.23.2-16.el7.x86_64 conflicts filesystem < 3

      --> Restarting Dependency Resolution with new changes.

      --> Running transaction check

      ---> Package filesystem.x86_64 0:2.4.30-3.el6 will be updated

      ---> Package filesystem.x86_64 0:3.2-18.el7 will be an update

      --> Processing Conflict: util-linux-2.23.2-16.el7.x86_64 conflicts sysvinit-tools < 2.88-8

      --> Restarting Dependency Resolution with new changes.

      --> Running transaction check

      ---> Package sysvinit-tools.x86_64 0:2.87-5.dsf.el6 will be updated

      ---> Package sysvinit-tools.x86_64 0:2.88-14.dsf.el7 will be an update

      --> Processing Conflict: util-linux-2.23.2-16.el7.x86_64 conflicts coreutils < 8.20

      --> Restarting Dependency Resolution with new changes.

      --> Running transaction check

      ---> Package coreutils.x86_64 0:8.4-31.0.1.el6 will be updated

      ---> Package coreutils.x86_64 0:8.22-11.0.1.el7 will be obsoleting

      --> Processing Dependency: libgmp.so.10()(64bit) for package: coreutils-8.22-11.0.1.el7.x86_64

      ---> Package coreutils-libs.x86_64 0:8.4-31.0.1.el6 will be obsoleted

      --> Running transaction check

      ---> Package gmp.x86_64 0:4.3.1-7.el6_2.2 will be updated

      --> Processing Dependency: libgmp.so.3()(64bit) for package: mpfr-2.4.1-6.el6.x86_64

      --> Processing Dependency: libgmp.so.3()(64bit) for package: cloog-ppl-0.15.7-1.2.el6.x86_64

      --> Processing Dependency: libgmp.so.3()(64bit) for package: cpp-4.4.7-4.el6.x86_64

      --> Processing Dependency: libgmp.so.3()(64bit) for package: ppl-0.10.2-11.el6.x86_64

      ---> Package gmp.x86_64 1:5.1.1-5.el7 will be an update

      --> Running transaction check

      ---> Package cpp.x86_64 0:4.4.7-4.el6 will be updated

      --> Processing Dependency: cpp = 4.4.7-4.el6 for package: gcc-4.4.7-4.el6.x86_64

      ---> Package cpp.x86_64 0:4.8.2-16.2.el7_0 will be an update

      --> Processing Dependency: libmpc.so.3()(64bit) for package: cpp-4.8.2-16.2.el7_0.x86_64

      ---> Package gmp.x86_64 0:4.3.1-7.el6_2.2 will be updated

      --> Processing Dependency: libgmp.so.3()(64bit) for package: cloog-ppl-0.15.7-1.2.el6.x86_64

      --> Processing Dependency: libgmp.so.3()(64bit) for package: ppl-0.10.2-11.el6.x86_64

      ---> Package mpfr.x86_64 0:2.4.1-6.el6 will be updated

      ---> Package mpfr.x86_64 0:3.1.1-4.el7 will be an update

      --> Running transaction check

      ---> Package gcc.x86_64 0:4.4.7-4.el6 will be updated

      ---> Package gcc.x86_64 0:4.8.2-16.2.el7_0 will be an update

      --> Processing Dependency: libgomp = 4.8.2-16.2.el7_0 for package: gcc-4.8.2-16.2.el7_0.x86_64

      --> Processing Dependency: libgcc >= 4.8.2-16.2.el7_0 for package: gcc-4.8.2-16.2.el7_0.x86_64

      --> Processing Dependency: binutils >= 2.20.51.0.2-12 for package: gcc-4.8.2-16.2.el7_0.x86_64

      ---> Package gmp.x86_64 0:4.3.1-7.el6_2.2 will be updated

      --> Processing Dependency: libgmp.so.3()(64bit) for package: cloog-ppl-0.15.7-1.2.el6.x86_64

      --> Processing Dependency: libgmp.so.3()(64bit) for package: ppl-0.10.2-11.el6.x86_64

      --> Processing Dependency: /sbin/new-kernel-pkg for package: kernel-uek-3.8.13-16.2.1.el6uek.x86_64

      --> Processing Dependency: /sbin/new-kernel-pkg for package: kernel-2.6.32-431.el6.x86_64

      --> Restarting Dependency Resolution with new changes.

      --> Running transaction check

       

            < The highlighted section above repeats until I kill the yum process>

       

      Thank you,

      BDub122

        • 1. Re: YUM install of a single package results in huge dependency list.
          Bdub122-Oracle

          Ah -- I see now that the command above is trying to install an OL7 version of the package on my OL 6.5 server.  This explains why it's trying to install of those packages -- I guess it's trying to upgrade the packages to an OL 7 version.

           

          Here are the versions that are available in my repos -- I really want to install an OL 6 version. . .

           

          [root@wallyYUM ~]# find /yum_repo -name openssh-clients*

          /yum_repo/yum/OracleLinux/OL6/latest/x86_64/getPackage/openssh-clients-5.3p1-104.el6_6.1.x86_64.rpm

          /yum_repo/yum/OracleLinux/OL6/latest/x86_64/getPackage/openssh-clients-5.3p1-70.el6_2.2.x86_64.rpm

          /yum_repo/yum/OracleLinux/OL6/latest/x86_64/getPackage/openssh-clients-5.3p1-70.el6.x86_64.rpm

          /yum_repo/yum/OracleLinux/OL6/latest/x86_64/getPackage/openssh-clients-5.3p1-20.el6_0.3.x86_64.rpm

          /yum_repo/yum/OracleLinux/OL6/latest/x86_64/getPackage/openssh-clients-5.3p1-52.el6.x86_64.rpm

          /yum_repo/yum/OracleLinux/OL6/latest/x86_64/getPackage/openssh-clients-5.3p1-81.el6.x86_64.rpm

          /yum_repo/yum/OracleLinux/OL6/latest/x86_64/getPackage/openssh-clients-5.3p1-84.1.el6.x86_64.rpm

          /yum_repo/yum/OracleLinux/OL6/latest/x86_64/getPackage/openssh-clients-5.3p1-81.el6_3.x86_64.rpm

          /yum_repo/yum/OracleLinux/OL6/latest/x86_64/getPackage/openssh-clients-5.3p1-94.el6.x86_64.rpm

          /yum_repo/yum/OracleLinux/OL6/latest/x86_64/getPackage/openssh-clients-5.3p1-52.el6_1.2.x86_64.rpm

          /yum_repo/yum/OracleLinux/OL6/latest/x86_64/getPackage/openssh-clients-5.3p1-20.el6.x86_64.rpm

          /yum_repo/yum/OracleLinux/OL6/latest/x86_64/getPackage/openssh-clients-5.3p1-104.el6.x86_64.rpm

          /yum_repo/yum/OracleLinux/OL5/latest/x86_64/getPackage/openssh-clients-4.3p2-72.el5.x86_64.rpm

          /yum_repo/yum/OracleLinux/OL5/latest/x86_64/getPackage/openssh-clients-4.3p2-72.el5_7.5.x86_64.rpm

          /yum_repo/yum/OracleLinux/OL5/latest/x86_64/getPackage/openssh-clients-4.3p2-72.el5_6.3.x86_64.rpm

          /yum_repo/yum/OracleLinux/OL5/latest/x86_64/getPackage/openssh-clients-4.3p2-82.el5.x86_64.rpm

          /yum_repo/yum/OracleLinux/OL5/latest/x86_64/headers/openssh-clients-0-4.3p2-72.el5.x86_64.hdr

          /yum_repo/yum/OracleLinux/OL5/latest/x86_64/headers/openssh-clients-0-4.3p2-72.el5_7.5.x86_64.hdr

          /yum_repo/yum/OracleLinux/OL5/latest/x86_64/headers/openssh-clients-0-4.3p2-72.el5_6.3.x86_64.hdr

          /yum_repo/yum/OracleLinux/OL5/latest/x86_64/headers/openssh-clients-0-4.3p2-82.el5.x86_64.hdr

          /yum_repo/yum/OracleLinux/OL7/latest/x86_64/getPackage/openssh-clients-6.4p1-8.el7.x86_64.rpm

          /yum_repo/yum/OracleLinux/OL7/latest/x86_64/headers/openssh-clients-0-6.4p1-8.el7.x86_64.hdr

          /yum_repo/yum/OracleLinux/OL7/x86_64/base/0/getPackage/openssh-clients-6.4p1-8.el7.x86_64.rpm

          /yum_repo/yum/OracleLinux/OL7/x86_64/base/0/headers/openssh-clients-0-6.4p1-8.el7.x86_64.hdr

          /yum_repo/yum/EngineeredSystems/exadata/dbserver/12.1.1.1.0/base/x86_64/getPackage/openssh-clients-4.3p2-82.el5.x86_64.rpm

          /yum_repo/yum/EngineeredSystems/exadata/dbserver/12.1.1.1.0/base/x86_64/headers/openssh-clients-0-4.3p2-82.el5.x86_64.hdr

          /yum_repo/yum/EngineeredSystems/exadata/dbserver/12.1.1.1.1/base/x86_64/getPackage/openssh-clients-4.3p2-82.el5.x86_64.rpm

          /yum_repo/yum/EngineeredSystems/exadata/dbserver/12.1.1.1.1/base/x86_64/headers/openssh-clients-0-4.3p2-82.el5.x86_64.hdr

          /yum_repo/yum/EngineeredSystems/exadata/dbserver/12.1/latest/x86_64/getPackage/openssh-clients-4.3p2-82.el5.x86_64.rpm

          /yum_repo/yum/EngineeredSystems/exadata/dbserver/12.1/latest/x86_64/headers/openssh-clients-0-4.3p2-82.el5.x86_64.hdr

           

           

          But I still encounter an issue if I try to specify an OL 6.5 version of the package in the install command:

          /yum_repo/yum/OracleLinux/OL6/latest/x86_64/getPackage/openssh-clients-5.3p1-70.el6_2.2.x86_64.rpm

          [root@wallyYUM ~]# yum --nogpgcheck localinstall /yum_repo/yum/OracleLinux/OL6/latest/x86_64/getPackage/openssh-clients-5.3p1-70.el6_2.2.x86_64.rpm

          Setting up Local Package Process

          Examining /yum_repo/yum/OracleLinux/OL6/latest/x86_64/getPackage/openssh-clients-5.3p1-70.el6_2.2.x86_64.rpm: openssh-clients-5.3p1-70.el6_2.2.x86_64

          Marking /yum_repo/yum/OracleLinux/OL6/latest/x86_64/getPackage/openssh-clients-5.3p1-70.el6_2.2.x86_64.rpm to be installed

          Resolving Dependencies

          --> Running transaction check

          ---> Package openssh-clients.x86_64 0:5.3p1-70.el6_2.2 will be installed

          --> Processing Dependency: openssh = 5.3p1-70.el6_2.2 for package: openssh-clients-5.3p1-70.el6_2.2.x86_64

          --> Processing Dependency: libedit.so.0()(64bit) for package: openssh-clients-5.3p1-70.el6_2.2.x86_64

          --> Running transaction check

          ---> Package libedit.x86_64 0:3.0-12.20121213cvs.el7 will be installed

          ---> Package openssh-clients.x86_64 0:5.3p1-70.el6_2.2 will be installed

          --> Processing Dependency: openssh = 5.3p1-70.el6_2.2 for package: openssh-clients-5.3p1-70.el6_2.2.x86_64

          --> Finished Dependency Resolution

          Error: Package: openssh-clients-5.3p1-70.el6_2.2.x86_64 (/openssh-clients-5.3p1-70.el6_2.2.x86_64)

                    Requires: openssh = 5.3p1-70.el6_2.2

                     Installed: openssh-5.3p1-94.el6.x86_64 (@anaconda-OracleLinuxServer-201311261449.x86_64/6.5)

                         openssh = 5.3p1-94.el6

                     Available: openssh-4.3p2-72.el5.x86_64 (local_ol5_x86_64_latest)

                         openssh = 4.3p2-72.el5

                     Available: openssh-4.3p2-72.el5_6.3.x86_64 (local_ol5_x86_64_latest)

                         openssh = 4.3p2-72.el5_6.3

                     Available: openssh-4.3p2-72.el5_7.5.x86_64 (local_ol5_x86_64_latest)

                         openssh = 4.3p2-72.el5_7.5

                     Available: openssh-4.3p2-82.el5.x86_64 (local_exadata_dbserver_12.1.1.1.0_x86_64_base)

                         openssh = 4.3p2-82.el5

                     Available: openssh-5.3p1-20.el6.x86_64 (local_ol6_x86_64_latest)

                         openssh = 5.3p1-20.el6

                     Available: openssh-5.3p1-20.el6_0.3.x86_64 (local_ol6_x86_64_latest)

                         openssh = 5.3p1-20.el6_0.3

                     Available: openssh-5.3p1-52.el6.x86_64 (local_ol6_x86_64_latest)

                         openssh = 5.3p1-52.el6

                     Available: openssh-5.3p1-52.el6_1.2.x86_64 (local_ol6_x86_64_latest)

                         openssh = 5.3p1-52.el6_1.2

                     Available: openssh-5.3p1-70.el6.x86_64 (local_ol6_x86_64_latest)

                         openssh = 5.3p1-70.el6

                     Available: openssh-5.3p1-70.el6_2.2.x86_64 (local_ol6_x86_64_latest)

                         openssh = 5.3p1-70.el6_2.2

                     Available: openssh-5.3p1-81.el6.x86_64 (local_ol6_x86_64_latest)

                         openssh = 5.3p1-81.el6

                     Available: openssh-5.3p1-81.el6_3.x86_64 (local_ol6_x86_64_latest)

                         openssh = 5.3p1-81.el6_3

                     Available: openssh-5.3p1-84.1.el6.x86_64 (local_ol6_x86_64_latest)

                         openssh = 5.3p1-84.1.el6

                     Available: openssh-5.3p1-104.el6.x86_64 (local_ol6_x86_64_latest)

                         openssh = 5.3p1-104.el6

                     Available: openssh-5.3p1-104.el6_6.1.x86_64 (local_ol6_x86_64_latest)

                         openssh = 5.3p1-104.el6_6.1

                     Available: openssh-6.4p1-8.el7.x86_64 (local_ol7_x86_64_latest)

                         openssh = 6.4p1-8.el7

          You could try using --skip-broken to work around the problem

          You could try running: rpm -Va --nofiles --nodigest

           

          Why is this so difficult. . .?

          • 2. Re: YUM install of a single package results in huge dependency list.
            Avi Miller-Oracle

            You have a yum configuration that has enabled inappropriate channels. This can happen on a yum server, for example, where you're using uln-yum-mirror to create a local repo.

             

            If so, you need to follow the docs to disable the non-appropriate channels: http://www.oracle.com/technetwork/articles/servers-storage-admin/yum-repo-setup-1659167.html#server-client-setup

             

            Essentially, you need to disable all the non-applicable channels (i.e. the OL7 ones) on the local machine, so it only uses the OL6 repos. It's better to disable all the upstream ULN channels and use the client setup to pull updates from itself.

            • 3. Re: YUM install of a single package results in huge dependency list.
              Bdub122-Oracle

              Thank you Avi.  I updated my /etc/yum.repos.d/wallyYUM-ol6.repo file and commented out all but this bit:

               

              [local_ol6_x86_64_latest]

              name=Oracle Linux $releasever - $basearch - latest

              baseurl=http://192.168.1.90/yum/OracleLinux/OL6/latest/$basearch/

              gpgcheck=1

              gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY

              enabled=1

               

              After that the "yum install openssh-clients" worked great!