1 Reply Latest reply on Sep 13, 2006 11:06 AM by Babu George-Oracle

    OAI adapter doesn't start, but no error messages at all - I'm totally lost

    495699
      Dear All

      I have a very strange problem regarding OAI Adapters (AS9i). We have a coupe of adapters which worked fine for years. But after a server restart, one of the adapters stopped working. This means, that the adapter can not be started using the start script. The behaviour is very strange: the java process is started, no error message is displayed at all (the agent_log_level is set to 2) but what's worth, nothig is displayed at all in the log file. And of course, it doesn't work.

      If I change the "application" parameter (adapter name) in the adapter.ini file, the adapter starts correctly. So the problem somehow relates to the original adapter name. And this also means that the jar file, the adapter.ini file and the start script are OK.

      I've tried to restart the whole AS9i, than restart the whole server but it didn't solve the problem.

      I've started the adapter with java -verbose option and the difference between a correct and errorous adapter start is that when I start the errorous adapter, less Java classes are loaded than normally. But there's no error message (or any other information) in the log file so I have no idea what causes this behaviour.

      I also tried to delete the persistence directory, but it didn't help.

      Any help would be greatly appreciated as I'm totally lost.

      Regards,
      Szilard