8 Replies Latest reply on Jul 10, 2015 10:06 PM by rp0428

    4.0.3.16 - Connection is currently busy. Try again?

    user6767894

      I saw an archived thread for 4EA1 - Connection is currently busy. Try again?.

      Is this now fixed? I seem to have this issue happening in Version 4.0.3.16 that I'm using. SQL developer Process has to be killed to exit out of problem. Any thoughts?

        • 1. Re: 4.0.3.16 - Connection is currently busy. Try again?
          thatJeffSmith-Oracle

          not enough information to answer your question

           

          there are no known issues around connections and this message

          • 2. Re: 4.0.3.16 - Connection is currently busy. Try again?
            Gary Graham-Oracle

            In note 6 of 4EA1 - Connection is currently busy. Try again? I mention some things done for 4.0 to improve the user experience in this area. Specific changes were noted for 4.0EA1, 4.0EA2, plus bug 16101234. That last item was definitely fixed for 4.0 production, but the change mainly involves the wait time value before the busy dialog pops up.  That does not seem to be your issue, but it defaults to 3 seconds and can be overridden by including the following parameter in your sqldeveloper.conf file:

            AddVMOption -Dsqldev.obtainlockwaittime=<number_of_seconds_to_delay>

            Otherwise...

            1. If SQL Developer is hanging or in a CPU loop, use jstack to get a full thread dump of the JVM for further analysis.

            2. If SQL Developer is OK, and the delay is on the DB end, try an available Cancel action or View > Task Progress to cancel the process.

             

            Killing the SQL Developer process should only be a last resort.

            • 3. Re: 4.0.3.16 - Connection is currently busy. Try again?
              Justin Warwick

              I am having similar trouble in 4.0, although I don't usually get into a completed hung state, this definitely slows me down. I mostly notice it when an object properties/edit tab is loaded. After trying Mr. Graham's sqldeveloper.conf file addition, I did not notice a difference. I even tried 8000 time spec in case it was really milliseconds. Just to be clear, this is the edit I should have performed, right?


              C:\Users\jwarwick>find /I "sqldev.obtainlockwaittime" "C:\Program Files\Oracle\sqldeveloper\sqldeveloper\bin\sqldeveloper.conf"

              ---------- C:\PROGRAM FILES\ORACLE\SQLDEVELOPER\SQLDEVELOPER\BIN\SQLDEVELOPER.CONF

              AddVMOption -Dsqldev.obtainlockwaittime=8

               

              Recently updated to 4.1.1.19. I found it unimproved. After some OTN searching I found this archived thread:  Connection is currently busy. Try again? - stuck

              So I restored my sqlplus/admin/glogin.sql file to default/as-shipped. It does not appear to have helped much, if at all.

               

              Client profile:

              Windows 7 Enterprise 64-bit, SP1

              Oracle Client Release 11.2.0.4.0

              Windows Env var TNS_ADMIN=c:\oracle\tns_admin

              Oracle SQL Developer 4.1.1.19    Version 4.1.1.19  Build MAIN-19.59

               

              IDE Version: 12.2.1.0.42.150520.0751

              Product ID: oracle.sqldeveloper

              Product Version: 12.2.0.19.59

               

              Version

              -------

               

              Component Version

              ========= =======

              Oracle IDE  4.1.1.19.59

              Java(TM) Platform  1.8.0_45

              • 4. Re: 4.0.3.16 - Connection is currently busy. Try again?
                Gary Graham-Oracle

                As Jeff said earlier, there are no known issues, so all I can suggest (specifically referring to 4.1.1) is...

                • Check if you are using the default JDBC driver (if no client settings configured in Tools > Preferences > Database > Advanced)
                • That default driver comes from the 12.1.0.2 Oracle client and has many bug fixes plus new features for accessing Oracle 12c DBs.
                • Also check in the same preferences screen if you are using the OCI/Thick driver. Using that may improve performance slightly.
                • If you wish, you can even download the latest Oracle 12c Instant Client and configure to use that.
                • If the Busy dialog appears when using both the worksheet and the object browser, you could try using unshared worksheets.

                 

                Hope this helps!

                • 6. Re: 4.0.3.16 - Connection is currently busy. Try again?
                  StephenA

                  I find it the connection busy message in 4.1.1.19 comes up almost immediately especially on the SQL tab for a table. I'm running against 11.2 databases and using the 11 Oracle client makes no difference.  My system configuration is pretty much the same as Justin's

                   

                  Changing to unshared worksheets doesn't help either.....

                  • 7. Re: 4.0.3.16 - Connection is currently busy. Try again?
                    Gary Graham-Oracle

                    Like Jeff says in his blog, it is quite difficult for us on the SQL Developer team to see this behavior, even if we go out of our way. 

                     

                    For example, using 4.1.1, default jdk1.8.0_45, default 12.1.0.2 thin jdbc driver, and sql array fetch size of 50 (Tools > Preferences > Database > Advanced), I connected to 3 different databases...

                    • Local XE 11.2 (ping time < 1 msec)
                    • Remote 12.1.0.2 (ping time around 60 msec)
                    • Remote 11.1.0.7 (ping time over 200 msec)

                    I even changed my laptop's power management to save energy, thereby reducing CPU performance by at least a factor of 3.  I only got the Busy dialog once -- when I switched to the browser's SQL tab to generate the table's DDL.

                     

                    So there is something about your environment, or the quantity of data, or type of data you are accessing.  Possibly the table accessed has more columns than the sql array fetch size, or some other unusual situation that our QA does not test.  Who knows, but maybe you can investigate further. 

                    • 8. Re: 4.0.3.16 - Connection is currently busy. Try again?

                      Please don't hijack another user's thread for your own question or issue.

                       

                      If you have a problem create a new thread and post the information needed to help you. Provide a link to this current user's thread if you think the problem is related.