2 Replies Latest reply on Nov 19, 2015 5:23 PM by 2679886

    Action Links from OBIEE 11g to Siebel 8.1.1.8 SIA not working

    Tobias Klumpp - ec4u

       

      Hello,

       

       

      we are currently facing a problem at the customer site regarding the integration of OBIEE 11g with Siebel. There are basically two scenarios that need to work for our customer:

       

       

      1) Accessing OBIEE dashboards from within Siebel (works perfectly)

       

      2) Navigating from OBIEE to Siebel via Action Links (e.g. to an Opportunity in Siebel) --> This does NOT work

       

       

      When we click on an Action Link in OBIEE that basically links to Siebel we immediately receive an error message saying "The Siebel CRM Server is not currently available."

       

      Obviously, OBIEE does not know how to reach the Siebel CRM server.

       

       

      Regarding our setup:

       


      - OBIEE 11.1.1.7.150120

       

      - SIA 8.1.1.8

       

      - MS IIS 7.0 is used for OBIEE Single Sign-On on a separate Win Server 2008 machine

       

      - OBIEE and Siebel are stored on DIFFERENT machines

       

      - Adjusted ActionFrameWork.xml (siebelcrmconfig parameter) to make the Navigate to Siebel Link visible

       

      - BI system is accessible via: http://<MS IIS WebServer Hostname>/analytics

       

      - CRM System is accessible via: http://crmtest/ --> Alias links to physical CRM machine

       

       

      We found this documentation: http://docs.oracle.com/cd/E23943_01/bi.1111/e16364/siebel_crm_integration.htm

       

       

      It is mentioned in the document that if Siebel Web Extension and OBIEE Presentation Services are on different Web Servers, we need to use some kind of networking / reverse proxy. Unfortunately, this document only explains how to setup this workaround for Oracle HTTP Server. Since we are using MS IIS we are required to find a solution how to make this work with this specific web server.

       

       

      What are the additional steps that need to be undertaken in order to make the Action Links work in our setup?

       

       

      We highly appreciate your help.


      Best regards,

      Tobias