11 Replies Latest reply on Jul 9, 2015 5:40 AM by PU

    EBS Login page failed to load

    2810978

      I have installed ebs 12.2.3 using vm templates .So ebs app & db tier got configured automatically  and i was able to login successfully.

      After few days, I faced OutofMemory (heap) error for oacore_server1 so  I increased its jvm memory and  restarted app tier using adstpall.sh and adstrtal.sh scripts.

      But login page failed to login with error message " The system has encountered an error when servicing the request. If the error persists, please contact the system administrator. "

      Report from adstrtal.sh:

        <Service Group>            <Service>                              <Script>                   <Status>

       

       

        Root Service                                                                                 Enabled

        Root Service               NodeManager                            adnodemgrctl.sh            Started

        Web Administration                                                                           Enabled

        Web Administration         AdminServer                            adadminsrvctl.sh           Started

        Web Administration         OracleTNSListenerAPPS_VISION_ebs       adalnctl.sh                Started

        Web Entry Point Services                                                                     Enabled

        Web Entry Point Services   Oracle HTTP Server VISION_ebs          adapcctl.sh                Started

        Web Entry Point Services   Oracle Process Manager for VISION_ebs  adopmnctl.sh               Started

        Web Application Services                                                                     Enabled

        Web Application Services   oacore_server1                         admanagedsrvctl.sh         Started

        Web Application Services   forms_server1                          admanagedsrvctl.sh         Started

        Web Application Services   oafm_server1                           admanagedsrvctl.sh         Started

        Web Application Services   forms-c4ws_server1                     admanagedsrvctl.sh         Started

        Web Application Services   oaea_server1                           admanagedsrvctl.sh         Disabled

        Batch Processing Services                                                                    Enabled

        Batch Processing Services  OracleConcMgrVISION_ebs                adcmctl.sh                 Started

        Batch Processing Services  Oracle ICSM VISION_ebs                 ieoicsm.sh                 Disabled

        Batch Processing Services  Oracle Fulfillment Server VISION_ebs   jtffmctl.sh                Started

        Other Services                                                                               Disabled

        Other Services             OracleFormsServer-Forms VISION_ebs     adformsrvctl.sh            Disabled

        Other Services             Oracle MWA Service VISION_ebs          mwactlwrpr.sh              Disabled

       

       

      I am getting  below error in oacore_server1 logs :


      ####<Jul 3, 2015 10:12:33 AM EDT> <Error> <ServletContext-/OA_HTML> <ebs.example.com> <oacore_server1> <[ACTIVE] ExecuteThread: '1' for queue: 'weblogic.kernel.Default (self-tuning)'> <<anonymous>> <> <0000KtKFKKr0BxzLK2h8ie1L_dR5000002> <1435932753256> <BEA-000000> <AppsFilter initialization failed ::

      java.lang.RuntimeException: Cookie security attributes calculation

        at oracle.apps.fnd.security.AppsServletFilter$SecureResponseWrapper.init(AppsServletFilter.java:700)

        at oracle.apps.fnd.security.AppsServletFilter.init(AppsServletFilter.java:159)

        at oracle.apps.fnd.security.LeakDetectionFilter.init(LeakDetectionFilter.java:69)

        at weblogic.servlet.internal.FilterManager$FilterInitAction.run(FilterManager.java:343)

        at weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:321)

        at weblogic.security.service.SecurityManager.runAs(SecurityManager.java:120)

        at weblogic.servlet.internal.FilterManager.loadFilter(FilterManager.java:96)

        at weblogic.servlet.internal.FilterManager.preloadFilters(FilterManager.java:57)

        at weblogic.servlet.internal.WebAppServletContext.preloadResources(WebAppServletContext.java:1874)

        at weblogic.servlet.internal.WebAppServletContext.start(WebAppServletContext.java:3163)

        at weblogic.servlet.internal.WebAppModule.startContexts(WebAppModule.java:1520)

        at weblogic.servlet.internal.WebAppModule.start(WebAppModule.java:486)

        at weblogic.application.internal.flow.ModuleStateDriver$3.next(ModuleStateDriver.java:425)

        at weblogic.application.utils.StateMachineDriver.nextState(StateMachineDriver.java:52)

        at weblogic.application.internal.flow.ModuleStateDriver.start(ModuleStateDriver.java:119)

        at weblogic.application.internal.flow.ScopedModuleDriver.start(ScopedModuleDriver.java:200)

        at weblogic.application.internal.flow.ModuleListenerInvoker.start(ModuleListenerInvoker.java:247)

        at weblogic.application.internal.flow.ModuleStateDriver$3.next(ModuleStateDriver.java:425)

        at weblogic.application.utils.StateMachineDriver.nextState(StateMachineDriver.java:52)

        at weblogic.application.internal.flow.ModuleStateDriver.start(ModuleStateDriver.java:119)

        at weblogic.application.internal.flow.StartModulesFlow.activate(StartModulesFlow.java:27)

        at weblogic.application.internal.BaseDeployment$2.next(BaseDeployment.java:671)

        at weblogic.application.utils.StateMachineDriver.nextState(StateMachineDriver.java:52)

        at weblogic.application.internal.BaseDeployment.activate(BaseDeployment.java:212)

        at weblogic.application.internal.EarDeployment.activate(EarDeployment.java:59)

        at weblogic.application.internal.DeploymentStateChecker.activate(DeploymentStateChecker.java:161)

        at weblogic.deploy.internal.targetserver.AppContainerInvoker.activate(AppContainerInvoker.java:79)

        at weblogic.deploy.internal.targetserver.BasicDeployment.activate(BasicDeployment.java:184)

        at weblogic.deploy.internal.targetserver.BasicDeployment.activateFromServerLifecycle(BasicDeployment.java:361)

        at weblogic.management.deploy.internal.DeploymentAdapter$1.doActivate(DeploymentAdapter.java:51)

        at weblogic.management.deploy.internal.DeploymentAdapter.activate(DeploymentAdapter.java:200)

        at weblogic.management.deploy.internal.AppTransition$2.transitionApp(AppTransition.java:30)

        at weblogic.management.deploy.internal.ConfiguredDeployments.transitionApps(ConfiguredDeployments.java:261)

        at weblogic.management.deploy.internal.ConfiguredDeployments.transitionApps(ConfiguredDeployments.java:220)

        at weblogic.management.deploy.internal.ConfiguredDeployments.activate(ConfiguredDeployments.java:169)

        at weblogic.management.deploy.internal.ConfiguredDeployments.deploy(ConfiguredDeployments.java:123)

        at weblogic.management.deploy.internal.DeploymentServerService.resume(DeploymentServerService.java:180)

        at weblogic.management.deploy.internal.DeploymentServerService.start(DeploymentServerService.java:96)

        at weblogic.t3.srvr.SubsystemRequest.run(SubsystemRequest.java:64)

        at weblogic.work.ExecuteThread.execute(ExecuteThread.java:256)

        at weblogic.work.ExecuteThread.run(ExecuteThread.java:221)

      Caused By: java.lang.NoClassDefFoundError: Could not initialize class oracle.apps.fnd.common.WebAppsContext

        at oracle.apps.fnd.security.AppsServletFilter$SecureResponseWrapper.init(AppsServletFilter.java:661)

        at oracle.apps.fnd.security.AppsServletFilter.init(AppsServletFilter.java:159)

        at oracle.apps.fnd.security.LeakDetectionFilter.init(LeakDetectionFilter.java:69)

        at weblogic.servlet.internal.FilterManager$FilterInitAction.run(FilterManager.java:343)

        at weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:321)

        at weblogic.security.service.SecurityManager.runAs(SecurityManager.java:120)

        at weblogic.servlet.internal.FilterManager.loadFilter(FilterManager.java:96)

        at weblogic.servlet.internal.FilterManager.preloadFilters(FilterManager.java:57)

        at weblogic.servlet.internal.WebAppServletContext.preloadResources(WebAppServletContext.java:1874)

        at weblogic.servlet.internal.WebAppServletContext.start(WebAppServletContext.java:3163)

        at weblogic.servlet.internal.WebAppModule.startContexts(WebAppModule.java:1520)

        at weblogic.servlet.internal.WebAppModule.start(WebAppModule.java:486)

        at weblogic.application.internal.flow.ModuleStateDriver$3.next(ModuleStateDriver.java:425)

        at weblogic.application.utils.StateMachineDriver.nextState(StateMachineDriver.java:52)

        at weblogic.application.internal.flow.ModuleStateDriver.start(ModuleStateDriver.java:119)

        at weblogic.application.internal.flow.ScopedModuleDriver.start(ScopedModuleDriver.java:200)

        at weblogic.application.internal.flow.ModuleListenerInvoker.start(ModuleListenerInvoker.java:247)

        at weblogic.application.internal.flow.ModuleStateDriver$3.next(ModuleStateDriver.java:425)

        at weblogic.application.utils.StateMachineDriver.nextState(StateMachineDriver.java:52)

        at weblogic.application.internal.flow.ModuleStateDriver.start(ModuleStateDriver.java:119)

        at weblogic.application.internal.flow.StartModulesFlow.activate(StartModulesFlow.java:27)

        at weblogic.application.internal.BaseDeployment$2.next(BaseDeployment.java:671)

        at weblogic.application.utils.StateMachineDriver.nextState(StateMachineDriver.java:52)

        at weblogic.application.internal.BaseDeployment.activate(BaseDeployment.java:212)

        at weblogic.application.internal.EarDeployment.activate(EarDeployment.java:59)

        at weblogic.application.internal.DeploymentStateChecker.activate(DeploymentStateChecker.java:161)

        at weblogic.deploy.internal.targetserver.AppContainerInvoker.activate(AppContainerInvoker.java:79)

        at weblogic.deploy.internal.targetserver.BasicDeployment.activate(BasicDeployment.java:184)

        at weblogic.deploy.internal.targetserver.BasicDeployment.activateFromServerLifecycle(BasicDeployment.java:361)

        at weblogic.management.deploy.internal.DeploymentAdapter$1.doActivate(DeploymentAdapter.java:51)

        at weblogic.management.deploy.internal.DeploymentAdapter.activate(DeploymentAdapter.java:200)

        at weblogic.management.deploy.internal.AppTransition$2.transitionApp(AppTransition.java:30)

        at weblogic.management.deploy.internal.ConfiguredDeployments.transitionApps(ConfiguredDeployments.java:261)

        at weblogic.management.deploy.internal.ConfiguredDeployments.transitionApps(ConfiguredDeployments.java:220)

        at weblogic.management.deploy.internal.ConfiguredDeployments.activate(ConfiguredDeployments.java:169)

        at weblogic.management.deploy.internal.ConfiguredDeployments.deploy(ConfiguredDeployments.java:123)

        at weblogic.management.deploy.internal.DeploymentServerService.resume(DeploymentServerService.java:180)

        at weblogic.management.deploy.internal.DeploymentServerService.start(DeploymentServerService.java:96)

        at weblogic.t3.srvr.SubsystemRequest.run(SubsystemRequest.java:64)

        at weblogic.work.ExecuteThread.execute(ExecuteThread.java:256)

        at weblogic.work.ExecuteThread.run(ExecuteThread.java:221)

      >

      ####<Jul 3, 2015 10:12:33 AM EDT> <Info> <ServletContext-/OA_HTML> <ebs.example.com> <oacore_server1> <[ACTIVE] ExecuteThread: '1' for queue: 'weblogic.kernel.Default (self-tuning)'> <<anonymous>> <> <0000KtKFKKr0BxzLK2h8ie1L_dR5000002> <1435932753257> <BEA-000000> <oracle.apps.fnd.security.LeakDetectionFilter.initialized:1435932753257>

      ####<Jul 3, 2015 10:12:33 AM EDT> <Info> <ServletContext-/OA_HTML> <ebs.example.com> <oacore_server1> <[ACTIVE] ExecuteThread: '1' for queue: 'weblogic.kernel.Default (self-tuning)'> <<anonymous>> <> <0000KtKFKKr0BxzLK2h8ie1L_dR5000002> <1435932753257> <BEA-000000> <LeakSetting:

        global:true,session:false,aggressive:false,stderr:false,appslog:false,corelog:false

        ignoring:null>

      ####<Jul 3, 2015 10:12:33 AM EDT> <Error> <HTTP> <ebs.example.com> <oacore_server1> <[ACTIVE] ExecuteThread: '1' for queue: 'weblogic.kernel.Default (self-tuning)'> <<WLS Kernel>>

      <> <0000KtKFKKr0BxzLK2h8ie1L_dR5000002> <1435932753258> <BEA-101165> <Could not load user defined filter in web.xml: oracle.apps.jtf.cabo.interceptor.JTFWrapperFilter.

      java.lang.NullPointerException

        at oracle.apps.jtf.cabo.interceptor.JTFWrapperFilter.init(JTFWrapperFilter.java:81)

        at weblogic.servlet.internal.FilterManager$FilterInitAction.run(FilterManager.java:343)

        at weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:321)

        at weblogic.security.service.SecurityManager.runAs(SecurityManager.java:120)

        at weblogic.servlet.internal.FilterManager.loadFilter(FilterManager.java:96)

        at weblogic.servlet.internal.FilterManager.preloadFilters(FilterManager.java:57)

        at weblogic.servlet.internal.WebAppServletContext.preloadResources(WebAppServletContext.java:1874)

        at weblogic.servlet.internal.WebAppServletContext.start(WebAppServletContext.java:3163)

        at weblogic.servlet.internal.WebAppModule.startContexts(WebAppModule.java:1520)

        at weblogic.servlet.internal.WebAppModule.start(WebAppModule.java:486)

        at weblogic.application.internal.flow.ModuleStateDriver$3.next(ModuleStateDriver.java:425)

        at weblogic.application.utils.StateMachineDriver.nextState(StateMachineDriver.java:52)

        at weblogic.application.internal.flow.ModuleStateDriver.start(ModuleStateDriver.java:119)

        at weblogic.application.internal.flow.ScopedModuleDriver.start(ScopedModuleDriver.java:200)

        at weblogic.application.internal.flow.ModuleListenerInvoker.start(ModuleListenerInvoker.java:247)

        at weblogic.application.internal.flow.ModuleStateDriver$3.next(ModuleStateDriver.java:425)

        at weblogic.application.utils.StateMachineDriver.nextState(StateMachineDriver.java:52)

        at weblogic.application.internal.flow.ModuleStateDriver.start(ModuleStateDriver.java:119)

        at weblogic.application.internal.flow.StartModulesFlow.activate(StartModulesFlow.java:27)

        at weblogic.application.internal.BaseDeployment$2.next(BaseDeployment.java:671)

        at weblogic.application.utils.StateMachineDriver.nextState(StateMachineDriver.java:52)

        at weblogic.application.internal.BaseDeployment.activate(BaseDeployment.java:212)

        at weblogic.application.internal.EarDeployment.activate(EarDeployment.java:59)

        at weblogic.application.internal.DeploymentStateChecker.activate(DeploymentStateChecker.java:161)

        at weblogic.deploy.internal.targetserver.AppContainerInvoker.activate(AppContainerInvoker.java:79)

        at weblogic.deploy.internal.targetserver.BasicDeployment.activate(BasicDeployment.java:184)

        at weblogic.deploy.internal.targetserver.BasicDeployment.activateFromServerLifecycle(BasicDeployment.java:361)

        at weblogic.management.deploy.internal.DeploymentAdapter$1.doActivate(DeploymentAdapter.java:51)

        at weblogic.management.deploy.internal.DeploymentAdapter.activate(DeploymentAdapter.java:200)

        at weblogic.management.deploy.internal.AppTransition$2.transitionApp(AppTransition.java:30)

        at weblogic.management.deploy.internal.ConfiguredDeployments.transitionApps(ConfiguredDeployments.java:261)

        at weblogic.management.deploy.internal.ConfiguredDeployments.transitionApps(ConfiguredDeployments.java:220)

        at weblogic.management.deploy.internal.ConfiguredDeployments.activate(ConfiguredDeployments.java:169)

        at weblogic.management.deploy.internal.ConfiguredDeployments.deploy(ConfiguredDeployments.java:123)

        at weblogic.management.deploy.internal.DeploymentServerService.resume(DeploymentServerService.java:180)

        at weblogic.management.deploy.internal.DeploymentServerService.start(DeploymentServerService.java:96)

        at weblogic.t3.srvr.SubsystemRequest.run(SubsystemRequest.java:64)

        at weblogic.work.ExecuteThread.execute(ExecuteThread.java:256)

        at weblogic.work.ExecuteThread.run(ExecuteThread.java:221)

       

       

      LOGS FROM  oacore_server1-diagnostic.log:

       

      [2015-07-03T10:14:30.618-04:00] [oacore_server1] [ERROR] [] [com.bea.portlet.i18n.PortletServerLogger] [tid: [ACTIVE].ExecuteThread: '1' for queue:

      'weblogic.kernel.Default (self-tuning)'] [userId: <anonymous>] [ecid: 0000KtKFKKr0BxzLK2h8ie1L_dR5000002,0] [APP: oacore#1.0.0]  [/OA_HTML] Error calling config handler setters

      using [/WEB-INF/portlet.xml] and [/WEB-INF/oracle-portlet.xml].[[

      java.lang.NullPointerException

        at oracle.apps.fnd.framework.jps.OAPortletAppConfigHandler.generatePortlets(OAPortletAppConfigHandler.java:475)

        at oracle.apps.fnd.framework.jps.OAPortletAppConfigHandler.generatePortletApp(OAPortletAppConfigHandler.java:283)

        at oracle.apps.fnd.framework.jps.OAPortletAppConfigHandler.setPortletFile(OAPortletAppConfigHandler.java:147)

        at com.bea.portlet.container.AppDeployer.initConfigHandler(AppDeployer.java:371)

        at com.bea.portlet.container.AppDeployer.<init>(AppDeployer.java:130)

        at com.bea.portlet.container.AppDeployer.getAppDeployer(AppDeployer.java:148)

        at com.bea.portlet.container.AppContainer.ensureRedeploy(AppContainer.java:498)

        at com.bea.wsrp.producer.adapter.javaportlet.JavaPortletAdapter.ensureRedeploy(JavaPortletAdapter.java:142)

        at com.bea.wsrp.producer.container.init.PortalInitializer.init(PortalInitializer.java:18)

        at com.bea.wsrp.producer.container.ProducerEndPoint.init(ProducerEndPoint.java:191)

        at com.bea.wsrp.producer.container.ProducerEndPoint.initialize(ProducerEndPoint.java:126)

        at com.bea.wsrp.producer.container.ProducerServlet.reinitInternal(ProducerServlet.java:101)

        at com.bea.wsrp.producer.container.ProducerServlet.initInternal(ProducerServlet.java:83)

        at com.bea.wsrp.producer.container.ProducerServlet.access$200(ProducerServlet.java:54)

        at com.bea.wsrp.producer.container.ProducerServlet$ServletLifecycleListenerImpl.init(ProducerServlet.java:1203)

        at com.bea.netuix.util.ServletLifecycleListener.initOrReinitInternal(ServletLifecycleListener.java:131)

        at com.bea.netuix.util.ServletLifecycleService.addServletLifecycleListener(ServletLifecycleService.java:252)

        at com.bea.netuix.util.ServletLifecycleService.addServletLifecycleListener(ServletLifecycleService.java:182)

        at com.bea.wsrp.producer.container.ProducerServlet.init(ProducerServlet.java:78)

        at javax.servlet.GenericServlet.init(GenericServlet.java:241)

        at weblogic.servlet.internal.StubSecurityHelper$ServletInitAction.run(StubSecurityHelper.java:283)

        at weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:321)

        at weblogic.security.service.SecurityManager.runAs(SecurityManager.java:120)

        at weblogic.servlet.internal.StubSecurityHelper.createServlet(StubSecurityHelper.java:64)

        at weblogic.servlet.internal.StubLifecycleHelper.createOneInstance(StubLifecycleHelper.java:58)

        at weblogic.servlet.internal.StubLifecycleHelper.<init>(StubLifecycleHelper.java:48)

        at weblogic.servlet.internal.ServletStubImpl.prepareServlet(ServletStubImpl.java:539)

        at weblogic.servlet.internal.WebAppServletContext.preloadServlet(WebAppServletContext.java:1983)

        at weblogic.servlet.internal.WebAppServletContext.loadServletsOnStartup(WebAppServletContext.java:1957)

        at weblogic.servlet.internal.WebAppServletContext.preloadResources(WebAppServletContext.java:1876)

        at weblogic.servlet.internal.WebAppServletContext.start(WebAppServletContext.java:3163)

        at weblogic.servlet.internal.WebAppModule.startContexts(WebAppModule.java:1520)

        at weblogic.servlet.internal.WebAppModule.start(WebAppModule.java:486)

        at weblogic.application.internal.flow.ModuleStateDriver$3.next(ModuleStateDriver.java:425)

        at weblogic.application.utils.StateMachineDriver.nextState(StateMachineDriver.java:52)

        at weblogic.application.internal.flow.ModuleStateDriver.start(ModuleStateDriver.java:119)

        at weblogic.application.internal.flow.ScopedModuleDriver.start(ScopedModuleDriver.java:200)

        at weblogic.application.internal.flow.ModuleListenerInvoker.start(ModuleListenerInvoker.java:247)

        at weblogic.application.internal.flow.ModuleStateDriver$3.next(ModuleStateDriver.java:425)

        at weblogic.application.utils.StateMachineDriver.nextState(StateMachineDriver.java:52)

        at weblogic.application.internal.flow.ModuleStateDriver.start(ModuleStateDriver.java:119)

        at weblogic.application.internal.flow.StartModulesFlow.activate(StartModulesFlow.java:27)

        at weblogic.application.internal.BaseDeployment$2.next(BaseDeployment.java:671)

        at weblogic.application.utils.StateMachineDriver.nextState(StateMachineDriver.java:52)

        at weblogic.application.internal.BaseDeployment.activate(BaseDeployment.java:212)

        at weblogic.application.internal.EarDeployment.activate(EarDeployment.java:59)

        at weblogic.application.internal.DeploymentStateChecker.activate(DeploymentStateChecker.java:161)

        at weblogic.deploy.internal.targetserver.AppContainerInvoker.activate(AppContainerInvoker.java:79)

        at weblogic.deploy.internal.targetserver.BasicDeployment.activate(BasicDeployment.java:184)

        at weblogic.deploy.internal.targetserver.BasicDeployment.activateFromServerLifecycle(BasicDeployment.java:361)

        at weblogic.management.deploy.internal.DeploymentAdapter$1.doActivate(DeploymentAdapter.java:51)

        at weblogic.management.deploy.internal.DeploymentAdapter.activate(DeploymentAdapter.java:200)

        at weblogic.management.deploy.internal.AppTransition$2.transitionApp(AppTransition.java:30)

        at weblogic.management.deploy.internal.ConfiguredDeployments.transitionApps(ConfiguredDeployments.java:261)

        at weblogic.management.deploy.internal.ConfiguredDeployments.transitionApps(ConfiguredDeployments.java:220)

        at weblogic.management.deploy.internal.ConfiguredDeployments.activate(ConfiguredDeployments.java:169)

        at weblogic.management.deploy.internal.ConfiguredDeployments.deploy(ConfiguredDeployments.java:123)

        at weblogic.management.deploy.internal.DeploymentServerService.resume(DeploymentServerService.java:180)

        at weblogic.management.deploy.internal.DeploymentServerService.start(DeploymentServerService.java:96)

        at weblogic.t3.srvr.SubsystemRequest.run(SubsystemRequest.java:64)

        at weblogic.work.ExecuteThread.execute(ExecuteThread.java:256)

        at weblogic.work.ExecuteThread.run(ExecuteThread.java:221)

      ]]

       

       

      Can some body provide me suggestions to resolve the issue?

      Thanks in Advance!!

        • 1. Re: EBS Login page failed to load
          Hussein Sawwan-Oracle

          After few days, I faced OutofMemory (heap) error for oacore_server1 so  I increased its jvm memory and  restarted app tier using adstpall.sh and adstrtal.sh scripts.

           

          What changes have you done? What if you revert back those changes, can you still reproduce the issue?

           

          Thanks,

          Hussein

          • 2. Re: EBS Login page failed to load
            2810978

            Hussein ,Thanks for your prompt reply!!

             

            We were integrating EBS with OID  (for enabling SSO) using below doc

            https://support.oracle.com/epmos/faces/DocumentDisplay?_afrLoop=550304879505368&id=1371932.1&_afrWindowMode=0&_adf.ctrl-…


            As per my colleague when he run , adop phase=prepare  (Step 1.3 of doc) ,login page became inaccessible ,

            when  we checked memory consumption using free -m cmd: Out of 6541 mb to EBS , 197mb is free . Then i restarted app tier and got the mentioned errors in logs.

            I think patching command error took lot of memory that cause hanging of few server threads.


            I will revert ebs to previous snapshot(newly created ebs without custom changes) and then restart app tier to see if still get those errors & let u know!!

            Thanks ,

            Rakhee

            • 3. Re: EBS Login page failed to load
              2810978

              Hi Hussein,

               

              When reverted , its worked fine , after app & db restart and machine restart too!!

              Now when I ran, adop phase=prepare . it ran successfully . I was able to access EBS also for some time but after an  hour again got the same error log and login page failed to load with same error mentioned above.

              Before applying adop phase=prepare , i sourced EBS env file and selected patch file system option.

               

              Is it possible that adop phase=prepare is doing some change that are taking some time to reflect (may after some scheduler run) ? Just a Guess as I have no knowledge of EBS using it just as a target app for SSO.

              or Have i missed some patch application ?

              Also Can i afford to skip online patching steps for EBS -OID intergartion?

               

              Waiting for your valuable opinion!!

               

               

              Thanks in Advance !!

              Rakhee

              • 4. Re: EBS Login page failed to load
                PU

                Hello Rakhee,

                 

                Just want to check if you have ran adautoconfig after the changes made ? Or i misunderstood the problem.

                Please confirm.

                 

                Prashant Umap

                • 5. Re: EBS Login page failed to load
                  2810978

                  No Prashant , I didn't run adautoconfig script.

                  • 6. Re: EBS Login page failed to load
                    PU

                    Hello Rakhee,

                     

                    Ok ...what are all the changes you have done ?

                     

                    Prashant U

                    • 7. Re: EBS Login page failed to load
                      2810978

                      Hi Prashant,

                      As I mentioned , I installed EBS 12.2.3 using VM templates . So when EBS VM was created ,its db & app tier was auto-configured. & EBS app was running fine.

                      Only change I made was to oacore server  jvm memory from weblogic console and  also  in  APP Conxtext xml file ( <oacore_jvm_start_options) .

                      Modified values : -XX:PermSize=384m -XX:MaxPermSize=512m -Xms512m -Xmx1024m

                      and then restarted app tier using adstpall.sh and adstrtal.sh scripts.  Everything  worked  fine till then.

                       

                      Since My objective is  just to do EBS SSO Integration,

                      I started on OID integration with EBS steps,

                      I sourced EBS env file and selected 'P' option.

                      Now when I ran, adop phase=prepare . it ran successfully . I was able to access EBS also for some time but after an  hour got the  error  mentioned above.

                      These are the only things I did!!

                       

                      Now I have skipped online patching cycle , source EBS envt file using run time file system and   went ahead on EBS integration with OID using txkrun.pl
                      -script=SetSSOReg and it ran successfully and EBS is also working fine so far.

                       

                       

                      I just hope there is no impact of  skipping online patching on EBS SSO Integration!!

                       

                      Anyone's opinion on same is welcome!!

                       

                      Thanks!!

                       

                       

                       

                       


                      • 8. Re: EBS Login page failed to load
                        2810978

                        Hi All,

                         

                        One more query!

                         

                        I am facing low memory issues with EBS. It has eaten all memory I increased.

                        Currently its consuming almost all  memory.

                        [oracle@ebs bin]$ free -m

                                     total       used       free     shared    buffers     cached

                        Mem:         11906      11778        127          0        602       4247

                        -/+ buffers/cache:       6929       4977

                        Swap:        10239         19      10220

                         

                        As I am not the end user of EBS and using it only for EBS SSO integration . Can any one let me know what all processes can I stop without impacting  EBS SSO flow?

                         

                        Thanks in Advance!!

                        • 9. Re: EBS Login page failed to load
                          Bashar.

                          Hi,

                           

                          The memory usage is actually as follows:

                          used - cached

                          11778 - 4247 = 7531 MB

                           

                          This is normal for 12.2. The minimum requirements per the installation guide is 8 GB.

                           

                          Regards,

                          Bashar

                          • 10. Re: EBS Login page failed to load
                            PU

                            Hello Rakhee,

                             

                            Yes, you can skip patching cycle phase=apply. And No impact on the same.

                             

                            Regards,

                            Prashant U

                            • 11. Re: EBS Login page failed to load
                              PU

                              Hello Bashar,

                               

                              Did u try to bounce the server.  As it will killed the defunct/dead process.

                              Please check and bounce the server and see if it will help.

                              Or

                              Please see any other instance if any consuming memory.

                               

                              Regards

                              Prashant U