2 Replies Latest reply on Jul 12, 2015 3:56 AM by user3715462

    Could not startup oacore in ebs 12.1.3

    user3715462

      Hi All,

       

      we are using ebs 12.1.3 on share application top. with 4 servers

      today after bring it down i could not bring the OACORE up

      Apache/Forms/OAFM are up

      before in one of the server i found this error

      in 1 server

      /u01/TEST/inst/apps/TEST1_xxxxx1/logs/ora/10.1.3/opmn/oacore_default_group_1

       

      15/07/11 07:02:01 FINE: OpmnConfig.registerComponentMBean reg comp: oc4j:type=OpmnCompOc4jGroup,OpmnConfig=Singleton,name=default_group

      15/07/11 07:02:01 FINER: UseDeploymentLockFile.installIfNeeded Installing File lock hooks

      15/07/11 07:02:01 FINEST: FileLockUtil.log Waiting for the deployment lock

      15/07/11 07:02:03 FINEST: FileLockUtil.log Waiting for the deployment lock again ...

      15/07/11 07:02:05 FINEST: FileLockUtil.log Waiting for the deployment lock again ...

      15/07/11 07:02:07 FINEST: FileLockUtil.log Waiting for the deployment lock again ...

      15/07/11 07:02:09 FINEST: FileLockUtil.log Waiting for the deployment lock again 

       

      but after cleanup  and run autoconfig.on all servers with no error

      but oacore always hung and the status is down when check status.

      i could not find any error in log files in j2ee or opmn

       

      went through these notes but it did not help

      there were not .lock in the system.

       

      Oacore Process Does Not Start (Doc ID 1447877.1)
      followed the document --Oacore Service Hanging at Startup ( Doc ID 1298003.1 )

       

      R12: Oacore JVM Processes Won't Start After Increasing Their Number In Oracle Applications Release 12 In Context.xml (Doc ID 555214.1)

       

      After Increasing the Number of OACORE OC4J Processes to More Than 5, adoacorectl.sh is Exiting With Status 204 (Doc ID 1177323.1)

       

       

      Please advise

      Thanks

        • 1. Re: Could not startup oacore in ebs 12.1.3
          user3715462

          Can someone please help, We have SR1 with support but so far have no success.

          It was at this state for longtime

          Starting OACORE oc4j...  and i had to cancel it.

          an Oracle suggested "problem really looks like an NFS locking issue" but so far after all the debug and test

          the issue is still alive.

           

          OACORE is still not working.

           

          Please give some suggestions.

          Thanks,

           

           

           

           

           

          OC4JGroup:default_group      | OC4J:oafm      |   27551 | Alive
          OC4JGroup:default_group      | OC4J:forms     |   27484 | Alive
          OC4JGroup:default_group      | OC4J:oacore    | N/A | Down
          HTTP_Server                  | HTTP_Server    |   19779 | Alive
          • 2. Re: Could not startup oacore in ebs 12.1.3
            user3715462

            a year ago oracle recommended to put in this line

            <load-on-startup>1</load-on-startup>

            to fix 500 Internal Server Error per note  Note:1910999.1  :

             

            the production system ran so well until this weekend when we do patching.

            the oacore failed across all shared application top  and could not figure out why it failed.

            all the debug turned on did not help that much.

             

            spent almost 11 hrs with support and finally they found this note below and some clients

            had similar issues FileLockUtil.log

            remove the line in orion-web.xml and the oacore up right away.

            i hope i will not not get  "500 Internal Server Error" after removed the line "load-on-startup" on fnd.sso

             

            $LOG_HOME/ora/10.1.3/opmn/oacore_default_group_3oacorestd.out

            15/07/11 13:13:56 FINE: OpmnConfig.registerComponentMBean reg comp: oc4j:type=OpmnCompOc4jGroup,OpmnConfig=Singleton,name=default_group

            15/07/11 13:13:56 FINER: UseDeploymentLockFile.installIfNeeded Installing File lock hooks

            15/07/11 13:13:56 FINEST: FileLockUtil.log Waiting for the deployment lock

            15/07/11 13:13:58 FINEST: FileLockUtil.log Waiting for the deployment lock again ...

            15/07/11 13:14:00 FINEST: FileLockUtil.log Waiting for the deployment lock again ...

            15/07/11 13:14:02 FINEST: FileLockUtil.log Waiting for the deployment lock again ...

            15/07/11 13:14:04 FINEST: FileLockUtil.log Waiting for the deployment lock again ...

            15/07/11 13:14:06 FINEST: FileLockUtil.log Waiting for the deployment lock again ...

             

            Note:1910999.1  :

             

            $ORA_CONFIG_HOME/ora/10.1.3/j2ee/oacore/application-deployments/oacore/html/orion-web.xml

            <servlet>

              <servlet-name>AppsLogin</servlet-name>

              <servlet-class>oracle.apps.fnd.sso.AppsLoginRedirect</servlet-class>

              <load-on-startup>1</load-on-startup>  <---- remove the line

              </servlet>