13 Replies Latest reply on Aug 11, 2015 2:54 PM by user525542

    problem starting sql developer 4.1.1.19.59

    Wouter Breeuwsma

      Hi,

       

      I have installed SQL developer 4.1.1.19.59, but when I start it it hangs on the Sign in window for the proxy, which is unresponsive. I can't even close it, and the only way is to kill the process with the Task Manager.

       

      An administrator can run the program, but I am not an administrator on my PC.

       

      I am runnning Windows 7 Professional, 64 bits.

       

      Can someone tell me which permissions are needed to make this run as a normal user?

       

      P.S. I don't have this problem with SQL Developer 4.0.3.16.84

       

      Thanks, Wouter

        • 1. Re: problem starting sql developer 4.1.1.19.59
          Pk

          Can you provide the screenshot of the issue?

          • 2. Re: problem starting sql developer 4.1.1.19.59
            thatJeffSmith-Oracle

            Have an admin start it up, then in preferences go to Web Browser and Proxy, Proxy Settings, and configure it for you.

            • 3. Re: problem starting sql developer 4.1.1.19.59
              Wouter Breeuwsma

              Hi PK,

               

              Here is the screenshot of the 2 windows.

               

              In this case the Sign in window is empty, but sometimes you can see the entry fields and the buttons.

               

              Regards, Wouter

              • 4. Re: problem starting sql developer 4.1.1.19.59
                Wouter Breeuwsma

                Hi Jeff,

                 

                Thanks for your suggestion. We have tried it, but unfortunately it didn't help.

                 

                Under the admin account we changed the setting to Manual Proxy and tested it (with the button in that screen), and it was OK. Then I started SQL Developer again under my account and it hung at the same point. It seems that the setting is not carried over to my user profile. Is there a way to edit a config file manually to achieve this under my account?

                 

                Thanks, Wouter

                • 5. Re: problem starting sql developer 4.1.1.19.59
                  Gary Graham-Oracle

                  When all else fails, you can always force your user settings into a folder that is writable.

                   

                  Add something like this line to your installation's sqldeveloper.conf file:

                  AddVMOption -Dide.user.dir=<path_to_parent_folder_of_system4.1.1.19.59>

                  1 person found this helpful
                  • 6. Re: problem starting sql developer 4.1.1.19.59
                    Wouter Breeuwsma

                    Hi Gary,

                     

                    Thanks for your suggestion, but it still didn't work. It halted at the same point where it did in previous runs.  Maybe I have not configured it properly.

                     

                    Can you have a look at my paths to see if the configuration is OK?

                     

                    Path to sqldeveloper.conf

                    C:\Oracle\sqldeveloper-4.1.1.19.59-no-jre\sqldeveloper\sqldeveloper\bin

                     

                    Path to system4.1.1.19.59

                    C:\Users\Oreade4.OMBUDSMAN.004\AppData\Roaming\SQL Developer\system4.1.1.19.59

                     

                    Option added to sqldeveloper.conf

                    #Added by Wouter to avoid proxy popup window stopping startup

                    AddVMOption -Dide.user.dir=C:\Users\Oreade4.OMBUDSMAN.004\AppData\Roaming\SQL Developer

                     

                    Thanks in advance, Wouter

                    • 7. Re: problem starting sql developer 4.1.1.19.59
                      Gary Graham-Oracle

                      HI Wouter,

                       

                      Actually, my advice was use ide.user.dir to override the default user settings folder.  Under normal circumstances this defaults to %APPDATA%\SQL Developer, and the problem is typically some administrative policy that prevents updates to folders and files under %APPDATA%.

                       

                      So my expectation was that you would set ide.user.dir to something other than a folder under %APPDATA%., maybe C:\Temp\OSD, to see if that works.

                       

                      Regards,

                      Gary

                      SQL Developer Team

                      • 8. Re: problem starting sql developer 4.1.1.19.59
                        Wouter Breeuwsma

                        Hi Gary,

                         

                        Thanks this did the trick!

                         

                        BTW, I like the new DBA section Database Status > DB Instance. Nice dashboard!

                        I also like the new tab Model to get a sneak preview of the section of the selected table in the complete Data Model.

                        I think it is a pity that the breadcrumb trail (showing the sub procedures) in the package body is gone. Will it come back in future versions?

                         

                        I appreciate your time and help. Thanks!

                         

                        Best Regards, Wouter

                        • 9. Re: problem starting sql developer 4.1.1.19.59
                          Gary Graham-Oracle

                          I think it is a pity that the breadcrumb trail (showing the sub procedures) in the package body is gone. Will it come back in future versions?

                          Good question. There were a couple of bugs logged against breadcrumbs, one a CPU hogging issue and the other a deadlock issue involving the line gutter. Both required JDeveloper team action to get fixes. I believe we actually got both fixes in time for 4.1.1, but without the time to test them thoroughly -- especially the deadlock.

                           

                          Discretion being the better part of valor, a decision was made to disable the breadcrumb feature until we could be certain the fixes work and the feature behaves correctly. So, as far as I know, it should come back in a future release. Maybe Jeff will comment further.

                          • 11. Re: problem starting sql developer 4.1.1.19.59
                            user525542

                            Still crashing!!!

                            Even with the ide.user.dir changed to a non-privileged location, ie: other than %APPDATA%, SQLDEVELOPER 4.1.1 still crashes on me at startup. 

                             

                            The crash happens early, the error is always complaining about not finding a netbeans class.

                             

                            Environment:

                            - Windows 7, 64 bit.

                            - JDK 1.8.0_51 installed, both x64 and i586

                             

                            Configurations:

                            - installing JDK 1.7 with netbeans, but SQLDEVELOPER 4.1.1. does not support that.

                            - pointing JDK to either Program Files (x86) or x64 Program Files.

                            - tried both 4.1.1 no-jre and 4.1.1 with JDK

                            - tried different locations for ide.user.dir

                            - tried putting the sqldeveloper directory itself in a folder off my desktop

                             

                            Tests:

                            Using 4.1.1 with JDK supplied, a popup panel states  "The module named org.netbeans.swing.outline was needed and not found"

                            Using 4.1.1 no-jre, the traceback below.

                             

                            There seem to be no other clues out there as to how to fix this, and the ide.user.dir fix does not appear to be the correct answer for my case.

                             

                            Anyone else having this difficulty?    Many thanks!

                             

                            Traceback....

                            java.lang.NoClassDefFoundError: org/eclipse/osgi/baseadaptor/HookConfigurator wh

                            ile loading org.netbeans.modules.netbinox.NetbinoxHooks; see http://wiki.netbean

                            s.org/DevFaqTroubleshootClassNotFound

                                    at org.netbeans.ProxyClassLoader.selfLoadClass(ProxyClassLoader.java:263

                            )

                                    at org.netbeans.ProxyClassLoader.loadClass(ProxyClassLoader.java:187)

                                    at java.lang.ClassLoader.loadClass(ClassLoader.java:357)

                                    at org.netbeans.modules.netbinox.NetbinoxFactory.newFramework(NetbinoxFa

                            ctory.java:79)

                                    at org.netbeans.core.netigso.Netigso.prepare(Netigso.java:165)

                                    at org.netbeans.NetigsoHandle.turnOn(NetigsoHandle.java:138)

                                    at org.netbeans.ModuleManager.enable(ModuleManager.java:1339)

                                    at org.netbeans.ModuleManager.enable(ModuleManager.java:1156)

                                    at org.netbeans.core.startup.ModuleList.installNew(ModuleList.java:340)

                                    at org.netbeans.core.startup.ModuleList.trigger(ModuleList.java:276)

                                    at org.netbeans.core.startup.ModuleSystem.restore(ModuleSystem.java:301)

                             

                             

                                    at org.netbeans.core.startup.Main.getModuleSystem(Main.java:181)

                                    at org.netbeans.core.startup.Main.getModuleSystem(Main.java:150)

                                    at org.netbeans.core.startup.Main.start(Main.java:307)

                                    at org.netbeans.core.startup.TopThreadGroup.run(TopThreadGroup.java:123)

                             

                             

                                    at java.lang.Thread.run(Thread.java:745)

                            Caused by: java.lang.NoClassDefFoundError: org/eclipse/osgi/baseadaptor/HookConf

                            igurator

                                    at java.lang.ClassLoader.defineClass1(Native Method)

                                    at java.lang.ClassLoader.defineClass(ClassLoader.java:760)

                                    at org.netbeans.JarClassLoader.doLoadClass(JarClassLoader.java:311)

                                    at org.netbeans.ProxyClassLoader.selfLoadClass(ProxyClassLoader.java:259

                            • 12. Re: problem starting sql developer 4.1.1.19.59
                              Gary Graham-Oracle

                              In the future, I recommend you start a new discussion and provide a link referencing the prior discussion rather than piggybacking on.

                               

                              It sounds like your install is corrupt...  when you changed the location of your SQL Developer install, did you just copy/move the directory contents or did you unzip into an empty directory?  The HookConfigurator.class should be under your install directory in...

                              sqldeveloper\netbeans\platform\modules\ext\org.eclipse.osgi_3.9.1.v20140110-1610.jar

                              Try downloading the zip again and installing into an empty directory.

                              • 13. Re: problem starting sql developer 4.1.1.19.59
                                user525542

                                Hi Gary:

                                 

                                Thank-you.  The issue I was having kept leading me to this thread, so I felt it was good to post here, but next time I promise to start a new thread.  :-)

                                 

                                You were absolutely correct, it was a corrupted compressed zip.   Not sure how or where the corruption occurred, but to fix it:

                                 

                                1) re-download zip from ORACLE site

                                2) unblock the zip file (using Windows Explorer file properties)

                                3) use Windows Explored to copy all files from the compressed directory into a new directory (did not use "universal extractor" app or "winzip")

                                 

                                Worked like a charm!


                                -Mike