3 Replies Latest reply on Apr 12, 2006 8:49 PM by Deepak Arora-Oracle

    OPMN Start Error

    493834
      Hi All,

      I encounter the error when I tried to start the OPMN by running opmnctl start
      opmnctl start
      pingwait exits with 1228584
      opmnctl: opmn start failed

      My OC4J 10g was working fine before until after i run the command dcmctl updateConfig, and after that i got the above problem of OPMN started failed.

      I have tried many ways for resolving the problem, but in vain, so finally i uninstall the OC4J 10g, then reinstall again. The sad thing is the above problem is still there......I cannot start OPMN at all..

      Do anyone have any idea on that? Plsss help me.....

      Thank you very much!!!
        • 1. Re: OPMN Start Error
          441615
          Hi,

          I think the OPMN.XML file is corrupted by the DCM command you used. You need to validate your OMPN.xml using :-

          opmnctl validate

          If this tells you that " opmnctl: opmn validation failed! ", you can try to validate the backup file :-

          opmnctl validate opmn.xml.bak

          If this is fine, you can trash the contents of OPMN.xml and copy & paste the contents of opmn.xml.bat. A dcmctl resyncinstance -force should then do the trick.

          Regards,

          Sandeep
          • 2. Re: OPMN Start Error
            493834
            Hi Sandeep,

            After i ran opmnctl validate, the validation was successful. So, i ran dcmctl resyncinstance -force, but i got the following error:

            C:\Documents and Settings\lauid>echo %ORACLE_HOME%
            C:\OraHome_1\ssmdev
            C:\OraHome_1\ssmdev\dcm\bin>dcmctl resyncinstance -force
            ADMN-705002
            The most likely causes are:
            1. TaskMaster cannot read configuration files, such as $ORACLE_HOME/opmn/conf/op
            mn.xml, and $ORACLE_HOME/dcm/dcm.conf, etc.
            2. Cannot connect to the repository.
            Resolution:
            1. Make sure that the system configuration files are present and the permission
            for those files are set correctly.
            2. If you are using Infrastructure Database, please make sure that the database
            is up and running, and the listener for the database is running. Also check the
            connectivity of the machine to the Database Repository. Please refer to the exce
            ption thrown by the Repository API for resolution. The Repository API may be mi
            sconfigured.
            Base Exception:
            oracle.ons.SubscriptionException
            Subscription request timed out after 120000 millseconds. Possible causes: OPMN
            may not be running, you may have an OPMN running in an alternate ORACLE_HOME usi
            ng duplicate port values, or OPMN may be misconfigured.
            oracle.ons.SubscriptionException: Subscription request timed out after 120000 mi
            llseconds. Possible causes: OPMN may not be running, you may have an OPMN runni
            ng in an alternate ORACLE_HOME using duplicate port values, or OPMN may be misco
            nfigured.
            at oracle.ons.SubscriptionNotification.waitForReply(SubscriptionNotifica
            tion.java:82)
            at oracle.ons.ONS.addSubscriber(ONS.java:336)
            at oracle.ons.Subscriber.realStartup(Subscriber.java:92)
            at oracle.ons.Subscriber.<init>(Subscriber.java:80)
            at oracle.ons.ONS.createNewSubscriber(ONS.java:690)
            at oracle.ias.sysmgmt.task.TaskMaster.sysInit(Unknown Source)
            at oracle.ias.sysmgmt.task.TaskMaster.sysInit(Unknown Source)
            at oracle.ias.sysmgmt.task.InstanceManager.sysInit(Unknown Source)
            at oracle.ias.sysmgmt.task.InstanceManager.init(Unknown Source)
            at oracle.ias.sysmgmt.cmdline.DcmCmdLine.checkInit(Unknown Source)
            at oracle.ias.sysmgmt.cmdline.DcmCmdLine.execute(Unknown Source)
            at oracle.ias.sysmgmt.cmdline.DcmCmdLine.main(Unknown Source)

            I have already set my ORACLE_HOME in my system environment variables. But even i delete this sys variable, the above error still existed.

            Please advise.

            Thank you very much for your great help.
            • 3. Re: OPMN Start Error
              Deepak Arora-Oracle
              Hi There,

              Looks like you have a corrupted repository.

              What version of the application server have you installed? Are you using a file base or database repository? What does dcmtl getState -v -d show?

              These resynch problems are easier to fix if you file a SR with Oracle Support. If however you cannot file a SR the choices are trying to fix this or[b] fully  uninstalling the application server.

              What were the changes that you made prior to running dcmctl updateConfig? Did you create a backup of the files that you changed?

              We might be able to restore the files through the archive that dcm creates (only if you are using 10.1.2.x) but lets see if you have a back up of the modified files, and try to resolve it through them first.

              Deepak

              Message was edited by:
              Deepak Arora