1 Reply Latest reply on Aug 31, 2015 10:30 AM by 3021946

    Analytics connection error after installing OBIEE 11g 11.1.1.7.150120 Bundle Patch

    3021946

      Hello

       

      After recent OBIEE upgrade from 11.1.1.7.0 to 11.1.1.7.150120 using bundle patch  (downloaded from here: https://blogs.oracle.com/proactivesupportEPM/entry/obiee_11g_11_1_11 )  along with Patch 16569379 - Dynamic Monitoring Service patch I've been facing an issue  with Dashboards and analyses in  Analytics

       

      I'm new to oracle, coming from SQL Server so i might be missing something obvious here

       

      Dashboards that worked fine before update, now throw errors on queries.

       

      Error

      View Display Error

      Odbc driver returned an error (SQLExecDirectW).

      Error Codes: OPR4ONWY:U9IM8TAC:OI2DL65P

      State: HY000. Code: 10058. [NQODBC] [SQL_STATE: HY000] [nQSError: 10058] A general error has occurred. [nQSError: 43113] Message returned from OBIS. [nQSError: 16001] ODBC error state: IM003 code: 160 message: Specified driver could not be loaded due to system error 127: The specified procedure could not be found. (Oracle in instantclient_11_2, C:\Oracle\instantclient_11_2\SQORA32.dll).. (HY000)

       

      SQL Issued: (...)

       

       

      Additional info:

      OS: windows server 2008 R2 Standard

      I followed instruction included in readme of patch bundle, untill couple last hours i haven't made any other changes in environment. (so nothing besides instructions in readme)

      Patches are applied, analytics shows "Oracle Business Intelligence Product Version 11.1.1.7.150120 (Build 150113.1200 64-bit). "

      opatch lsinventory showed all (8+1) patches applied

      SQORA32.dll is present in C:\Oracle\instantclient_11_2

      Test connection in ODBC succeded , i was also able to define new system dns using the same parameters

      I was also able to refresh database structure in Bi Administration Tool using mentioned instantclient system dns

      Instant client version when i started -  11.2.0.3.0

      I also tried 11.2.0.3.0  - changed folder name from instantclient_11_2 to instantclient_11_2_OLD, unpacking instantclient 11.2.0.4 to instantclient_11_2- going by this doc ( http://docs.oracle.com/cd/B19306_01/install.102/e12121/post_inst_task.htm#CHDHHJHH - Upgrading instant client)

      (now instantclient_11_2  points to older version - 11.2.0.3.0 )


      All registry entries point to correct path ( C:\Oracle\instantclient_11_2)

      during patch installation i issued some set commands to path enviornment variable, as instructed, it looks like this now (new line for clarity)

      C:\Users\Administrator>set pat

      Path=

      C:\Program Files\HP\NCU

      ;C:\Windows\system32

      ;C:\Windows

      ;C:\Windows\System32\Wbem

      ;C:\Windows\System32\WindowsPowerShell\v1.0\ vbs

      ;D:\Programs\OBI\Oracle_BI1\bin

      ;D:\Programs\OBI\Oracle_BI1\opmn\bin

      ;D:\Programs\OBI\Oracle_BI1\opmn\lib

      ;D:\Programs\OBI\Oracle_BI1\perl\bin

      ;C:\Program Files (x86)\Microsoft SQL Server\110\Tools\Binn\

      ;D:\Programs\SQL 2012 Express\110\Tools\Binn\

      ;D:\Programs\SQL 2012 Express\110\DTS\Binn\

      ;C:\Program Files (x86)\Microsoft SQL Server\110\Tools\Binn\ManagementStudio\

      ;C:\Program Files (x86)\Microsoft SQL Server\110\DTS\Binn\

      ;C:\Oracle\instantclient_11_2\

       

      Comments in posts about similar errors suggested moving  instant client to the beggining, tried this but it seems nothing changed (i tried changing it and restarting core application- it's possible it was not enough)


      TNS_Admin points to correct directory ( tnsnames.ora file)

       

      I' ve been browsing forums, but so far i was unable to find a solution, but  as i said  - Im new to OBIEE, coming from SQL Server so i might be missing something obvious here