1 Reply Latest reply on Sep 9, 2015 2:34 PM by dmdamiyo

    AutoRest feature and APEX?

    dmdamiyo

      Hi,

      Oracle documentation says about AutoRest:

      "Note that this feature is only available for Oracle REST Data Services- enabled schemas, not for Oracle Application Express workspaces"

       

      I created a schema called "TESTORDS" using SQLDeveloper and enabled REST services for it. Everything worked, I had access to metadata catalog and was able to access desired resources. But after I had created APEX workspace for this schema, with the same name (workspace name "TESTORDS", schema name "TESTORDS") it stopped working. So after the creation of the APEX workspace I couldn't access metadata catalog and any of the resources.

       

      Is this the designed behavior or am I doing something wrong?

        • 1. Re: AutoRest feature and APEX?
          dmdamiyo

          Ok, I solved it.

           

          Seems that when you create a workspace with the same name as the schema it overwrites it.

          So now you cannot use autorest.

           

          If I name the workspace differently but use the same schema I'm able to use autorest using:

          localhost:8080/ords/SCHEMA/employyes

          and I can use all modules I created in apex using:

          localhost:8080/ords/WORKSPACE/employyes