13 Replies Latest reply on Sep 17, 2015 5:37 AM by yoonas

    adgendb.sh error

    JFCastro

      Hi everyone,

       

      I need your help,

       

      I have an 11i instance an this was with 9i database (9.2.0.6). I upgraded the database to 9.2.0.8 version with the intention to migrate this database to the 11g release

       

      the situation is the following

       

      EBS 11i

      9i database 9.2.0.8

      OS Red Hat Enterprise Linux AS release 4 (Nahant Update 8)

       

      I have an error when I perform /u01/appltest/testcomn/admin/scripts/TEST_orapps/adautocfg.sh,  specifically with the adgendbc.sh, the error in the above message



       

      [appltest@orapps TEST_orapps]$ ./adgendbc.sh

      adgendbc.sh started at lun sep 14 09:05:52 CLT 2015

      Enter the APPS username: apps

      Enter the APPS password:

      SQL*Plus: Release 8.0.6.0.0 - Production on Mon Sep 14 09:05:55 2015

      (c) Copyright 1999 Oracle Corporation.  All rights reserved.

       

      Enter value for 1: Enter value for 2: Enter value for 3: Connected.

      Created profile option value - 0 row(s) inserted

      Application Id : 0

      Profile Name : APPS_DATABASE_ID

      Level Id : 10001

      Profile Value : test

       

      PL/SQL procedure successfully completed.

       

      Commit complete.

       

      Disconnected from Oracle9i Enterprise Edition Release 9.2.0.8.0 - Production

      With the Partitioning, OLAP and Oracle Data Mining options

      JServer Release 9.2.0.8.0 - Production

       

      ==============================

      * * * * DBC PARAMETERS * * * *

      ==============================

      fnd_jdbc_stmt_cache_free_mem=TRUE

      fnd_jdbc_buffer_min=1

      fnd_jdbc_buffer_max=5

      fnd_jdbc_buffer_decay_interval=300

      fnd_jdbc_buffer_decay_size=5

      fnd_jdbc_usable_check=false

      fnd_jdbc_context_check=true

      fnd_jdbc_plsql_reset=false

       

      ====================================

      * * * * NO CUSTOM PARAMETERS * * * *

      ====================================

       

      Unique constraint error (00001) is OK if key already exists

      Unable to update GUEST_USER_PWD in database to GUEST/ORACLE - null

      Application server ID already exists for this host - loading..

      ADD executed successfully - /u01/appltest/testappl/fnd/11.5.0/secure/TEST_orapps/orapps_test.dbc

      Unable to update GUEST_USER_PWD in database to GUEST/ORACLE - null

      Application server ID already exists for this host - loading..

      ADD executed successfully - /u01/appltest/testappl/fnd/11.5.0/secure/TEST_orapps/orapps_test.dbc

       

      ........ Updated for ias1022 ..... exiting 

       

      Generating /u01/appltest/testappl/fnd/11.5.0/secure/orapps.adepta.cl_TEST.dbc

      DBC argument specified, ignoring SECURE_PATH

      Unable to update GUEST_USER_PWD in database to GUEST/ORACLE - null

      UPDATE executed successfully - /u01/appltest/testappl/fnd/11.5.0/secure/orapps.adepta.cl_TEST.dbc

       

      Generating /u01/appltest/testappl/fnd/11.5.0/secure/orapps_TEST.dbc

      DBC argument specified, ignoring SECURE_PATH

      Unable to update GUEST_USER_PWD in database to GUEST/ORACLE - null

      UPDATE executed successfully - /u01/appltest/testappl/fnd/11.5.0/secure/orapps_TEST.dbc

       

      Updating Server Security Authentication

      java.sql.SQLException: Excepción de E/S: Invalid number format for port number

      Database connection to jdbc:oracle:thin:@host_name:port_number:database failed

      Updating Server Security Authentication failed with exit code 1

      adgendbc.sh exiting with status 1

      ERRORCODE = 1 ERRORCODE_END

       


      I've tried everything but nothing

       

      the database up without any problem, I run adautocfg.sh in the database without any problem when I perform adstrtal.sh all aplication services up withou any problem but is in blank appslogin I imagine that is to root the error in adgendbc.sh


      anyone can help me?


      best regards,

       

      Felipe Farías Lagos

        • 1. Re: adgendb.sh error
          JFCastro

          Hi experts,

           

          I've noticed when I execute adautocfg.sh in the application tier the Classpath appears double //, above the indicated;

          [appltest@orapps TEST_orapps]$ adautocfg.sh

          Enter the APPS user password :

           

          The log file for this session is located at: /u01/appltest/testappl/admin/TEST_orapps/log/09141726/adconfig.log

           

          AutoConfig is configuring the Applications environment...

           

          AutoConfig will consider the custom templates if present.

              Using APPL_TOP location     : /u01/appltest/testappl

              Classpath                   : /usr/java/jdk1.6.0_05//jre/lib/rt.jar:/usr/java/jdk1.6.0_05//lib/dt.jar:/usr/java/jdk1.6.0_05//lib/tools.jar:/u01/appltest/testcomn/java/appsborg2.zip:/u01/appltest/testcomn/java

           

              Using Context file          : /u01/appltest/testappl/admin/TEST_orapps.xml

           

          why it occur this, how can fix this error ?

           

          Best Regard,

           

          Felipe Farías Lagos

           



           

          • 2. Re: adgendb.sh error
            Chiranjeevi M A

            Hello,

             

            Did you check the output of the below query??

            Please post the o/p.

             

            select fnd_web_sec.validate_password('GUEST','ORACLE') from dual;

             

            -Chiranjeevi M A

            • 3. Re: adgendb.sh error
              JFCastro

              Hello, thanks for your answer, The result of this query is 'N' best regards, Felipe Farías

              • 4. Re: adgendb.sh error
                JFCastro

                I have achieved to fix the problem with the adautocfg.sh, I modified the context file (delete double //)

                Now the problem is that the APPSLOGIN is in blank and the "Logon to Oracle Applications Manager" "Oracle Applications Manager" goes to Internal Server Error

                below, I left  the log of the adstrtal.sh

                 

                any help will be very usefull

                 

                [appltest@orapps TEST_orapps]$ adstrtal.sh apps/apps

                 

                You are running adstrtal.sh version 115.19

                 

                Executing service control script:

                /u01/appltest/testcomn/admin/scripts/TEST_orapps/adapcctl.sh start

                script returned:

                ****************************************************

                 

                adapcctl.sh version 115.55

                 

                Oracle error 100: ORA-01403: no data found

                has been detected in FND_CLIENT_INFO.SETUP_CLIENT_INFO.

                Apache Web Server Listener :httpd ( pid 18916 ) is running.

                Can not start Apache Web Server now

                Oracle error 100: ORA-01403: no data found

                has been detected in FND_CLIENT_INFO.SETUP_CLIENT_INFO.

                Oracle error 100: ORA-01403: no data found

                has been detected in FND_CLIENT_INFO.SETUP_CLIENT_INFO.

                Apache Web Server Listener (PLSQL) :httpd ( pid 18960 ) is running.

                Can not start Apache Web Server now

                Oracle error 100: ORA-01403: no data found

                has been detected in FND_CLIENT_INFO.SETUP_CLIENT_INFO.

                 

                adapcctl.sh: exiting with status 0

                 

                 

                .end std out.

                 

                .end err out.

                 

                ****************************************************

                 

                 

                Executing service control script:

                /u01/appltest/testcomn/admin/scripts/TEST_orapps/adalnctl.sh start

                script returned:

                ****************************************************

                 

                adalnctl.sh version 115.17

                 

                Checking for FNDFS executable.

                Listener APPS_TEST has already been started.

                 

                adalnctl.sh: exiting with status 2

                 

                 

                .end std out.

                 

                .end err out.

                 

                ****************************************************

                 

                 

                Executing service control script:

                /u01/appltest/testcomn/admin/scripts/TEST_orapps/adcmctl.sh start

                script returned:

                ****************************************************

                 

                You are running adcmctl.sh version 115.31

                 

                Starting concurrent manager for TEST ...

                Starting TEST_0915@TEST Internal Concurrent Manager

                Default printer is noprint

                 

                adcmctl.sh: exiting with status 0

                 

                 

                .end std out.

                 

                .end err out.

                 

                ****************************************************

                 

                 

                Executing service control script:

                /u01/appltest/testcomn/admin/scripts/TEST_orapps/adfrmctl.sh start

                script returned:

                ****************************************************

                 

                You are running adfrmctl.sh version 115.38

                 

                Oracle error 100: ORA-01403: no data found

                has been detected in FND_CLIENT_INFO.SETUP_CLIENT_INFO.

                forms server for TEST on port 9010 already started.

                 

                adfrmctl.sh: exiting with status 2

                 

                 

                .end std out.

                 

                .end err out.

                 

                ****************************************************

                 

                 

                Executing service control script:

                /u01/appltest/testcomn/admin/scripts/TEST_orapps/adrepctl.sh start

                script returned:

                ****************************************************

                 

                You are running adrepctl.sh version 115.33

                 

                Oracle error 100: ORA-01403: no data found

                has been detected in FND_CLIENT_INFO.SETUP_CLIENT_INFO.

                Reports Server for TEST is already started.

                 

                adrepctl.sh: exiting with status 2

                 

                 

                .end std out.

                 

                .end err out.

                 

                ****************************************************

                 

                 

                Executing service control script:

                /u01/appltest/testcomn/admin/scripts/TEST_orapps/adfmcctl.sh start

                script returned:

                ****************************************************

                 

                You are running adfmcctl.sh version 115.20

                 

                Oracle error 100: ORA-01403: no data found

                has been detected in FND_CLIENT_INFO.SETUP_CLIENT_INFO.

                forms load balancing client for TEST already running.

                 

                adfmcctl.sh: exiting with status 2

                 

                 

                .end std out.

                 

                .end err out.

                 

                ****************************************************

                 

                 

                Executing service control script:

                /u01/appltest/testcomn/admin/scripts/TEST_orapps/adfmsctl.sh start

                script returned:

                ****************************************************

                 

                You are running adfmsctl.sh version 115.16

                 

                Oracle error 100: ORA-01403: no data found

                has been detected in FND_CLIENT_INFO.SETUP_CLIENT_INFO.

                forms  metrics serverfor TEST is already started.

                 

                adfmsctl.sh: exiting with status 2

                 

                 

                .end std out.

                 

                .end err out.

                 

                ****************************************************

                 

                 

                Executing service control script:

                /u01/appltest/testcomn/admin/scripts/TEST_orapps/jtffmctl.sh start

                script returned:

                ****************************************************

                 

                You are running jtffmctl.sh version 115.16

                 

                Validating Fulfillment patch level via /u01/appltest/testcomn/java

                Fulfillment patch level validated.

                Starting Fulfillment Server for TEST on port 9310 ...

                 

                jtffmctl.sh: exiting with status 0

                 

                 

                .end std out.

                 

                .end err out.

                 

                ****************************************************

                 

                 

                Executing service control script:

                /u01/appltest/testcomn/admin/scripts/TEST_orapps/addisctl.sh start

                script returned:

                ****************************************************

                 

                addisctl.sh version 115.16

                 

                Starting discoverer processes

                 

                Oracle Discoverer OAD is running as PID 20128

                 

                Oracle Discoverer OSAGENT is running as PID 20178

                 

                Oracle Discoverer LOCATOR is running as PID 20195

                 

                 

                addisctl.sh: exiting with status 2

                 

                 

                .end std out.

                 

                .end err out.

                 

                ****************************************************

                 

                 

                All enabled services for this node are started.

                Check logfile /u01/appltest/testcomn/admin/log/TEST_orapps/09151207.log for details

                 

                Exiting with status 0

                 

                 

                thanks in advance

                 

                best regards,

                 

                Felipe Farías L.

                • 5. Re: adgendb.sh error
                  Hussein Sawwan-Oracle
                  I upgraded the database to 9.2.0.8 version with the intention to migrate this database to the 11g release

                   

                   

                  Please confirm that "JAVA_JIT_ENABLED" is set to "FALSE" -- See (Doc ID 1673030.1) for details.

                   

                  Thanks,

                  Hussein

                  • 6. Re: adgendb.sh error
                    JFCastro

                    Hi Hussein,

                     

                    thank for your answer

                     

                    i checked the note, but actually we have EBS 11i (11.5.10.2) db 9i (9.2.0.8)

                     

                    I execute the below query and the result is 'N'

                    select apps.fnd_web_sec.validate_password('GUEST','ORACLE') from dual;

                     

                    respect for the "alter system set JAVA_JIT_ENABLED= FALSE scope = both;" it's not posible to execute because our database is 9i

                     

                    Anyway, I compiled JSP with the following statement

                     

                    perl -x /u01/appltest/testappl/jtf/11.5.0/admin/scripts/ojspCompile.pl --compile --flush -p 2

                     

                    the result was

                     

                    [appltest@orapps TEST_orapps]$ perl -x /u01/appltest/testappl/jtf/11.5.0/admin/scripts/ojspCompile.pl --compile --flush -p 2

                    identifying apache_top.../u01/appltest/testora/iAS

                    identifying apache_config_top.../u01/appltest/testora/iAS

                    identifying java_home.../usr/java/jdk1.6.0_05

                    identifying jsp_dir.../u01/appltest/testcomn/html

                    identifying pages_dir.../u01/appltest/testcomn

                    identifying classpath...file:///u01/appltest/testora/iAS/Apache/Jserv/etc/jserv.properties

                    auto-logging to /u01/appltest/testcomn/_pages/ojsp_error.log

                    starting...(compiling all)

                    using 8i internal ojsp ver: 1.1.3.5.2

                    including compatibility flag -whiteSpaceBetweenScriptlet

                    synchronizing dependency file:

                      loading deplist...15470

                      enumerating jsps...15470

                      updating dependency...0

                    initializing compilation:

                      eliminating children...12382 (-3088)

                    translating and compiling:

                      translating jsps...12382/12382 [failed: 3] in 2m42s             

                      compiling jsps...12379/12379 [failed: 10] in 7m3s                  

                    Finished!

                     

                     

                     

                    after that I up the apps service with adstrtal.sh with the same problem (http://orapps.adepta.cl:8010/oa_servlets/AppsLogin is in blank)

                    I think that the problem is

                     

                    Oracle error 100: ORA-01403: no data found

                    has been detected in FND_CLIENT_INFO.SETUP_CLIENT_INFO.

                     

                    but I haven't found any note with the fix

                     

                    the result of the adstrtal.sh is:

                     

                     

                     

                    [appltest@orapps TEST_orapps]$ adstrtal.sh apps/apps

                     

                    You are running adstrtal.sh version 115.19

                     

                    Executing service control script:

                    /u01/appltest/testcomn/admin/scripts/TEST_orapps/adapcctl.sh start

                    script returned:

                    ****************************************************

                     

                    adapcctl.sh version 115.55

                     

                    Oracle error 100: ORA-01403: no data found

                    has been detected in FND_CLIENT_INFO.SETUP_CLIENT_INFO.

                    Apache Web Server Listener :httpd ( pid 24150 ) is running.

                    Can not start Apache Web Server now

                    Oracle error 100: ORA-01403: no data found

                    has been detected in FND_CLIENT_INFO.SETUP_CLIENT_INFO.

                    Oracle error 100: ORA-01403: no data found

                    has been detected in FND_CLIENT_INFO.SETUP_CLIENT_INFO.

                    Apache Web Server Listener (PLSQL) :httpd ( pid 24194 ) is running.

                    Can not start Apache Web Server now

                    Oracle error 100: ORA-01403: no data found

                    has been detected in FND_CLIENT_INFO.SETUP_CLIENT_INFO.

                     

                    adapcctl.sh: exiting with status 0

                     

                     

                    .end std out.

                     

                    .end err out.

                     

                    ****************************************************

                     

                     

                    Executing service control script:

                    /u01/appltest/testcomn/admin/scripts/TEST_orapps/adalnctl.sh start

                    script returned:

                    ****************************************************

                     

                    adalnctl.sh version 115.17

                     

                    Checking for FNDFS executable.

                    Listener APPS_TEST has already been started.

                     

                    adalnctl.sh: exiting with status 2

                     

                     

                    .end std out.

                     

                    .end err out.

                     

                    ****************************************************

                     

                     

                    Executing service control script:

                    /u01/appltest/testcomn/admin/scripts/TEST_orapps/adcmctl.sh start

                    script returned:

                    ****************************************************

                     

                    You are running adcmctl.sh version 115.31

                     

                    Starting concurrent manager for TEST ...

                    Starting TEST_0915@TEST Internal Concurrent Manager

                    Default printer is noprint

                     

                    adcmctl.sh: exiting with status 0

                     

                     

                    .end std out.

                     

                    .end err out.

                     

                    ****************************************************

                     

                     

                    Executing service control script:

                    /u01/appltest/testcomn/admin/scripts/TEST_orapps/adfrmctl.sh start

                    script returned:

                    ****************************************************

                     

                    You are running adfrmctl.sh version 115.38

                     

                    Oracle error 100: ORA-01403: no data found

                    has been detected in FND_CLIENT_INFO.SETUP_CLIENT_INFO.

                    forms server for TEST on port 9010 already started.

                     

                    adfrmctl.sh: exiting with status 2

                     

                     

                    .end std out.

                     

                    .end err out.

                     

                    ****************************************************

                     

                     

                    Executing service control script:

                    /u01/appltest/testcomn/admin/scripts/TEST_orapps/adrepctl.sh start

                    script returned:

                    ****************************************************

                     

                    You are running adrepctl.sh version 115.33

                     

                    Oracle error 100: ORA-01403: no data found

                    has been detected in FND_CLIENT_INFO.SETUP_CLIENT_INFO.

                    Reports Server for TEST is already started.

                     

                    adrepctl.sh: exiting with status 2

                     

                     

                    .end std out.

                     

                    .end err out.

                     

                    ****************************************************

                     

                     

                    Executing service control script:

                    /u01/appltest/testcomn/admin/scripts/TEST_orapps/adfmcctl.sh start

                    script returned:

                    ****************************************************

                     

                    You are running adfmcctl.sh version 115.20

                     

                    Oracle error 100: ORA-01403: no data found

                    has been detected in FND_CLIENT_INFO.SETUP_CLIENT_INFO.

                    forms load balancing client for TEST already running.

                     

                    adfmcctl.sh: exiting with status 2

                     

                     

                    .end std out.

                     

                    .end err out.

                     

                    ****************************************************

                     

                     

                    Executing service control script:

                    /u01/appltest/testcomn/admin/scripts/TEST_orapps/adfmsctl.sh start

                    script returned:

                    ****************************************************

                     

                    You are running adfmsctl.sh version 115.16

                     

                    Oracle error 100: ORA-01403: no data found

                    has been detected in FND_CLIENT_INFO.SETUP_CLIENT_INFO.

                    forms  metrics serverfor TEST is already started.

                     

                    adfmsctl.sh: exiting with status 2

                     

                     

                    .end std out.

                     

                    .end err out.

                     

                    ****************************************************

                     

                     

                    Executing service control script:

                    /u01/appltest/testcomn/admin/scripts/TEST_orapps/jtffmctl.sh start

                    script returned:

                    ****************************************************

                     

                    You are running jtffmctl.sh version 115.16

                     

                    Validating Fulfillment patch level via /u01/appltest/testcomn/java

                    Fulfillment patch level validated.

                    Starting Fulfillment Server for TEST on port 9310 ...

                     

                    jtffmctl.sh: exiting with status 0

                     

                     

                    .end std out.

                     

                    .end err out.

                     

                    ****************************************************

                     

                     

                    Executing service control script:

                    /u01/appltest/testcomn/admin/scripts/TEST_orapps/addisctl.sh start

                    script returned:

                    ****************************************************

                     

                    addisctl.sh version 115.16

                     

                    Starting discoverer processes

                     

                    Oracle Discoverer OAD is running as PID 25415

                     

                    Oracle Discoverer OSAGENT is running as PID 25389

                     

                    Oracle Discoverer LOCATOR is running as PID 25422

                     

                     

                    addisctl.sh: exiting with status 2

                     

                     

                    .end std out.

                     

                    .end err out.

                     

                    ****************************************************

                     

                     

                    All enabled services for this node are started.

                    Check logfile /u01/appltest/testcomn/admin/log/TEST_orapps/09151206.log for details

                     

                    Exiting with status 0

                     

                    best regards,

                     

                    very thank

                     

                    Felipe Farías Lagos

                    • 7. Re: adgendb.sh error
                      Hussein Sawwan-Oracle

                      My bad, was under the impression that you moved to 11gR2 already.

                       

                      Please change the GUEST user password as per (How To Successfully Change The Guest Password In E-Business Suite 11.5.10 and R12 (Doc ID 443353.1)) and run the same select statement then.

                       

                      Thanks,

                      Hussein

                      • 8. Re: adgendb.sh error
                        JFCastro

                        Hussein,

                         

                        i have changed the password in the CONTEXT_FILE through vi, re-run AutoConfig. and this end without problem but when I up apps service (adstrtal.sh) I have the same error

                        I checked the the value in the select statemen select fnd_web_sec.validate_login('GUEST','ORACLE') from dual; and the result still is N

                        I checked the .dbc file and the GUEST_USER_PWD=GUEST/ORACLE


                        What am I doing wrong?


                        best regards,


                        Felipe Farías Lagos



                         

                        • 9. Re: adgendb.sh error
                          JFCastro

                          Hussein,

                           

                          It's strange, I was connected with system user and the query had the value N  (select apps.fnd_web_sec.validate_login('GUEST','ORACLE') from dual).

                          I connected with the apps user and the query give the Y result, but the problem still not have solution

                           

                          I don't have any value with the below query

                          select fnd_profile.value('GUEST_USER_PWD') from dual;

                           

                          regards,

                           

                          Fellipe Farías

                          • 10. Re: adgendb.sh error
                            JFCastro

                            Hi,

                             

                            I have reviewed the CONTEX_FILE and the .dbc and the GUEST/ORACLE it's the same in both files

                            select fnd_web_sec.validate_login('GUEST','ORACLE') from dual;

                            the result of the above query is Y, but I can't to enter to application,  http://orapps.adepta.cl:8010/oa_servlets/AppsLogin is in blank


                            what can to be?


                            Regards,


                            Felipe Farías Lagos

                            • 11. Re: adgendb.sh error
                              Chiranjeevi M A

                              Please refer the below MOS , it may help:

                               

                              11.5.10.2 Login Gives Blank Page Upon Login Attempt (Doc ID 1442162.1)

                              Blank Pages In I.E Browser With 11.5.10 (Doc ID 342303.1)

                               

                              -Chiranjeevi M A

                              • 12. Re: adgendb.sh error
                                JFCastro

                                Hi thanks for your answer, but the problem haven't been resolved....... I don't know what can to be....

                                 

                                regards,

                                 

                                Felipe Farías Lagos

                                • 13. Re: adgendb.sh error
                                  yoonas

                                  Hi,

                                   

                                  Had a look at Apache logs ?

                                  Please share

                                   

                                  Regards

                                  Yoonas