6 Replies Latest reply on Sep 27, 2015 6:53 PM by anders.norgaard

    SQLcl: Release 4.2.0.15.257.0801 - ansiconsole unwanted numeric formatting

    anders.norgaard

      Hi,

       

      When I set ansiconsole my keys which are NUMBER(19) are formated with grouping commas like 10,934,534 instead of just plain 10934534.

       

      Is there a way to disable this formatting?

       

      My login.sql is

       

      set sqlformat ansiconsole
      ALTER SESSION SET NLS_TIMESTAMP_FORMAT = 'YYYY-MM-DD HH24:MI:SS'
      ALTER SESSION SET NLS_NUMERIC_CHARACTERS = '.'
      

       

      however, the 3rd line is invalid.

       

      Any tips?

       

      Best,

      Anders