1 Reply Latest reply on Apr 18, 2006 10:44 AM by 159563

    AQ Adapter failure - reinstall doens't help, unless a new name is provided

    495699
      Hi

      Our AQ adapter worked fine for years, but after a restart it suddenly stopped working. No error messages are written when started but what is more strange, no log is written at all (the agent_log_level is set to 2, so it should write something). And of course it doens't do anything.

      What is more strange: if I reinstall it with the same name, nothing happens. If I reinstall it with a new name, it works correctly. The problem is that I nee to have this adapter with the original name, so installing with a new name doesn't solve my problem. It's just starnge. It seems that something is stored somewhere related to the original name and this is reloaded all the time is try to start it. I've tried to delete the persistence directory, but didn't help.

      Regards,
      Szilard
        • 1. Re: AQ Adapter failure - reinstall doens't help, unless a new name is provided
          159563
          I think something wrong with you repository!

          Try the folowing:
          1) stop all your adapters (check if it really stopeed - in windows look for processes with name "java.exe", in Unix "ps -ef adapter"), if not all stoped by stop script - kill them
          2) stop the repository (check if it really stopped)
          3) delete the "persistance" directory of all your adapters

          Then start normally: repository, than your adapter

          If it doesn't help - the problem may be with java.
          Smb. may have reinstall it or install a new version - and it can be not you, it can be administrator for ex.