1 Reply Latest reply on Oct 8, 2015 4:18 PM by Vigneswar Battu

    The file should be in XML-DATA-TEMPLATE format

    Williams Oluwafemi

      Hi all,

       

      please i am learning to build report in Oracle EBS,

      i have written my data template but uploading it in XML publisher gives the above error and below is the content and name i used to save it:

       

      <?xml version="1.0" encoding="WINDOWS-1252"?>

      <dataTemplate name="XX_REPORT" description="XX Report" version="1.0" defaultPackage="">

        <parameters>

         <parameter name="P_PARAMETER" datatype="character" defaultvalue="X"/>

         <parameter name="P_PROPERTY_CODE_FROM" datatype="character"/>

         <parameter name="P_PROPERTY_CODE_TO" datatype="character"/>

         <parameter name="P_PERIOD_NAME" datatype="character"/>

        </parameters>

      <dataQuery>

      <sqlStatement name="Q_HDR">

        <![CDATA[select distinct fbv.book_type_code book_type

        , fav.asset_id asset_id

        , fav.asset_number asset_number

        , fav.attribute_category_code category

        , fbv.life_in_months life_in_month

        ,fbv.prorate_date prorate_date

        , fbv.cost cost

            from fa_additions fav,

        fa_books_v fbv,

        fa_categories_vl fcv

           where fav.asset_category_id = fcv.category_id

           and fav.asset_id    = fbv.asset_id

           order by asset_number

        ]]>

        </sqlStatement>

        <dataQuery>

        <dataStructure>

          <group name="G_BOOK" source="Q_HDR">

        <element name="book_type" value="book_type"/>

        <element name="book_cost" value="cost" function="SUM()"/>

        <group name="G_PROPERTY" source="Q_HDR">

        <element name="property_cost" value="cost" function="SUM()"/>

        <group name="G_ASSET" source="Q_HDR">

        <element name="asset_id" value="asset_id"/>

        <element name="asset_number" value="asset_number"/>

        <element name="category" value="category"/>

        <element name="life_in_months" value="life_in_months"/>

        <element name="cost" value="cost"/>

        </group>

        </group>

           </group>

      </dataStructure>

       

       

      the name is XX_REPORT.xml


      please what could be the issue here?

      Thanks.xx-rep.PNG