4 Replies Latest reply on Nov 8, 2015 11:24 AM by 2829271

    Smart  view Error

    871516

      Hi All,

       

      i faced the issue while retrieving the data smart view.The request time out.Contact your Smart view Client system administrator to extend your windows internet explorer time out settings(Receive time out,KeepAliveTimeout,  and server Info time out).

        • 1. Re: Smart  view Error
          rpc1

          Read document

          Oracle Support Document 1995401.1

           

          You have to create keys in registry

           

          [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings]

          [HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Internet Settings]

          Create the following new DWORD keys with decimal values:

          ReceiveTimeout=480000

          KeepAliveTimeout=180000

          ServerInfoTimeout=180000

           

          or increase values if it exists

          • 2. Re: Smart  view Error
            Srinivas_Nanduri

            Update IE registry values as below given.

             

            Windows Registry Editor Version 5.00

            [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings]

            "KeepAliveTimeout"=dword:00180000

            "ReceiveTimeout"=dword:00dbba00

            "ServerInfoTimeout"=dword:00180000

            • 3. Re: Smart  view Error
              2829271

              Before going to increase the net retrieval count in user machine please ask them (user) to get the Admin rights in that machine. Then only our changes will applicable.

                

                

               

              To change the default time-out value for persistent HTTP connections in Internet Explorer and then set its value data to the time (in milliseconds) that you want Internet Explorer to wait before resetting an idle connection please follow these steps:

              1. Click Start, click Run, type regedit, and then click OK.
              2. Locate and then click the following key in the registry:
              HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\InternetSettings
              3. On the Edit menu, point to New, and then click DWORD Value.
              4. Type KeepAliveTimeout, and then press ENTER.
              5. On the Edit menu, click Modify.
              6. Type the appropriate time-out value (in milliseconds), and then click OK. For example, to set the time-out value to two minutes, type 120000 (or 180000 for 3 minutes).
              7. On the Edit menu, point to New, and then click DWORD Value.
              8. Type ServerInfoTimeout, and then press ENTER.
              9. On the Edit menu, click Modify.
              10. Type the appropriate time-out value (in milliseconds), and then click OK. For example, to set the time-out value to two minutes, type 120000.
              11. Restart Internet Explorer.
              Although Microsoft does not encourage this approach, you may also need to change the default time-out setting for Internet Explorer 7:
              12. Add a ReceiveTimeout DWORD value with a data value of ()*1000 in the following registry key:
              HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings
              For example, if you want the timeout duration to be 8 minutes, set the ReceiveTimeout data value to 480000
              (<480>*1000).
              13. Restart your computer.

                

                

               

              Please changes below settings also if problem reproduce:

                

                

               

              The following registry keys have to be updated on the client machine:

              1. Open the Registry (Start -> Run -> Regedit)
              2. Locate the following section:[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings\
              3. Create the following new keys for DWORD with Hexadecimal values:

              ReceiveTimeout and set it to 00dbba00
              KeepAliveTimeout and set it to 00180000
              ServerInfoTimeout and set it to 00180000

              4. Locate the following section: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\ Services\TCPIP\Parameters\
              5. Create the following keys for DWORD with Decimal Values:

              TcpTimedWaitDelay and set it to 30
              MaxUserPort should be set to 65534

              6. Restart the Client machine for the new settings to take effect and check if the issue is reproduced.

                

                

               

              For Excel 2007

                

               

               

               

                To avoid this message you have to modify IE registry settings (even if the message appears under Excel 2007)
              For that, you can
              1. Create a text file and copy/paste the text below.
              2. Rename the text file to "LogOut.reg"
              3. Execute the file (double-click) to change the registry.

              Windows Registry Editor Version 5.00
              [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings]
              "KeepAliveTimeout"=dword:00180000
              "ReceiveTimeout"=dword:00dbba00
              "ServerInfoTimeout"=dword:00180000

              • 4. Re: Smart  view Error
                2829271

                Here below you can find the optimization steps, it will useful for this issues.

                 

                Here info is very important and useful to our daily work as while we are retrieving smart view retrievals generally we will face an issues with slowness in the way of connectivity , in that case if we follow below steps it would be very helpful to us to get the faster performance in Hyperion smart view.

                • Retrieval time will be fastest when using a new Excel sheet. Every time we perform a Refresh, Smart View caches the activity (this is why we can press “Undo” so many times).

                • Repeatedly running retrieves off of the same Excel sheet will therefore cause performance to slowly diminish over time.

                • If performance becomes noticeably slower after using the same sheet for an extended period of time, open a blank Excel workbook and recreate the query.Select the option to Use Excel Formatting. Without this option, Smart View will reformat each cell based on the grid operations we perform.

                • It will also mark cells as “dirty” each time we change data values.These activities add system overhead to all Refreshes, making them take longer.

                • The most efficient performance will result from small, focused queries on a specific subset of data.

                • Zooming in on extremely large dimensions will cause slow performance. If we absolutely must zoom in on larger dimensions, suppressing rows that have no data or zero data will help.

                  The bigger our Excel workbook, the slower our Smart View queries will run. This is why running a query in an Excel workbook that has many other worksheets can take a long, long time.Retrieval performance will be optimized if the Smart View query is the only tab in the workbook.

                 

                 

                If other worksheets are being used, the overall size of the file itself will have the biggest impact on performance. Queries used in larger files (over 10 MB) are very likely to run slowly.

                 

                 

                Turn off the preserve formulas option when retrieving against an ASO Essbase cube. This has been known to make retrieves take much longer than normal.Interestingly enough, it also can dramatically increase the size of the Excel file itself when this setting is turned on. It does not seem to do this against a BSO or Planning cube.

                 

                 

                The Excel Auto Recover option can create performance issues or even cause the query to crash. For example, if the Auto Recover option is set to every 3 minutes, a query that takes longer than 3 minutes to retrieve will cause Excel to crash. Disable this option if we are using large queries.


                If we have users that rely on Smart View to pull data from our Essbase and Planning application, many of them may have large spreadsheets. One way to improve the perception of the performance of Essbase is the method in which Smart View (client side) communicates with the server.

                 

                APS [Analytic Provider Services], Planning, and HFM have the ability to take advantage of compression during the communication process. When large queries, retrieving and submitting data, are initiated, the performance can be significant.

                 

                The default compression settings for APS and Planning are not turned on Find the essbase.properties file on the APS server and change it to false. The path to this file is different in versions 9 and 11. In 11, the path is \Products\Essbase\aps\bin.

                smartview.webservice.gzip.compression.disable=false

                Open the Hyperion Planning application and change the

                  SMARTVIEW_COMPRESSION_THRESHOLD in the System Properties

                  (Administration/Manage Properties – System Properties tab) to a value not less than 1 This threshold is the minimum size of the query in which compression will be used. So, a value of 1000 would mean compression would be used for anything greater than 1,000 bytes.

                 

                 

                For smaller queries, compression may not be necessary. It may even decrease performance because of the overhead to compress and uncompress the data.

                 

                Still if you have any issues with Hyperion smartview ,please go to aps server and increase the heap size of below file.

                 

                 

                path, C:\Oracle\Middleware\user_projects\epmsystem1\bin\deploymentScripts

                 

                 

                Above path you can find setCustomParamsAnalyticProviderServices batch file,please open this batch file in notepad and edit line like below.

                 

                 

                set USER_MEM_ARGS=-Xms2048m -XX:PermSize=64m -XX:MaxPermSize=256m -Xmx2048m

                 

                Once its done please stop and start essbase & check the issue.Still if you have an issues please modify above line like below.

                 

                set USER_MEM_ARGS=-Xms4096m -XX:PermSize=64m -XX:MaxPermSize=256m -Xmx4096m 



                Regards

                Prasad