5 Replies Latest reply on Nov 11, 2015 11:32 PM by Haytham Mostafa

    Errors with adadmin & adpatch

    Haytham Mostafa

      Dear Expers,

       

      I did a clone from my production envirnoment, currently I am facing the following errors with 'adadmin' & 'adpatch':

       

      Error: ld.so.1: adadmin: fatal: /oa1/oa01/app/apps/tech_st/10.1.2/lib/libclntsh.so.10.1 wrong ELF class: ELFCLASS64

                Killed

       

      - I tried the following solution but the error still exist:

       

      1. mv $ORACLE_HOME/lib32/ldflags ldflags_bckp

       

      2. ln -s $ORACLE_HOME/lib/ldflags $ORACLE_HOME/lib32/ldflags

       

      3. as root, cp /usr/css/bin/make /usr/bin/

       

      4. as root, chmod 777 /usr/bin/make

       

      5. as root, chmod -R 777 $ORACLE_HOME/bin

       

      6. cd $ORACLE_HOME/bin

       

      7. genclntsh

      # completed without error

       

      8. relink all

       

      after 'relink' completed I tried to run the 'adadmin' but the the error still exist.

       

      PLEASE ADVICE ...

       

      # My cuurent envirnoment:

       

      Operating system: Oracle Solaris 10

      Application: 12.1.3

      RDBMS: 11.2R2

       

      # .profile:

       

      . /oa1/oa01/app/apps/apps_st/appl/TEST_kpcappl1.env

      ORACLE_HOME= /oa1/oa01/app/apps/tech_st/10.1.2