2 Replies Latest reply on Nov 18, 2015 1:51 PM by Pravin Takpire

    getting "//" in starting patch when starting listener and running autoconfig in 11gR2

    3043697

      Dear All,

       

      I have upgraded my one of the Test database to 11.2.0.4 successfully and configured application tier 12.1.3 for it also .

      all the services and database is running fine accept listener taking time to start.

      when I dig to the root cause I found out that it is taking "//" path after ORACLE_HOME . please check highlighted red below.

       

      [dbprod@prod64 11.2.0]$ lsnrctl start ERP64

      LSNRCTL for Linux: Version 11.2.0.4.0 - Production on 17-NOV-2015 22:33:42

      Copyright (c) 1991, 2013, Oracle.  All rights reserved.

      Starting /d01/ERP64/db/tech_st/11.2.0//bin/tnslsnr: please wait...

      TNSLSNR for Linux: Version 11.2.0.4.0 - Production
      System parameter file is /d01/ERP64/db/tech_st/11.2.0/network/admin/ERP64_prod64/listener.ora
      Log messages written to /d01/ERP64/db/tech_st/11.2.0/admin/ERP64_prod64/diag/tnslsnr/prod64/erp64/a                                  lert/log.xml
      Listening on: (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=prod64.aamal.com)(PORT=1528)))

      Connecting to (DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=prod64.aamal.com)(PORT=1528)))
      STATUS of the LISTENER
      ------------------------
      Alias                     ERP64
      Version                   TNSLSNR for Linux: Version 11.2.0.4.0 - Production
      Start Date                17-NOV-2015 22:33:42
      Uptime                    0 days 0 hr. 1 min. 15 sec
      Trace Level               off
      Security                  ON: Local OS Authentication
      SNMP                      OFF
      Listener Parameter File   /d01/ERP64/db/tech_st/11.2.0/network/admin/ERP64_prod64/listener.ora
      Listener Log File         /d01/ERP64/db/tech_st/11.2.0/admin/ERP64_prod64/diag/tnslsnr/prod64/erp64                                  /alert/log.xml
      Listening Endpoints Summary...
        (DESCRIPTION=(ADDRESS=(PROTOCOL=tcp)(HOST=prod64.aamal.com)(PORT=1528)))
      Services Summary...
      Service "ERP64" has 1 instance(s).
        Instance "ERP64", status UNKNOWN, has 1 handler(s) for this service...
      The command completed successfully
      [dbprod@prod64 11.2.0]$ lsnrctl status ERP64

       

      out from autoconfig --------------------------

      [dbprod@prod64 ERP64_prod64]$ ./adautocfg.sh
      Enter the APPS user password:
      The log file for this session is located at: /d01/ERP64/db/tech_st/11.2.0//appsutil/log/ERP64_prod64/11180123/adconfig.log

      AutoConfig is configuring the Database environment...

      AutoConfig will consider the custom templates if present.
              Using ORACLE_HOME location : /d01/ERP64/db/tech_st/11.2.0/
              Classpath                   : :/d01/ERP64/db/tech_st/11.2.0//jdbc/lib/ojdbc5.jar:/d01/ERP64/db/tech_st/11.2.0/appsutil/java/xmlparserv2.jar:/d01/ERP64/db/tech_st/11.2.0//appsutil/java:/d01/ERP64/db/tech_st/11.2.0//jlib/netcfg.jar:/d01/ERP64/db/tech_st/11.2.0//jlib/ldapjclnt11.jar

              Using Context file          : /d01/ERP64/db/tech_st/11.2.0/appsutil/ERP64_prod64.xml

      Context Value Management will now update the Context file

              Updating Context file...COMPLETED

              Attempting upload of Context file and templates to database...COMPLETED

      Updating rdbms version in Context file to db112
      Updating rdbms type in Context file to 64 bits
      Configuring templates from ORACLE_HOME ...

      AutoConfig completed successfully.
      [dbprod@prod64 ERP64_prod64]$

       

      Please help me out how to get rid "//" from the path.

      looking forward to here from you soon.

      Regards

      Wahid