0 Replies Latest reply on Nov 24, 2015 7:07 PM by danbou

    SQLcl APEX Export command throwing error

    danbou

      Hello All,

       

      I am testing out the different functionality of SQLcl and have run into the following error when trying to run the command 'apex export 114' (114 being one of my app IDs):

       

      nov. 24, 2015 11:54:57 AM oracle.dbtools.raptor.newscriptrunner.ScriptExecutor run

      SEVERE: java.lang.String.substring(Unknown Source)

      java.lang.StringIndexOutOfBoundsException: String index out of range: -1

              at java.lang.String.substring(Unknown Source)

              at oracle.dbtools.raptor.newscriptrunner.commands.ApexCmd.getDDL(ApexCmd.java:135)

              at oracle.dbtools.raptor.newscriptrunner.commands.ApexCmd.handleEvent(ApexCmd.java:93)

              at oracle.dbtools.raptor.newscriptrunner.CommandRegistry.fireListeners(CommandRegistry.java:384)

              at oracle.dbtools.raptor.newscriptrunner.ScriptRunner.run(ScriptRunner.java:197)

              at oracle.dbtools.raptor.newscriptrunner.ScriptExecutor.run(ScriptExecutor.java:286)

              at oracle.dbtools.raptor.newscriptrunner.ScriptExecutor.run(ScriptExecutor.java:191)

              at oracle.dbtools.raptor.scriptrunner.cmdline.SqlCli.process(SqlCli.java:255)

              at oracle.dbtools.raptor.scriptrunner.cmdline.SqlCli.processLine(SqlCli.java:261)

              at oracle.dbtools.raptor.scriptrunner.cmdline.SqlCli.startSQLPlus(SqlCli.java:737)

              at oracle.dbtools.raptor.scriptrunner.cmdline.SqlCli.main(SqlCli.java:307)

       

      I am running the tool on my Windows 10 machine connected to one of our dev database servers as sys (but also tried with other users/schemas with same result).

      Am I using the command wrong or is this a bug?

       

      My Java :

      java version "1.8.0_65"

      Java(TM) SE Runtime Environment (build 1.8.0_65-b17)

      Java HotSpot(TM) 64-Bit Server VM (build 25.65-b01, mixed mode)

       

      Database :

      Oracle Database 11g Enterprise Edition Release 11.2.0.4.0 - 64bit Production

       

      Apex :

      Application Express 4.2.6.00.03
      Any help or insight is appreicated.
      Thank you,
      Daniel