14 Replies Latest reply on Dec 16, 2015 12:21 PM by Beauty_and_dBest

    Cloning R12.2.4

    Beauty_and_dBest

      Hi All,

       

      EBS R12.2.4

      RHEL6

       

      I really can not perfect my cloning skills

      I have been cloning this R12.2.4 many times and they still throws different error in difference scenario.

      Right now I get the following error on the appsTier:

       

      #############################################################

      Started ApplyAppsTier at Wed Dec 16 16:19:20 PHT 2015

      Version:

              ApplyAppsTier.java      :       120.11.12020000.6

      #############################################################

      START: Creating the FMW Home from ApplyAppsTier

      FMW JDK version in use: 1.7.0_67

       

      START: Creating FMW Home.

      Running /home/appprod/PROD/fs1/EBSapps/comn/clone/FMW/pasteBinary.sh -javaHome /home/appprod/PROD/fs1/EBSapps/comn/util/jdk64 -al /home/appprod/PROD/fs1/EBSapps/comn/clone/FMW/FMW_Home.jar -tl /home/appprod/PROD/fs1/FMW_Home -invPtrLoc /etc/oraInst.loc -ldl /home/appprod/PROD/fs1/inst/apps/PROD_prodapp/admin/log/clone/fmwT2PApply -silent true -debug true -executeSysPrereqs false

      Script Executed in 302407 milliseconds, returning status 255

      ERROR: Script failed, exit code 255

      ~

       

       

      Please help....

       

      Thanks a lot,

      jc

        • 1. Re: Cloning R12.2.4
          Beauty_and_dBest

          I check google and I do the following:

           

          # chmod -R 777    /tmp    /var/tmp     /usr/tmp

          # rm /tmp/.ovdlock.tmp

           

          But still same error:

          • 2. Re: Cloning R12.2.4
            Pravin Takpire

            Can you paste contents of log files

            FSCloneApplyAppsTier_[timestamp].log

            Also check the note Timeout Error Encountered for pasteBinary.sh While Running "adop phase=fs_clone" (Doc ID 1599424.1)

            regards

            Pravin

            1 person found this helpful
            • 3. Re: Cloning R12.2.4
              Hussein Sawwan-Oracle

              Jc,

               

              This is not sufficient, we should find more details about the error in the logs.

               

              $INST_TOP/admin/log/clone/run

              $INST_TOP/admin/log/clone/patch

               

              I assume you didn't copy FMW home from source to target, right? -- 12.2.X Rapid Clone fails with error "Exiting cloning as FMW Home already exists." (Doc ID 1900583.1)

               

              Thanks,

              Hussein

              1 person found this helpful
              • 4. Re: Cloning R12.2.4
                Beauty_and_dBest

                Thanks Pravin,

                 

                Are you referring to this file? >  /home/appprod/PROD/fs1/inst/apps/PROD_prodapp/admin/log/clone/ApplyAppsTier_12161640.log

                That is the one I paste on the first page

                • 5. Re: Cloning R12.2.4
                  Hussein Sawwan-Oracle

                  Jenna_C wrote:

                   

                  Thanks Pravin,

                   

                  Are you referring to this file? >  /home/appprod/PROD/fs1/inst/apps/PROD_prodapp/admin/log/clone/ApplyAppsTier_12161640.log

                  That is the one I paste on the first page

                   

                  Any other logs under /home/appprod/PROD/fs1/inst/apps/PROD_prodapp/admin/log/clone/fmwT2PApply?

                   

                  Thanks,

                  Hussein

                  1 person found this helpful
                  • 6. Re: Cloning R12.2.4
                    Pravin Takpire

                    There would be many other logfiles under directory

                    /home/appprod/PROD/fs1/inst/apps/PROD_prodapp/admin/log/clone

                    check all those

                    regard

                    Pravin

                    1 person found this helpful
                    • 7. Re: Cloning R12.2.4
                      Beauty_and_dBest

                      Thanks hussein,

                       

                      But this is not my error *** Exiting cloning as FMW Home already exists ***

                      Because I cleaned up my directories using:

                      rm -rf    /home/appprod/PROD/fs1/FMW_Home

                      rm -rf    /home/appprod/PROD/fs1/inst

                      rm -rf    /home/appprod/PROD/fs2/*

                      rm -rf    /home/appprod/PROD/fs_ne/*

                      I only left > /home/appprod/PROD/fs1/EBSapps

                       

                       

                      My error is >

                      Script Executed in 302407 milliseconds, returning status 255

                      ERROR: Script failed, exit code 255

                      • 8. Re: Cloning R12.2.4
                        Pravin Takpire
                        1 person found this helpful
                        • 9. Re: Cloning R12.2.4
                          Beauty_and_dBest

                          Hi Hussein, Pravin and ALL,

                           

                          I found this error:

                          ==============

                          SEVERE : Dec 16, 2015 4:45:10 PM - ERROR - CLONE-20218   Cloning is not successful.

                          SEVERE : Dec 16, 2015 4:45:10 PM - CAUSE - CLONE-20218   An internal operation failed.

                          SEVERE : Dec 16, 2015 4:45:10 PM - ACTION - CLONE-20218   Provide the clone log and error file for investigation.

                          java.lang.Exception: Invalid Oracle home as its inventory pointer file /home/appprod/PROD/fs1/FMW_Home/oracle_common/oraInst.loc has invalid entry for Oracle inventory.

                                  at oracle.as.clone.util.OracleHomeDepRefUtil.setInvPtrLocInInventoryManager(OracleHomeDepRefUtil.java:327)

                                  at oracle.as.clone.util.OracleHomeDepRefUtil.backupAndSetInvPtrLocBeforeInstallEngineInvoke(OracleHomeDepRefUtil.java:269)

                                  at oracle.as.clone.util.OracleHomeDepRefUtil.preSetupBeforeInstallEngineInvoke(OracleHomeDepRefUtil.java:207)

                                  at oracle.as.clone.util.OracleHomeDepRefUtil.setOHProperties(OracleHomeDepRefUtil.java:465)

                                  at oracle.as.clone.util.OracleHomeDepRefUtil.setOracleHomeProperties(OracleHomeDepRefUtil.java:424)

                                  at oracle.as.clone.mwhome.cloner.OracleHomeApplyCloner.updateOracleHomeInfo(OracleHomeApplyCloner.java:1904)

                                  at oracle.as.clone.mwhome.cloner.NormalOracleHomeApplyCloner.doPostApplyClone(NormalOracleHomeApplyCloner.java:127)

                                  at oracle.as.clone.request.ApplyCloneRequest.performFirstPostoperation(ApplyCloneRequest.java:248)

                                  at oracle.as.clone.request.ApplyCloneRequest.applyArchive(ApplyCloneRequest.java:219)

                                  at oracle.as.clone.request.ApplyCloneRequest._clone(ApplyCloneRequest.java:69)

                                  at oracle.as.clone.process.CloningExecutionProcess.execute(CloningExecutionProcess.java:131)

                                  at oracle.as.clone.process.CloningExecutionProcess.execute(CloningExecutionProcess.java:114)

                                  at oracle.as.clone.client.CloningClient.executeT2PCommand(CloningClient.java:238)

                                  at oracle.as.clone.client.CloningClient.main(CloningClient.java:115)

                          SEVERE : Invalid Oracle home as its inventory pointer file /home/appprod/PROD/fs1/FMW_Home/oracle_common/oraInst.loc has invalid entry for Oracle inventory.

                          FINE : Dec 16, 2015 4:45:10 PM - [OracleHomeDepRefUtil:setInvPtrLocInInventoryManager] From commandLine, inventory pointer file /etc/oraInst.loc , Oracle inventory location is = /home/oraInventory

                          FINE : Dec 16, 2015 4:45:10 PM - [OracleHomeDepRefUtil:setInvPtrLocInInventoryManager] From inventory pointer file /home/appprod/PROD/fs1/FMW_Home/oracle_common/oraInst.loc , Oracle inventory location is = /u01/install/oraInventory

                          FINE : Dec 16, 2015 4:45:10 PM - CLONE-22042   Path represented by "/u01/install/oraInventory" did not exist.

                          FINE : Dec 16, 2015 4:45:10 PM - [JavaUtilForCloning:restoreJavaLibraryPath] Restoring java library path to original value /home/appprod/PROD/fs1/EBSapps/comn/clone/oui/lib/linux:/usr/java/packages/lib/amd64:/usr/lib64:/lib64:/lib:/usr/lib

                          ~

                           

                          I can not understand why it is invalid? and my inventory pointing to other location?

                           

                          I created my inventory as:

                          # vi /etc/oraInst.loc

                          inventory_loc=/home/oraInventory

                          inst_group=dba

                          # chown appprod.dba /etc/oraInst.loc

                          # chmod 664 /etc/oraInst.loc

                          # mkdir -p /home/oraInventory

                          # chown -R appprod.dba /home/oraInventory

                          # chmod -R 664  /home/oraInventory

                           

                           

                          Please help...

                           

                          Thanks,

                          • 10. Re: Cloning R12.2.4
                            Hussein Sawwan-Oracle

                            What does /home/appprod/PROD/fs1/FMW_Home/oracle_common/oraInst.loc file contain? Is the entry in this file valid?

                             

                            Also, please confirm you didn't copy FMW home.

                             

                            Thanks,

                            Hussein

                            1 person found this helpful
                            • 11. Re: Cloning R12.2.4
                              Hussein Sawwan-Oracle

                              Jenna_C wrote:

                               

                              Thanks hussein,

                               

                              But this is not my error *** Exiting cloning as FMW Home already exists ***

                              Because I cleaned up my directories using:

                              rm -rf    /home/appprod/PROD/fs1/FMW_Home

                              rm -rf    /home/appprod/PROD/fs1/inst

                              rm -rf    /home/appprod/PROD/fs2/*

                              rm -rf    /home/appprod/PROD/fs_ne/*

                              I only left > /home/appprod/PROD/fs1/EBSapps

                               

                               

                              My error is >

                              Script Executed in 302407 milliseconds, returning status 255

                              ERROR: Script failed, exit code 255

                               

                              Jc,

                               

                              You need to copy certain files/directories. Please see "Copy the application tier file system from the Source "Run Edition File System" to the Target "Run Edition File System" in (Cloning Oracle E-Business Suite Release 12.2 with Rapid Clone (Doc ID 1383621.1)).

                               

                              Once you copy the correct files/directories your clone will work -- Please read the doc!

                               

                              Thanks,

                              Hussein

                              1 person found this helpful
                              • 12. Re: Cloning R12.2.4
                                Beauty_and_dBest

                                Thanks hussein,

                                 

                                Yeah I copied the file. But my source is /u01/install/PROD, then my target ins now /home/appprod/PROD

                                Maybe I just used the default oracle inventory and have not created my own

                                But I did not know which one if it had not shown in the error?

                                 

                                Issue is now resolved. mislocated oraInventory.loc

                                 

                                Thanks ALL!!!

                                • 13. Re: Cloning R12.2.4
                                  Beauty_and_dBest

                                  Hi Hussein, Pravin, and ALL,

                                   

                                  Issue on fs1 (run) cloning was resolved, but when I run again on fs2 (patch) I got another error

                                   

                                  Log file located at /home/appprod/PROD/fs2/inst/apps/PROD_prodapp/admin/log/clone/ApplyAppsTier_12161902.log

                                    |     50% completed

                                  ERROR while running Apply...

                                  Wed Dec 16 19:18:16 2015

                                   

                                  Enabling EBS_LOGON Trigger...

                                   

                                  SEVERE : Dec 16, 2015 7:18:15 PM - ERROR - CLONE-20237   Restoring the sourceid "J2EECOMPONENT@EBS_domain_EBSDB" has failed.

                                  SEVERE : Dec 16, 2015 7:18:15 PM - CAUSE - CLONE-20237   An internal operation failed.

                                  SEVERE : Dec 16, 2015 7:18:15 PM - ACTION - CLONE-20237   Check the clone log and error file for more details.

                                  SEVERE : Dec 16, 2015 7:18:15 PM - ERROR - CLONE-20218   Cloning is not successful.

                                  SEVERE : Dec 16, 2015 7:18:15 PM - CAUSE - CLONE-20218   An internal operation failed.

                                  SEVERE : Dec 16, 2015 7:18:15 PM - ACTION - CLONE-20218   Provide the clone log and error file for investigation.

                                  ~

                                  ~

                                  Warning:  org.apache.xerces.parsers.SAXParser: Property 'http://www.oracle.com/xml/jaxp/properties/entityExpansionLimit' is not recognized.

                                  Warning:  org.apache.xerces.parsers.SAXParser: Property 'http://javax.xml.XMLConstants/property/accessExternalDTD' is not recognized.

                                  Warning:  org.apache.xerces.parsers.SAXParser: Property 'http://www.oracle.com/xml/jaxp/properties/entityExpansionLimit' is not recognized.

                                  Error: cd() failed. Do dumpStack() to see details.

                                  SSL setting failed

                                  Error: cd() failed. Do dumpStack() to see details.

                                  SSL setting failed

                                  Error: cd() failed. Do dumpStack() to see details.

                                  SSL setting failed

                                  Error: cd() failed. Do dumpStack() to see details.

                                  SSL setting failed

                                  Configuring the Server -  AdminServer

                                  Configuring the Server -  oacore_server1

                                  Configuring the Server -  forms_server1

                                  Configuring the Server -  oafm_server1

                                  Configuring the Server -  forms-c4ws_server1

                                  Configuring the Machine -  prodapp

                                  Configuring the Cluster -  oafm_cluster1

                                  Configuring the Cluster -  forms_cluster1

                                   

                                   

                                  Please help....

                                   

                                  Thanks,

                                  • 14. Re: Cloning R12.2.4
                                    Beauty_and_dBest

                                    Ok issue resolved, I just rerun the process and it got okay 2nd time, sooo weird a cloning process